summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Matthijs <axxo@gentoo.org>2006-05-02 13:54:20 +0000
committerThomas Matthijs <axxo@gentoo.org>2006-05-02 13:54:20 +0000
commit4e66b29473e82daa5a9174b9395ae689ab50b52c (patch)
treeaffd0e08228dc2de5e96d9fccee62d2740f7b800 /dev-java
parentUnmask xine-lib. (diff)
downloadgentoo-2-4e66b29473e82daa5a9174b9395ae689ab50b52c.tar.gz
gentoo-2-4e66b29473e82daa5a9174b9395ae689ab50b52c.tar.bz2
gentoo-2-4e66b29473e82daa5a9174b9395ae689ab50b52c.zip
Fix needed files not being included in jar. Directly to stable since current stable doesnt work
(Portage version: 2.1_pre10-r2)
Diffstat (limited to 'dev-java')
-rw-r--r--dev-java/jdictrayapi/ChangeLog9
-rw-r--r--dev-java/jdictrayapi/files/digest-jdictrayapi-0.9.1-r13
-rw-r--r--dev-java/jdictrayapi/jdictrayapi-0.9.1-r1.ebuild55
3 files changed, 66 insertions, 1 deletions
diff --git a/dev-java/jdictrayapi/ChangeLog b/dev-java/jdictrayapi/ChangeLog
index c279d0316978..14f55ee7ae4d 100644
--- a/dev-java/jdictrayapi/ChangeLog
+++ b/dev-java/jdictrayapi/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-java/jdictrayapi
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/jdictrayapi/ChangeLog,v 1.6 2006/04/27 13:12:37 axxo Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/jdictrayapi/ChangeLog,v 1.7 2006/05/02 13:54:20 axxo Exp $
+
+*jdictrayapi-0.9.1-r1 (02 May 2006)
+
+ 02 May 2006; Thomas Matthijs <axxo@gentoo.org>
+ +jdictrayapi-0.9.1-r1.ebuild:
+ Fix needed files not being included in jar. Directly to stable since current
+ stable doesnt work
27 Apr 2006; Thomas Matthijs <axxo@gentoo.org> jdictrayapi-0.9.1.ebuild:
dont install CVS files along with the examples
diff --git a/dev-java/jdictrayapi/files/digest-jdictrayapi-0.9.1-r1 b/dev-java/jdictrayapi/files/digest-jdictrayapi-0.9.1-r1
new file mode 100644
index 000000000000..7729f899f895
--- /dev/null
+++ b/dev-java/jdictrayapi/files/digest-jdictrayapi-0.9.1-r1
@@ -0,0 +1,3 @@
+MD5 0153e414413ddf4bea8cc9b8a4d81bb9 jdic-0.9.1-src.zip 946706
+RMD160 29193141fc0c2f4592bfa41fac7f73795d189e6d jdic-0.9.1-src.zip 946706
+SHA256 2b455c657c815650dd42b9a08714d561419b8da423009c710f046aadbe83e69b jdic-0.9.1-src.zip 946706
diff --git a/dev-java/jdictrayapi/jdictrayapi-0.9.1-r1.ebuild b/dev-java/jdictrayapi/jdictrayapi-0.9.1-r1.ebuild
new file mode 100644
index 000000000000..cc4c646f2f09
--- /dev/null
+++ b/dev-java/jdictrayapi/jdictrayapi-0.9.1-r1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/jdictrayapi/jdictrayapi-0.9.1-r1.ebuild,v 1.1 2006/05/02 13:54:20 axxo Exp $
+
+inherit eutils java-pkg
+
+MY_PN="jdic"
+MY_P=${MY_PN}-${PV}
+DESCRIPTION="The JDesktop Integration Components (JDIC) tray icon API"
+HOMEPAGE="https://jdic.dev.java.net/"
+SRC_URI="https://jdic.dev.java.net/files/documents/880/16466/${MY_P}-src.zip"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="doc examples jikes source"
+
+DEPEND=">=virtual/jdk-1.4
+ dev-java/ant-core
+ app-arch/unzip
+ jikes? ( >=dev-java/jikes-1.21 )
+ source? ( app-arch/zip )"
+RDEPEND=">=virtual/jre-1.4"
+
+S="${WORKDIR}/${MY_P}-src/${MY_PN}"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ epatch ${FILESDIR}/0.8.7-gentoo.patch
+ find -type d -name CVS -exec rm -r {} \; >/dev/null 2>&1
+}
+
+src_compile() {
+ local antflags="buildunixjar buildunixjni_tray"
+ use doc && antflags="${antflags} docs"
+ use jikes && antflags="${antflags} -Dbuild.compiler=jikes"
+ ant ${antflags} || die "ant build failed"
+}
+
+src_install() {
+ cd ${WORKDIR}/${MY_P}-${PV}-src/
+
+ cd ${S}/dist/linux
+ java-pkg_dojar jdic.jar
+ java-pkg_doso libtray.so
+
+ use doc && java-pkg_dohtml -r docs/*
+ use source && java-pkg_dosrc ${S}/src/share/classes/* ${S}/src/unix/classes/*
+ if use examples; then
+ dodir /usr/share/doc/${PF}/examples
+ cp -r ${S}/demo/* ${D}/usr/share/doc/${PF}/examples
+ fi
+}