summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSerkan Kaba <serkan@gentoo.org>2009-02-05 20:58:56 +0000
committerSerkan Kaba <serkan@gentoo.org>2009-02-05 20:58:56 +0000
commit5da0fe6e215c976e77b2d21969bcaa4b33b3be48 (patch)
tree44d78a8493be4c1270ebe99427f3b4ca2d331300 /dev-java
parentDont disable traceroute as we don't have any working ebuild for it otherwise... (diff)
downloadgentoo-2-5da0fe6e215c976e77b2d21969bcaa4b33b3be48.tar.gz
gentoo-2-5da0fe6e215c976e77b2d21969bcaa4b33b3be48.tar.bz2
gentoo-2-5da0fe6e215c976e77b2d21969bcaa4b33b3be48.zip
Version bump that finally adds 64-bit nsplugin which works with Firefox 3. Visit http://java.sun.com/javase/6/webnotes/6u12.html for more info.
(Portage version: 2.2_rc23/cvs/Linux x86_64)
Diffstat (limited to 'dev-java')
-rw-r--r--dev-java/sun-jdk/ChangeLog8
-rw-r--r--dev-java/sun-jdk/sun-jdk-1.6.0.12.ebuild158
2 files changed, 165 insertions, 1 deletions
diff --git a/dev-java/sun-jdk/ChangeLog b/dev-java/sun-jdk/ChangeLog
index 6855728573db..b5cd44f06e7a 100644
--- a/dev-java/sun-jdk/ChangeLog
+++ b/dev-java/sun-jdk/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-java/sun-jdk
# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/sun-jdk/ChangeLog,v 1.251 2009/01/15 12:16:39 betelgeuse Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/sun-jdk/ChangeLog,v 1.252 2009/02/05 20:58:56 serkan Exp $
+
+*sun-jdk-1.6.0.12 (05 Feb 2009)
+
+ 05 Feb 2009; Serkan Kaba <serkan@gentoo.org> +sun-jdk-1.6.0.12.ebuild:
+ Version bump that finally adds 64-bit nsplugin which works with Firefox 3.
+ Visit http://java.sun.com/javase/6/webnotes/6u12.html for more info.
15 Jan 2009; Petteri Räty <betelgeuse@gentoo.org>
-sun-jdk-1.4.2.18.ebuild, -sun-jdk-1.5.0.16.ebuild,
diff --git a/dev-java/sun-jdk/sun-jdk-1.6.0.12.ebuild b/dev-java/sun-jdk/sun-jdk-1.6.0.12.ebuild
new file mode 100644
index 000000000000..08c98487c083
--- /dev/null
+++ b/dev-java/sun-jdk/sun-jdk-1.6.0.12.ebuild
@@ -0,0 +1,158 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/sun-jdk/sun-jdk-1.6.0.12.ebuild,v 1.1 2009/02/05 20:58:56 serkan Exp $
+
+inherit versionator java-vm-2 eutils pax-utils
+
+UPDATE="$(get_version_component_range 4)"
+UPDATE="${UPDATE#0}"
+MY_PV="$(get_version_component_range 2)u${UPDATE}"
+X86_AT="jdk-${MY_PV}-dlj-linux-i586.bin"
+AMD64_AT="jdk-${MY_PV}-dlj-linux-amd64.bin"
+
+DESCRIPTION="Sun's J2SE Development Kit, version ${PV}"
+HOMEPAGE="http://java.sun.com/javase/6/"
+URL_BASE="http://download.java.net/dlj/binaries"
+SRC_URI="x86? ( ${URL_BASE}/${X86_AT} )
+ amd64? ( ${URL_BASE}/${AMD64_AT} )"
+SLOT="1.6"
+LICENSE="dlj-1.1"
+KEYWORDS="~amd64 ~x86"
+RESTRICT="strip"
+IUSE="X alsa doc examples jce nsplugin odbc"
+
+QA_TEXTRELS_x86="opt/${P}/jre/lib/i386/motif21/libmawt.so
+ opt/${P}/jre/lib/i386/libdeploy.so
+ opt/${P}/jre/lib/i386/client/libjvm.so
+ opt/${P}/jre/lib/i386/server/libjvm.so"
+
+DEPEND="jce? ( =dev-java/sun-jce-bin-1.6.0* )"
+RDEPEND="doc? ( =dev-java/java-sdk-docs-1.6.0* )
+ sys-libs/glibc
+ alsa? ( media-libs/alsa-lib )
+ X? (
+ x11-libs/libXext
+ x11-libs/libXi
+ x11-libs/libXp
+ x11-libs/libXtst
+ amd64? ( x11-libs/libXt )
+ x11-libs/libX11
+ )
+ odbc? ( dev-db/unixODBC )"
+
+JAVA_PROVIDE="jdbc-stdext jdbc-rowset"
+
+S="${WORKDIR}/jdk$(replace_version_separator 3 _)"
+
+src_unpack() {
+ sh "${DISTDIR}"/${A} --accept-license --unpack || die "Failed to unpack"
+}
+
+src_compile() {
+ # Set PaX markings on all JDK/JRE executables to allow code-generation on
+ # the heap by the JIT compiler. This needs to be done before CDS - #215225
+ pax-mark m $(list-paxables "${S}"{,/jre}/bin/*)
+
+ # see bug #207282
+ if use x86; then
+ einfo "Creating the Class Data Sharing archives"
+ "${S}"/bin/java -client -Xshare:dump || die
+ "${S}"/bin/java -server -Xshare:dump || die
+ fi
+}
+
+src_install() {
+ local dirs="bin include jre lib man"
+
+ dodir /opt/${P}
+
+ cp -pPR $dirs "${D}/opt/${P}/" || die "failed to copy"
+ dodoc COPYRIGHT || die
+ dohtml README.html || die
+
+ cp -pP src.zip "${D}/opt/${P}/" || die
+
+ if use examples; then
+ cp -pPR demo sample "${D}/opt/${P}/" || die
+ fi
+
+ if use jce; then
+ cd "${D}/opt/${P}/jre/lib/security"
+ dodir /opt/${P}/jre/lib/security/strong-jce
+ mv "${D}"/opt/${P}/jre/lib/security/US_export_policy.jar \
+ "${D}"/opt/${P}/jre/lib/security/strong-jce || die
+ mv "${D}"/opt/${P}/jre/lib/security/local_policy.jar \
+ "${D}"/opt/${P}/jre/lib/security/strong-jce || die
+ dosym /opt/sun-jce-bin-1.6.0/jre/lib/security/unlimited-jce/US_export_policy.jar /opt/${P}/jre/lib/security/
+ dosym /opt/sun-jce-bin-1.6.0/jre/lib/security/unlimited-jce/local_policy.jar /opt/${P}/jre/lib/security/
+ fi
+
+ if use nsplugin; then
+ local plugin_dir="ns7-gcc29"
+ if has_version '>=sys-devel/gcc-3' ; then
+ plugin_dir="ns7"
+ fi
+
+ if use x86 ; then
+ install_mozilla_plugin /opt/${P}/jre/plugin/i386/$plugin_dir/libjavaplugin_oji.so
+ install_mozilla_plugin /opt/${P}/jre/lib/i386/libnpjp2.so plugin2
+ else
+ install_mozilla_plugin /opt/${P}/jre/lib/amd64/libnpjp2.so
+ fi
+ fi
+
+ # create dir for system preferences
+ dodir /opt/${P}/jre/.systemPrefs
+ # Create files used as storage for system preferences.
+ touch "${D}"/opt/${P}/jre/.systemPrefs/.system.lock
+ chmod 644 "${D}"/opt/${P}/jre/.systemPrefs/.system.lock
+ touch "${D}"/opt/${P}/jre/.systemPrefs/.systemRootModFile
+ chmod 644 "${D}"/opt/${P}/jre/.systemPrefs/.systemRootModFile
+
+ if [[ -f "${D}"/opt/${P}/jre/plugin/desktop/sun_java.desktop ]]; then
+ # install control panel for Gnome/KDE
+ # The jre also installs these so make sure that they do not have the same
+ # Name
+ sed -e "s/\(Name=\)Java/\1 Java Control Panel for Sun JDK ${SLOT}/" \
+ -e "s#Exec=.*#Exec=/opt/${P}/jre/bin/ControlPanel#" \
+ -e "s#Icon=.*#Icon=/opt/${P}/jre/plugin/desktop/sun_java.png#" \
+ "${D}"/opt/${P}/jre/plugin/desktop/sun_java.desktop > \
+ "${T}"/sun_jdk-${SLOT}.desktop
+
+ domenu "${T}"/sun_jdk-${SLOT}.desktop
+ fi
+
+ # bug #56444
+ insinto /opt/${P}/jre/lib/
+ newins "${FILESDIR}"/fontconfig.Gentoo.properties fontconfig.properties
+
+ set_java_env
+ java-vm_revdep-mask
+}
+
+pkg_postinst() {
+ # Set as default VM if none exists
+ java-vm-2_pkg_postinst
+
+ if use x86 && use nsplugin; then
+ elog
+ elog "Two variants of the nsplugin are available via eselect java-nsplugin:"
+ elog "${VMHANDLE} and ${VMHANDLE}-plugin2 (the Next-Generation Plug-In) "
+ ewarn "Note that the ${VMHANDLE}-plugin2 works only in Firefox 3!"
+ elog "For more info see https://jdk6.dev.java.net/plugin2/"
+ elog
+ fi
+
+ if use amd64 && use nsplugin; then
+ elog
+ elog "This version finally brings a browser plugin for amd64"
+ elog "It is the so-called Next-Generation Plug-In (plugin2)"
+ elog "Use eselect java-nsplugin to select it (${VMHANDLE})."
+ ewarn "Note that it works only in Firefox 3 or newer browsers!"
+ elog "For more info see https://jdk6.dev.java.net/plugin2/"
+ elog
+ fi
+
+ elog "Please reinstall eclipse-sdk if you have it installed and want"
+ elog "workaround for bug #215150."
+}