summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoshua Nichols <nichoj@gentoo.org>2007-01-05 05:08:21 +0000
committerJoshua Nichols <nichoj@gentoo.org>2007-01-05 05:08:21 +0000
commit632d23dee3fcf1807a6d8cef7fcdbff2eb59dc2b (patch)
treeafc2169bc0ca40e19063e10e2214c6142b11a307 /dev-java
parentfix debug codepaths (diff)
downloadgentoo-2-632d23dee3fcf1807a6d8cef7fcdbff2eb59dc2b.tar.gz
gentoo-2-632d23dee3fcf1807a6d8cef7fcdbff2eb59dc2b.tar.bz2
gentoo-2-632d23dee3fcf1807a6d8cef7fcdbff2eb59dc2b.zip
Version bump for final release.
(Portage version: 2.1.2_rc4-r4)
Diffstat (limited to 'dev-java')
-rw-r--r--dev-java/groovy/ChangeLog10
-rw-r--r--dev-java/groovy/files/build.xml-1.0136
-rw-r--r--dev-java/groovy/files/digest-groovy-1.03
-rw-r--r--dev-java/groovy/files/groovy-1.0-compiler-exit-code.patch11
-rw-r--r--dev-java/groovy/groovy-1.0.ebuild104
5 files changed, 262 insertions, 2 deletions
diff --git a/dev-java/groovy/ChangeLog b/dev-java/groovy/ChangeLog
index 0ee371929ecf..b98ee778c2b3 100644
--- a/dev-java/groovy/ChangeLog
+++ b/dev-java/groovy/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-java/groovy
-# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/groovy/ChangeLog,v 1.18 2006/12/30 20:46:42 caster Exp $
+# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/groovy/ChangeLog,v 1.19 2007/01/05 05:08:21 nichoj Exp $
+
+*groovy-1.0 (05 Jan 2007)
+
+ 05 Jan 2007; Joshua Nichols <nichoj@gentoo.org> +files/build.xml-1.0,
+ +files/groovy-1.0-compiler-exit-code.patch, +groovy-1.0.ebuild:
+ Version bump for final release.
30 Dec 2006; Vlastimil Babka <caster@gentoo.org> files/build.xml-1.0_rc01,
groovy-1.0_rc01.ebuild:
diff --git a/dev-java/groovy/files/build.xml-1.0 b/dev-java/groovy/files/build.xml-1.0
new file mode 100644
index 000000000000..1111b90d9f3f
--- /dev/null
+++ b/dev-java/groovy/files/build.xml-1.0
@@ -0,0 +1,136 @@
+<?xml version="1.0" encoding="UTF-8"?>
+
+<!--build.xml generated by maven from project.xml version 1.0
+ on date January 4 2007, time 2343-->
+<project default="jar" name="groovy" basedir=".">
+ <!--Load local and user build preferences-->
+ <property file="build.properties"></property>
+ <property file="${user.home}/build.properties"></property>
+ <!--Build properties-->
+ <property name="defaulttargetdir" value="${basedir}/target"></property>
+ <property name="libdir" value="${user.home}/.maven/repository"></property>
+ <property name="classesdir" value="${basedir}/target/classes"></property>
+ <property name="testclassesdir" value="${basedir}/target/test-classes"></property>
+ <property name="testreportdir" value="${basedir}/target/test-reports"></property>
+ <property name="distdir" value="${basedir}/dist"></property>
+ <property name="javadocdir" value="${basedir}/dist/docs/api"></property>
+ <property name="final.name" value="groovy-1.0"></property>
+ <property name="proxy.host" value=""></property>
+ <property name="proxy.port" value=""></property>
+ <property name="proxy.username" value=""></property>
+ <property name="proxy.password" value=""></property>
+ <path id="build.classpath">
+ <fileset dir="${libdir}" includes="**/*.jar"/>
+ </path>
+ <target name="init" description="o Initializes some properties">
+ <mkdir dir="${libdir}"></mkdir>
+ <condition property="noget">
+ <equals arg2="only" arg1="${build.sysclasspath}"></equals>
+ </condition>
+ <!--Test if JUNIT is present in ANT classpath-->
+ <available property="Junit.present" classname="junit.framework.Test"></available>
+ <!--Test if user defined a proxy-->
+ <condition property="useProxy">
+ <and>
+ <isset property="proxy.host"></isset>
+ <not>
+ <equals trim="true" arg2="" arg1="${proxy.host}"></equals>
+ </not>
+ </and>
+ </condition>
+ </target>
+ <target name="compile" description="o Compile the code" depends="">
+ <mkdir dir="${classesdir}"></mkdir>
+ <javac destdir="${classesdir}" deprecation="true" debug="true" optimize="false" excludes="**/package.html">
+ <src>
+ <pathelement location="${basedir}/src/main"></pathelement>
+ </src>
+ <classpath refid="build.classpath"></classpath>
+ </javac>
+ <copy todir="${classesdir}">
+ <fileset dir="${basedir}/src/main">
+ <include name="**/*.properties"></include>
+ <include name="**/*.xml"></include>
+ </fileset>
+ </copy>
+ </target>
+ <target name="jar" description="o Create the jar" depends="compile">
+ <jar jarfile="${defaulttargetdir}/${final.name}.jar" excludes="**/package.html" basedir="${classesdir}"></jar>
+ </target>
+ <target name="clean" description="o Clean up the generated directories">
+ <delete dir="${defaulttargetdir}"></delete>
+ <delete dir="${distdir}"></delete>
+ </target>
+ <target name="dist" description="o Create a distribution" depends="jar, javadoc">
+ <mkdir dir="dist"></mkdir>
+ <copy todir="dist">
+ <fileset dir="${defaulttargetdir}" includes="*.jar"></fileset>
+ <fileset dir="${basedir}" includes="LICENSE*, README*"></fileset>
+ </copy>
+ </target>
+ <target name="test" description="o Run the test cases" if="test.failure" depends="internal-test">
+ <fail message="There were test failures."></fail>
+ </target>
+ <target name="internal-test" depends="compile-tests">
+ <mkdir dir="${testreportdir}"></mkdir>
+ <junit dir="${basedir}" failureproperty="test.failure" printSummary="yes" fork="true" haltonerror="true">
+ <sysproperty key="basedir" value="."></sysproperty>
+ <formatter type="xml"></formatter>
+ <formatter usefile="false" type="plain"></formatter>
+ <classpath>
+ <path refid="build.classpath"></path>
+ <pathelement path="${testclassesdir}"></pathelement>
+ <pathelement path="${classesdir}"></pathelement>
+ </classpath>
+ <batchtest todir="${testreportdir}">
+ <fileset dir="${basedir}/src/test">
+ <include name="**/Uber*.*"></include>
+ <exclude name="**/SignedJarTest.*"></exclude>
+ </fileset>
+ </batchtest>
+ </junit>
+ </target>
+ <target name="junit-present" unless="Junit.present" depends="init">
+ <echo>================================= WARNING ================================</echo>
+ <echo>Junit isn't present in your ${ANT_HOME}/lib directory. Tests not executed.</echo>
+ <echo>==========================================================================</echo>
+ </target>
+ <target name="compile-tests" depends="compile">
+ <mkdir dir="${testclassesdir}"></mkdir>
+ <javac destdir="${testclassesdir}" deprecation="true" debug="true" optimize="false" excludes="**/package.html">
+ <src>
+ <pathelement location="${basedir}/src/test"></pathelement>
+ </src>
+ <classpath>
+ <path refid="build.classpath"></path>
+ <pathelement path="${classesdir}"></pathelement>
+ </classpath>
+ </javac>
+ <copy todir="${testclassesdir}">
+ <fileset dir="${basedir}/src/test">
+ <include name="**/*.properties"></include>
+ <include name="**/*.xml"></include>
+ <include name="**/*.xsd"></include>
+ </fileset>
+ </copy>
+ <copy todir="${testclassesdir}">
+ <fileset dir="${basedir}/src/test">
+ <include name="**/*.*"></include>
+ <include name="**/groovy*"></include>
+ </fileset>
+ </copy>
+ </target>
+ <target name="javadoc" description="o Generate javadoc" depends="">
+ <mkdir dir="${javadocdir}"></mkdir>
+ <tstamp>
+ <format pattern="2003-yyyy" property="year"></format>
+ </tstamp>
+ <property name="copyright" value="Copyright &amp;copy; The Codehaus. All Rights Reserved."></property>
+ <property name="title" value="groovy 1.0 API"></property>
+ <javadoc use="true" private="true" destdir="${javadocdir}" author="true" version="true" sourcepath="${basedir}/src/main" packagenames=".*">
+ <classpath>
+ <path refid="build.classpath"></path>
+ </classpath>
+ </javadoc>
+ </target>
+</project>
diff --git a/dev-java/groovy/files/digest-groovy-1.0 b/dev-java/groovy/files/digest-groovy-1.0
new file mode 100644
index 000000000000..36011df7d086
--- /dev/null
+++ b/dev-java/groovy/files/digest-groovy-1.0
@@ -0,0 +1,3 @@
+MD5 14d39578832e3c7a02a4d5972e5d573f groovy-1.0-src.tar.gz 966931
+RMD160 dad940d5bbe10a16686dc619a094c2cbdc0d52f1 groovy-1.0-src.tar.gz 966931
+SHA256 63d1e47d80a31567792b65dfe19653ab98ce74a6876fb05b9423b83ecc960599 groovy-1.0-src.tar.gz 966931
diff --git a/dev-java/groovy/files/groovy-1.0-compiler-exit-code.patch b/dev-java/groovy/files/groovy-1.0-compiler-exit-code.patch
new file mode 100644
index 000000000000..18c5bb55ba4e
--- /dev/null
+++ b/dev-java/groovy/files/groovy-1.0-compiler-exit-code.patch
@@ -0,0 +1,11 @@
+diff -ru groovy-1.0/src/main/org/codehaus/groovy/tools/FileSystemCompiler.java groovy-1.0-patched/src/main/org/codehaus/groovy/tools/FileSystemCompiler.java
+--- groovy-1.0/src/main/org/codehaus/groovy/tools/FileSystemCompiler.java 2007-01-02 19:17:30.000000000 -0500
++++ groovy-1.0-patched/src/main/org/codehaus/groovy/tools/FileSystemCompiler.java 2007-01-05 00:02:45.000000000 -0500
+@@ -223,6 +223,7 @@
+ catch( Throwable e )
+ {
+ new ErrorReporter( e, displayStackTraceOnError ).write( System.err );
++ System.exit(1);
+ }
+ }
+
diff --git a/dev-java/groovy/groovy-1.0.ebuild b/dev-java/groovy/groovy-1.0.ebuild
new file mode 100644
index 000000000000..2dcd827d3f20
--- /dev/null
+++ b/dev-java/groovy/groovy-1.0.ebuild
@@ -0,0 +1,104 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/groovy/groovy-1.0.ebuild,v 1.1 2007/01/05 05:08:21 nichoj Exp $
+
+inherit versionator java-pkg-2 java-ant-2
+
+MY_PV=${PV/_rc/-RC-}
+MY_P="${PN}-${MY_PV}"
+
+DESCRIPTION="Groovy is a high-level dynamic language for the JVM"
+HOMEPAGE="http://groovy.codehaus.org/"
+SRC_URI="http://dist.codehaus.org/groovy/distributions/${MY_P/JSR/jsr}-src.tar.gz"
+LICENSE="codehaus-groovy"
+SLOT="1"
+KEYWORDS="~amd64 ~x86"
+IUSE="source"
+
+COMMON_DEPS="
+ =dev-java/asm-2.2*
+ >=dev-java/antlr-2.7.5
+ >=dev-java/xerces-2.7
+ >=dev-java/ant-core-1.6.5
+ >=dev-java/xstream-1.1.1
+ >=dev-java/junit-3.8.1
+ dev-java/qdox
+ >=dev-java/commons-cli-1.0
+ >=dev-java/bsf-2.3.0_rc1
+ >=dev-java/mockobjects-0.09
+ ~dev-java/servletapi-2.4
+ dev-java/sun-jmx"
+RDEPEND=">=virtual/jre-1.4
+ ${COMMON_DEPS}"
+# FIXME doesn't compile with 1.6 due to JDBC api change
+DEPEND="|| ( =virtual/jdk-1.4* =virtual/jdk-1.5* )
+ ${COMMON_DEPS}"
+
+S="${WORKDIR}/${MY_P}"
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}
+# epatch ${FILESDIR}/${P}-compiler-exit-code.patch
+
+ mkdir -p ${S}/target/lib
+
+ cd ${S}/target/lib
+ java-pkg_jar-from commons-cli-1
+ java-pkg_jar-from xerces-2
+ java-pkg_jar-from ant-core ant.jar
+ java-pkg_jar-from antlr
+ java-pkg_jar-from asm-2.2
+ java-pkg_jar-from qdox-1.6
+ java-pkg_jar-from xstream
+ java-pkg_jar-from mockobjects
+ java-pkg_jar-from junit
+ java-pkg_jar-from servletapi-2.4
+ java-pkg_jar-from bsf-2.3
+ java-pkg_jar-from sun-jmx
+
+ cd ${S}
+
+ # We use ant NOT maven. This build.xml is generated using 'maven ant', and
+ # then the following tweaks:
+ # - change build.classpath to use <fileset dir="${libdir}" includes="**/*.jar"/>
+ # instead of using each individual jar
+ # - remove get-deps from the depends of all targets. you should be able to
+ # define -Dnoget=true, but that doesn't really work
+ # - remove all the get-* targets (otherwise, the file is a bit oversized to
+ # be in files/
+ # - remove all the junit-present stuff
+ # - remove test dependency from jar target
+ cp ${FILESDIR}/build.xml-${PV} ${S}/build.xml || die "Failed to update build.xml"
+
+ cd src/main
+ # This won't compile without an incestuous relationship with radeox.
+ rm -rf org/codehaus/groovy/wiki
+}
+
+src_compile() {
+ eant jar
+
+ # need to compile .groovy files to .class files
+ cd src/main
+ java -classpath ../../target/${MY_P}.jar:$(java-pkg_getjars commons-cli-1,asm-2.2,antlr,junit,qdox-1.6) \
+ org.codehaus.groovy.tools.FileSystemCompiler \
+ $(find -name *.groovy) || die "Failed to invoke groovyc"
+
+ # add the now compiled .class files to our jar
+ jar uf ../../target/${MY_P}.jar $(find -name *.class) || die "Failed to backpatch Console*.class"
+}
+
+src_install() {
+ java-pkg_newjar target/${MY_P}.jar
+ java-pkg_dolauncher "grok" --main org.codehaus.groovy.tools.Grok
+ java-pkg_dolauncher "groovyc" --main org.codehaus.groovy.tools.FileSystemCompiler
+ java-pkg_dolauncher "groovy" --main groovy.ui.GroovyMain
+ java-pkg_dolauncher "groovysh" --main groovy.ui.InteractiveShell
+ java-pkg_dolauncher "groovyConsole" --main groovy.ui.Console
+}
+
+src_test() {
+ eant test
+}