summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoshua Nichols <nichoj@gentoo.org>2006-10-18 03:37:56 +0000
committerJoshua Nichols <nichoj@gentoo.org>2006-10-18 03:37:56 +0000
commit7a77e1258d070320359cf396faf92f9006693e30 (patch)
tree15ad9bbad188286a801386a950dcb93c87bb7e07 /dev-java
parentStable for HPPA (bug #151762). (diff)
downloadgentoo-2-7a77e1258d070320359cf396faf92f9006693e30.tar.gz
gentoo-2-7a77e1258d070320359cf396faf92f9006693e30.tar.bz2
gentoo-2-7a77e1258d070320359cf396faf92f9006693e30.zip
Direct to stable bump. Adds a patch to improve output of java-check-environment, to help avoid stumbling blocks during an upgrade. Specifically, when checking the generation-1 system-vm, we now see if java-config-1 -L actually lists anything. If it doesn\'t, then we suggest to emerge =virtual/jdk-1.4*. Otherwise, we list possible choices (from java-config-1 -L), and prompt the user to select one.
(Portage version: 2.1.2_pre3-r4)
Diffstat (limited to 'dev-java')
-rw-r--r--dev-java/java-config-wrapper/ChangeLog14
-rw-r--r--dev-java/java-config-wrapper/files/digest-java-config-wrapper-0.12-r13
-rw-r--r--dev-java/java-config-wrapper/files/java-config-wrapper-0.12-generation_1_system_vm.patch34
-rw-r--r--dev-java/java-config-wrapper/java-config-wrapper-0.12-r1.ebuild27
4 files changed, 77 insertions, 1 deletions
diff --git a/dev-java/java-config-wrapper/ChangeLog b/dev-java/java-config-wrapper/ChangeLog
index 3c00452b57cf..5eb7be480aa7 100644
--- a/dev-java/java-config-wrapper/ChangeLog
+++ b/dev-java/java-config-wrapper/ChangeLog
@@ -1,6 +1,18 @@
# ChangeLog for dev-java/java-config-wrapper
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/java-config-wrapper/ChangeLog,v 1.23 2006/10/15 18:26:45 nichoj Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/java-config-wrapper/ChangeLog,v 1.24 2006/10/18 03:37:56 nichoj Exp $
+
+*java-config-wrapper-0.12-r1 (18 Oct 2006)
+
+ 18 Oct 2006; Joshua Nichols <nichoj@gentoo.org>
+ +files/java-config-wrapper-0.12-generation_1_system_vm.patch,
+ +java-config-wrapper-0.12-r1.ebuild:
+ Direct to stable bump. Adds a patch to improve output of
+ java-check-environment, to help avoid stumbling blocks during an upgrade.
+ Specifically, when checking the generation-1 system-vm, we now see if
+ java-config-1 -L actually lists anything. If it doesn't, then we suggest to
+ emerge =virtual/jdk-1.4*. Otherwise, we list possible choices (from
+ java-config-1 -L), and prompt the user to select one.
15 Oct 2006; Tobias Scherbaum <dertobi123@gentoo.org>
java-config-wrapper-0.12.ebuild:
diff --git a/dev-java/java-config-wrapper/files/digest-java-config-wrapper-0.12-r1 b/dev-java/java-config-wrapper/files/digest-java-config-wrapper-0.12-r1
new file mode 100644
index 000000000000..4ed577186fce
--- /dev/null
+++ b/dev-java/java-config-wrapper/files/digest-java-config-wrapper-0.12-r1
@@ -0,0 +1,3 @@
+MD5 39a073be74d730bd618e5a3d4d4b0e23 java-config-wrapper-0.12.tar.bz2 7808
+RMD160 9cfa95dc96039f051f9f7ae034d14209ca2ac180 java-config-wrapper-0.12.tar.bz2 7808
+SHA256 0c50136cc82b180258364272b24d90702760cb05b39bc239e7cb2fef01718003 java-config-wrapper-0.12.tar.bz2 7808
diff --git a/dev-java/java-config-wrapper/files/java-config-wrapper-0.12-generation_1_system_vm.patch b/dev-java/java-config-wrapper/files/java-config-wrapper-0.12-generation_1_system_vm.patch
new file mode 100644
index 000000000000..f86fe88ada79
--- /dev/null
+++ b/dev-java/java-config-wrapper/files/java-config-wrapper-0.12-generation_1_system_vm.patch
@@ -0,0 +1,34 @@
+Index: src/shell/java-check-environment
+===================================================================
+--- src/shell/java-check-environment (revision 2757)
++++ src/shell/java-check-environment (working copy)
+@@ -182,18 +182,19 @@
+ local this_result=0
+ local env="/etc/env.d/20java"
+ # Make sure a generation-1 VM is set
+- if [[ ! -f "${env}" ]]; then
++ if [[ ! -f "${env}" || -z $(java-config-1 -f) ]]; then
+ qeerror "No Generation-1 System VM is set! (no /etc/env.d/20java)"
+- qeerror "Run 'java-config-1 -L' to see a list of available VMs"
+- qeerror "Then run 'java-config-1 -S <VM choice>'"
+- qeerror "Then run 'env-update && source /etc/profile"
++ local vm_list=$(java-config-1 -L)
++ if [[ ! ${vm_list} =~ "]" ]]; then
++ qeerror "It doesn't look like java-config-1 sees any installed VMs."
++ qeerror "It is most likely because you don't have a 1.4 JDK installed"
++ qeerror "This is required for generation-1 to work properly."
++ qeerror "You will want to emerge =virtual/jdk-1.4*"
++ else
++ java-config-1 -L
++ qeerror "Choose one, and run 'java-config-1 ---set-system-vm <VM choice>'"
++ fi
+ this_result=1
+- elif [[ -z $(java-config-1 -f) ]]; then
+- qeerror "No Generation-1 System VM is set! (no java-config-1 -f output)"
+- qeerror "Run 'java-config-1 -L' to see a list of available VMs"
+- qeerror "Then run 'java-config-1 -S <VM choice>'"
+- qeerror "Then run 'env-update && source /etc/profile"
+- this_result=1
+ # Make sure the generation-1 VM set is generation-2 compatible, not set long before migration
+ else
+ # We need to unset GENERATION, because this ends up being in
diff --git a/dev-java/java-config-wrapper/java-config-wrapper-0.12-r1.ebuild b/dev-java/java-config-wrapper/java-config-wrapper-0.12-r1.ebuild
new file mode 100644
index 000000000000..acb95295e64e
--- /dev/null
+++ b/dev-java/java-config-wrapper/java-config-wrapper-0.12-r1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/java-config-wrapper/java-config-wrapper-0.12-r1.ebuild,v 1.1 2006/10/18 03:37:56 nichoj Exp $
+
+inherit base eutils
+DESCRIPTION="Wrapper for java-config"
+HOMEPAGE="http://www.gentoo.org/proj/en/java"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha amd64 ~hppa ia64 ppc ppc64 x86 ~x86-fbsd"
+DEPEND="!<dev-java/java-config-1.3"
+RDEPEND="app-portage/portage-utils"
+
+IUSE=""
+
+# Patch to improve output of generation_1_system_vm
+PATCHES="${FILESDIR}/${P}-generation_1_system_vm.patch"
+
+src_compile() {
+ :;
+}
+
+src_install() {
+ dobin src/shell/*
+}