summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDylan Carlson <absinthe@gentoo.org>2003-03-22 12:02:07 +0000
committerDylan Carlson <absinthe@gentoo.org>2003-03-22 12:02:07 +0000
commit9936492fd7243b408d6c0bf08a471d9a1e56437f (patch)
tree71449a6353d5afd084f3c9bf71d038da5f0e1c74 /dev-java
parentInitial import. Keywords ~x86. (diff)
downloadgentoo-2-9936492fd7243b408d6c0bf08a471d9a1e56437f.tar.gz
gentoo-2-9936492fd7243b408d6c0bf08a471d9a1e56437f.tar.bz2
gentoo-2-9936492fd7243b408d6c0bf08a471d9a1e56437f.zip
Initial import. Keywords ~x86.
Diffstat (limited to 'dev-java')
-rw-r--r--dev-java/commons-httpclient/ChangeLog10
-rw-r--r--dev-java/commons-httpclient/commons-httpclient-2.0_alpha3.ebuild31
-rw-r--r--dev-java/commons-httpclient/files/digest-commons-httpclient-2.0_alpha31
3 files changed, 42 insertions, 0 deletions
diff --git a/dev-java/commons-httpclient/ChangeLog b/dev-java/commons-httpclient/ChangeLog
new file mode 100644
index 000000000000..4be223d46dc4
--- /dev/null
+++ b/dev-java/commons-httpclient/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for dev-java/commons-httpclient
+# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-httpclient/ChangeLog,v 1.1 2003/03/22 12:02:07 absinthe Exp $
+
+*commons-httpclient-2.0_alpha3 (22 Mar 2003)
+
+ 22 Mar 2003; Dylan Carlson <absinthe@gentoo.org>
+ commons-httpclient-2.0_alpha3.ebuild:
+ Initial import.
+
diff --git a/dev-java/commons-httpclient/commons-httpclient-2.0_alpha3.ebuild b/dev-java/commons-httpclient/commons-httpclient-2.0_alpha3.ebuild
new file mode 100644
index 000000000000..b8ddf711aa0d
--- /dev/null
+++ b/dev-java/commons-httpclient/commons-httpclient-2.0_alpha3.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-httpclient/commons-httpclient-2.0_alpha3.ebuild,v 1.1 2003/03/22 12:02:07 absinthe Exp $
+
+inherit jakarta-commons
+
+MY_P=${P/_/-}
+
+S="${WORKDIR}/httpclient"
+DESCRIPTION="The Jakarta Commons HttpClient provides an efficient, up-to-date, and feature-rich package implementing the client side of the most recent HTTP standards and recommendations."
+HOMEPAGE="http://jakarta.apache.org/commons/httpclient/index.html"
+SRC_URI="http://jakarta.apache.org/builds/jakarta-commons/release/${PN}/v2.0/${MY_P}.zip"
+DEPEND=">=virtual/jdk-1.3
+ >=dev-java/log4j-1.2.5
+ >=dev-java/ant-1.4"
+RDEPEND=">=virtual/jdk-1.3"
+LICENSE="Apache-1.1"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="doc jikes junit"
+src_compile()
+
+{
+ jakarta-commons_src_compile myconf make
+ use doc && jakarta-commons_src_compile makedoc
+
+ # UGLY HACK
+ mv ${S}/target/conf/MANIFEST.MF ${S}/target/classes/
+ cd ${S}/target/classes
+ zip -r ../${PN}-${PV}.jar org
+}
diff --git a/dev-java/commons-httpclient/files/digest-commons-httpclient-2.0_alpha3 b/dev-java/commons-httpclient/files/digest-commons-httpclient-2.0_alpha3
new file mode 100644
index 000000000000..36fdc0fb5da4
--- /dev/null
+++ b/dev-java/commons-httpclient/files/digest-commons-httpclient-2.0_alpha3
@@ -0,0 +1 @@
+MD5 d668cc6b590ee1c2f5a533b41aa7fb89 commons-httpclient-2.0-alpha3.zip 1068445