summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-08-05 18:57:54 +0000
committerMike Frysinger <vapier@gentoo.org>2003-08-05 18:57:54 +0000
commita044d2b12bc7a378feafedd92f4735c3019c2d62 (patch)
tree0e40440a013536436c57ebdd7fb903e5f768fa77 /dev-java
parentFix for second error reported in bug #25879 (diff)
downloadgentoo-2-a044d2b12bc7a378feafedd92f4735c3019c2d62.tar.gz
gentoo-2-a044d2b12bc7a378feafedd92f4735c3019c2d62.tar.bz2
gentoo-2-a044d2b12bc7a378feafedd92f4735c3019c2d62.zip
fix license
Diffstat (limited to 'dev-java')
-rw-r--r--dev-java/oro/oro-2.0.6-r2.ebuild26
-rw-r--r--dev-java/oro/oro-2.0.7.ebuild26
-rw-r--r--dev-java/xom/xom-1.0.14.ebuild16
3 files changed, 35 insertions, 33 deletions
diff --git a/dev-java/oro/oro-2.0.6-r2.ebuild b/dev-java/oro/oro-2.0.6-r2.ebuild
index fee9a8bb2d59..ef063961c41e 100644
--- a/dev-java/oro/oro-2.0.6-r2.ebuild
+++ b/dev-java/oro/oro-2.0.6-r2.ebuild
@@ -1,20 +1,23 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/dev-java/oro/oro-2.0.6-r2.ebuild,v 1.3 2003/04/26 05:36:58 strider Exp $
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/oro/oro-2.0.6-r2.ebuild,v 1.4 2003/08/05 18:53:42 vapier Exp $
-S=${WORKDIR}/jakarta-oro-${PV}
DESCRIPTION="A set of text-processing Java classes that provide Perl5 compatible regular expressions, AWK-like regular expressions, glob expressions, and utility classes for performing substitutions, splits, filtering filenames, etc."
-SRC_URI="mirror://apache/jakarta/oro/source/jakarta-oro-${PV}.tar.gz"
HOMEPAGE="http://jakarta.apache.org/oro/index.html"
-DEPEND=">=virtual/jdk-1.3
- >=dev-java/ant-1.4
- jikes? ( >=dev-java/jikes-1.17 )"
-REDEPND=">=virtual/jdk-1.3"
+SRC_URI="mirror://apache/jakarta/oro/source/jakarta-oro-${PV}.tar.gz"
+
LICENSE="Apache-1.1"
SLOT="0"
KEYWORDS="x86 ppc sparc"
IUSE="doc jikes"
+DEPEND=">=virtual/jdk-1.3
+ >=dev-java/ant-1.4
+ jikes? ( >=dev-java/jikes-1.17 )"
+RDEPEND=">=virtual/jdk-1.3"
+
+S=${WORKDIR}/jakarta-oro-${PV}
+
src_compile() {
local myc
@@ -29,14 +32,11 @@ src_compile() {
fi
}
-src_install () {
+src_install() {
mv jakarta-oro*.jar oro.jar
dojar oro.jar || die "Failed Installing"
dodoc BUGS CHANGES COMPILE CONTRIBUTORS README STYLE TODO
dohtml *.html
- if [ -n "`use doc`" ] ; then
- dodir /usr/share/doc/${P}
- dohtml -r docs/
- fi
+ [ -n "`use doc`" ] && dohtml -r docs/
}
diff --git a/dev-java/oro/oro-2.0.7.ebuild b/dev-java/oro/oro-2.0.7.ebuild
index 2ded54566df3..8b7ddb1f050f 100644
--- a/dev-java/oro/oro-2.0.7.ebuild
+++ b/dev-java/oro/oro-2.0.7.ebuild
@@ -1,20 +1,23 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/dev-java/oro/oro-2.0.7.ebuild,v 1.3 2003/07/11 21:41:54 aliz Exp $
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/oro/oro-2.0.7.ebuild,v 1.4 2003/08/05 18:53:42 vapier Exp $
-S=${WORKDIR}/jakarta-oro-${PV}
DESCRIPTION="A set of text-processing Java classes that provide Perl5 compatible regular expressions, AWK-like regular expressions, glob expressions, and utility classes for performing substitutions, splits, filtering filenames, etc."
-SRC_URI="mirror://apache/jakarta/oro/source/jakarta-${PN}-${PV}.tar.gz"
HOMEPAGE="http://jakarta.apache.org/oro/index.html"
-DEPEND=">=virtual/jdk-1.3
- >=dev-java/ant-1.4
- jikes? ( >=dev-java/jikes-1.17 )"
-REDEPND=">=virtual/jdk-1.3"
+SRC_URI="mirror://apache/jakarta/oro/source/jakarta-${PN}-${PV}.tar.gz"
+
LICENSE="Apache-1.1"
SLOT="0"
KEYWORDS="x86 ~ppc ~sparc"
IUSE="doc jikes"
+DEPEND=">=virtual/jdk-1.3
+ >=dev-java/ant-1.4
+ jikes? ( >=dev-java/jikes-1.17 )"
+RDEPEND=">=virtual/jdk-1.3"
+
+S=${WORKDIR}/jakarta-oro-${PV}
+
src_compile() {
local myc
@@ -29,14 +32,11 @@ src_compile() {
fi
}
-src_install () {
+src_install() {
mv jakarta-oro*.jar oro.jar
dojar oro.jar || die "Failed Installing"
dodoc CHANGES COMPILE CONTRIBUTORS ISSUES LICENSE README STYLE TODO
dohtml *.html
- if [ -n "`use doc`" ] ; then
- dodir /usr/share/doc/${P}
- dohtml -r docs/
- fi
+ [ -n "`use doc`" ] && dohtml -r docs/
}
diff --git a/dev-java/xom/xom-1.0.14.ebuild b/dev-java/xom/xom-1.0.14.ebuild
index cc452e58f1b9..cbe53f26a03d 100644
--- a/dev-java/xom/xom-1.0.14.ebuild
+++ b/dev-java/xom/xom-1.0.14.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/dev-java/xom/xom-1.0.14.ebuild,v 1.2 2003/05/26 08:49:16 absinthe Exp $
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/xom/xom-1.0.14.ebuild,v 1.3 2003/08/05 18:54:18 vapier Exp $
inherit java-pkg
@@ -8,15 +8,17 @@ inherit java-pkg
S=${WORKDIR}/XOM
XOMVER="xom-1.0d14"
DESCRIPTION="XOM is a new XML object model. It is a tree-based API for processing XML with Java that strives for correctness and simplicity."
-SRC_URI="http://cafeconleche.org/XOM/${XOMVER}.zip"
HOMEPAGE="http://cafeconleche.org/XOM/index.html"
-DEPEND=">=dev-java/ant-1.4"
-RDEPEND=">=virtual/jdk-1.2"
+SRC_URI="http://cafeconleche.org/XOM/${XOMVER}.zip"
+
LICENSE="LGPL-2"
SLOT="0"
KEYWORDS="x86 ppc sparc alpha"
IUSE="doc"
+DEPEND=">=dev-java/ant-1.4"
+RDEPEND=">=virtual/jdk-1.2"
+
src_compile() {
local myc
cd ${WORKDIR}/XOM
@@ -24,8 +26,8 @@ src_compile() {
ANT_OPTS=${myc} ant jar || die "Failed Compiling"
}
-src_install () {
- mv ${WORKDIR}/XOM/build/${XOMVER}.jar xom.jar
+src_install() {
+ mv ${WORKDIR}/XOM/build/${XOMVER}.jar xom.jar
java-pkg_dojar xom.jar || die "Failed Installing"
dodoc Todo.txt