summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohann Schmitz <ercpe@gentoo.org>2015-01-23 17:51:17 +0000
committerJohann Schmitz <ercpe@gentoo.org>2015-01-23 17:51:17 +0000
commitd85b8d6a119e18b746c24b3514032ed5fa5f7b3c (patch)
treed9eba42d459396efab71cb8f6de45fa2a5a062b1 /dev-java
parentadded ~amd64-linux (tested by me) (diff)
downloadgentoo-2-d85b8d6a119e18b746c24b3514032ed5fa5f7b3c.tar.gz
gentoo-2-d85b8d6a119e18b746c24b3514032ed5fa5f7b3c.tar.bz2
gentoo-2-d85b8d6a119e18b746c24b3514032ed5fa5f7b3c.zip
Version bump of java-sdk-docs wrt bug #537214
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 77C501ED)
Diffstat (limited to 'dev-java')
-rw-r--r--dev-java/java-sdk-docs/ChangeLog11
-rw-r--r--dev-java/java-sdk-docs/java-sdk-docs-1.7.0.76.ebuild49
-rw-r--r--dev-java/java-sdk-docs/java-sdk-docs-1.8.0.31.ebuild51
3 files changed, 109 insertions, 2 deletions
diff --git a/dev-java/java-sdk-docs/ChangeLog b/dev-java/java-sdk-docs/ChangeLog
index b36f06f53a50..4443ab423455 100644
--- a/dev-java/java-sdk-docs/ChangeLog
+++ b/dev-java/java-sdk-docs/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-java/java-sdk-docs
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/java-sdk-docs/ChangeLog,v 1.114 2014/11/22 08:29:09 ercpe Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/java-sdk-docs/ChangeLog,v 1.115 2015/01/23 17:51:17 ercpe Exp $
+
+*java-sdk-docs-1.7.0.76 (23 Jan 2015)
+*java-sdk-docs-1.8.0.31 (23 Jan 2015)
+
+ 23 Jan 2015; Johann Schmitz <ercpe@gentoo.org> +java-sdk-docs-1.7.0.76.ebuild,
+ +java-sdk-docs-1.8.0.31.ebuild:
+ Version bump of java-sdk-docs wrt bug #537214
*java-sdk-docs-1.8.0.25 (22 Nov 2014)
diff --git a/dev-java/java-sdk-docs/java-sdk-docs-1.7.0.76.ebuild b/dev-java/java-sdk-docs/java-sdk-docs-1.7.0.76.ebuild
new file mode 100644
index 000000000000..f2cd092834ff
--- /dev/null
+++ b/dev-java/java-sdk-docs/java-sdk-docs-1.7.0.76.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/java-sdk-docs/java-sdk-docs-1.7.0.76.ebuild,v 1.1 2015/01/23 17:51:17 ercpe Exp $
+
+EAPI=5
+
+inherit versionator
+
+MY_PV="$(get_version_component_range 2)u$(get_version_component_range 4)"
+
+DOWNLOAD_URL="http://www.oracle.com/technetwork/java/javase/documentation/java-se-7-doc-download-435117.html#jdk-${MY_PV}-apidocs-oth-JPR"
+ORIG_NAME="jdk-${MY_PV}-docs-all.zip"
+
+DESCRIPTION="Oracle's documentation bundle (including API) for Java SE"
+HOMEPAGE="http://download.oracle.com/javase/7/docs/"
+SRC_URI="${ORIG_NAME}"
+
+LICENSE="oracle-java-documentation-7"
+SLOT="1.7"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+DEPEND="app-arch/unzip"
+
+RESTRICT="fetch"
+
+S="${WORKDIR}/docs"
+
+pkg_nofetch() {
+ einfo "Please download ${ORIG_NAME} from "
+ einfo "${DOWNLOAD_URL}"
+ einfo "(agree to the license) and place it in ${DISTDIR}"
+
+ einfo "If you find the file on the download page replaced with a higher"
+ einfo "version, please report to the bug 67266 (link below)."
+ einfo "If emerge fails because of a checksum error it is possible that"
+ einfo "the upstream release changed without renaming. Try downloading the file"
+ einfo "again (or a newer revision if available). Otherwise report this to"
+ einfo "http://bugs.gentoo.org/67266 and we will make a new revision."
+}
+
+src_install(){
+ insinto /usr/share/doc/${P}/html
+ doins index.html
+
+ for i in *; do
+ [[ -d $i ]] && doins -r $i
+ done
+}
diff --git a/dev-java/java-sdk-docs/java-sdk-docs-1.8.0.31.ebuild b/dev-java/java-sdk-docs/java-sdk-docs-1.8.0.31.ebuild
new file mode 100644
index 000000000000..1314c506b0ee
--- /dev/null
+++ b/dev-java/java-sdk-docs/java-sdk-docs-1.8.0.31.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/java-sdk-docs/java-sdk-docs-1.8.0.31.ebuild,v 1.1 2015/01/23 17:51:17 ercpe Exp $
+
+EAPI="5"
+
+inherit versionator
+
+DOWNLOAD_URL="http://www.oracle.com/technetwork/java/javase/documentation/jdk8-doc-downloads-2133158.html"
+
+[[ "$(get_version_component_range 4)" == 0 ]] \
+ || MY_PV_EXT="u$(get_version_component_range 4)"
+
+MY_PV="$(get_version_component_range 2)${MY_PV_EXT}"
+ORIG_NAME="jdk-${MY_PV}-docs-all.zip"
+
+DESCRIPTION="Oracle's documentation bundle (including API) for Java SE"
+HOMEPAGE="http://download.oracle.com/javase/8/docs/"
+SRC_URI="${ORIG_NAME}"
+
+LICENSE="oracle-java-documentation-8"
+SLOT="1.8"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+
+DEPEND="app-arch/unzip:0"
+
+RESTRICT="fetch"
+
+S="${WORKDIR}/docs"
+
+pkg_nofetch() {
+ einfo "Please download ${ORIG_NAME} from "
+ einfo "${DOWNLOAD_URL}"
+ einfo "(agree to the license) and place it in ${DISTDIR}"
+
+ einfo "If you find the file on the download page replaced with a higher"
+ einfo "version, please report to the bug 67266 (link below)."
+ einfo "If emerge fails because of a checksum error it is possible that"
+ einfo "the upstream release changed without renaming. Try downloading the file"
+ einfo "again (or a newer revision if available). Otherwise report this to"
+ einfo "http://bugs.gentoo.org/67266 and we will make a new revision."
+}
+
+src_install(){
+ insinto /usr/share/doc/${P}/html
+ doins index.html
+
+ for i in *; do
+ [[ -d $i ]] && doins -r $i
+ done
+}