summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTom Wijsman <tomwij@gentoo.org>2013-07-05 14:32:34 +0000
committerTom Wijsman <tomwij@gentoo.org>2013-07-05 14:32:34 +0000
commitda598f380d1ef0268fe9f784be39c99a3d577c01 (patch)
tree1ce9faa5e5f1f6d20a9942ac2b75672eca6c240e /dev-java
parentVersion bump to 1.9.1. (diff)
downloadgentoo-2-da598f380d1ef0268fe9f784be39c99a3d577c01.tar.gz
gentoo-2-da598f380d1ef0268fe9f784be39c99a3d577c01.tar.bz2
gentoo-2-da598f380d1ef0268fe9f784be39c99a3d577c01.zip
Version bump to 1.9.1.
(Portage version: 2.1.12.11/cvs/Linux x86_64, signed Manifest commit with key 6D34E57D)
Diffstat (limited to 'dev-java')
-rw-r--r--dev-java/ant-trax/ChangeLog7
-rw-r--r--dev-java/ant-trax/ant-trax-1.9.1.ebuild30
2 files changed, 36 insertions, 1 deletions
diff --git a/dev-java/ant-trax/ChangeLog b/dev-java/ant-trax/ChangeLog
index 4e2bd71fc3bf..ce9da9dcfe49 100644
--- a/dev-java/ant-trax/ChangeLog
+++ b/dev-java/ant-trax/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-java/ant-trax
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/ant-trax/ChangeLog,v 1.36 2013/02/05 05:54:19 zerochaos Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/ant-trax/ChangeLog,v 1.37 2013/07/05 14:32:34 tomwij Exp $
+
+*ant-trax-1.9.1 (05 Jul 2013)
+
+ 05 Jul 2013; Tom Wijsman <TomWij@gentoo.org> +ant-trax-1.9.1.ebuild:
+ Version bump to 1.9.1.
05 Feb 2013; Rick Farina <zerochaos@gentoo.org> ant-trax-1.8.4.ebuild:
adding ~arm
diff --git a/dev-java/ant-trax/ant-trax-1.9.1.ebuild b/dev-java/ant-trax/ant-trax-1.9.1.ebuild
new file mode 100644
index 000000000000..1afac2e55941
--- /dev/null
+++ b/dev-java/ant-trax/ant-trax-1.9.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/ant-trax/ant-trax-1.9.1.ebuild,v 1.1 2013/07/05 14:32:34 tomwij Exp $
+
+EAPI="5"
+
+ANT_TASK_DEPNAME=""
+ANT_TASK_DISABLE_VM_DEPS="true"
+
+inherit ant-tasks
+
+DESCRIPTION="Apache Ant .jar with optional tasks depending on XML transformer (Deprecated!)"
+KEYWORDS="~amd64 ~arm ~ia64 ~ppc ~ppc64 ~x86 ~x86-fbsd ~x64-freebsd \
+ ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos \
+ ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+# Dependency needed for jar.
+DEPEND=">=virtual/jdk-1.4"
+
+src_compile() {
+ # The classes were moved to ant-core in 1.8.1, this is just for compatibility.
+ mkdir -p build/lib/empty && cd build/lib/empty || die
+ jar -cf ../${PN}.jar .
+}
+
+pkg_postinst() {
+ elog "Upstream has removed ant-trax.jar as of 1.8.1 and moved the classes to ant.jar"
+ elog "This package thus installs an empty jar for compatibility"
+ elog "and will be removed once reverse dependencies are transitioned."
+}