summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJean-Noël Rivasseau <elvanor@gentoo.org>2008-01-23 11:11:14 +0000
committerJean-Noël Rivasseau <elvanor@gentoo.org>2008-01-23 11:11:14 +0000
commitef73a489af3f0ad78d1b587d0fdaf9321a74a452 (patch)
treeaa1f00e1e53fdf7b583cdcf609587bfa2c17dfd9 /dev-java
parentVersion bump. (diff)
downloadgentoo-2-ef73a489af3f0ad78d1b587d0fdaf9321a74a452.tar.gz
gentoo-2-ef73a489af3f0ad78d1b587d0fdaf9321a74a452.tar.bz2
gentoo-2-ef73a489af3f0ad78d1b587d0fdaf9321a74a452.zip
Fix for bug #206819.
(Portage version: 2.1.3.19)
Diffstat (limited to 'dev-java')
-rw-r--r--dev-java/icu4j/ChangeLog8
-rw-r--r--dev-java/icu4j/files/digest-icu4j-3.6.1-r16
-rw-r--r--dev-java/icu4j/icu4j-3.6.1-r1.ebuild69
3 files changed, 82 insertions, 1 deletions
diff --git a/dev-java/icu4j/ChangeLog b/dev-java/icu4j/ChangeLog
index 6cf57409d504..21e025e4e8cc 100644
--- a/dev-java/icu4j/ChangeLog
+++ b/dev-java/icu4j/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-java/icu4j
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/icu4j/ChangeLog,v 1.18 2008/01/15 22:32:43 caster Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/icu4j/ChangeLog,v 1.19 2008/01/23 11:11:13 elvanor Exp $
+
+*icu4j-3.6.1-r1 (23 Jan 2008)
+
+ 23 Jan 2008; Jean-Noël Rivasseau <elvanor@gentoo.org>
+ +icu4j-3.6.1-r1.ebuild:
+ Fix for bug #206819.
15 Jan 2008; Vlastimil Babka <caster@gentoo.org> icu4j-3.6.1.ebuild:
Restrict compiler to javac which unlike ecj doesn't mind the API changes in
diff --git a/dev-java/icu4j/files/digest-icu4j-3.6.1-r1 b/dev-java/icu4j/files/digest-icu4j-3.6.1-r1
new file mode 100644
index 000000000000..6c0a52109d2d
--- /dev/null
+++ b/dev-java/icu4j/files/digest-icu4j-3.6.1-r1
@@ -0,0 +1,6 @@
+MD5 db5670fcaf4ea21ee79777024635f0b3 icu4jdocs_3_6_1.jar 1272083
+RMD160 bee225934e218f1ec30d6178cce683af696eb70a icu4jdocs_3_6_1.jar 1272083
+SHA256 94825decfad15ac4ba6dc1bda7893398e421a37b4ce7f3fa87b80a7d1c39d6f0 icu4jdocs_3_6_1.jar 1272083
+MD5 e282dad6502ee0679c69d0a26e541552 icu4jsrc_3_6_1.jar 12914772
+RMD160 58f6c7dcdd62247b633e2ee162b98cb86d7bb498 icu4jsrc_3_6_1.jar 12914772
+SHA256 4800e02ff7916dda103063e51bd6f81237c1003087879b5a12a74593d02f1d36 icu4jsrc_3_6_1.jar 12914772
diff --git a/dev-java/icu4j/icu4j-3.6.1-r1.ebuild b/dev-java/icu4j/icu4j-3.6.1-r1.ebuild
new file mode 100644
index 000000000000..08c2382a05fa
--- /dev/null
+++ b/dev-java/icu4j/icu4j-3.6.1-r1.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/icu4j/icu4j-3.6.1-r1.ebuild,v 1.1 2008/01/23 11:11:13 elvanor Exp $
+
+# We currently download the Javadoc documentation.
+# It could optionally be built using the Ant build file.
+# testdata.jar and icudata.jar do not contain *.class files but *.res files
+# These *.res data files are needed to built the final jar
+# They do not need to be installed however as they will already be present in icu4j.jar
+
+JAVA_PKG_IUSE="source"
+
+inherit java-pkg-2 java-ant-2 java-osgi
+
+DESCRIPTION="ICU4J is a mature, widely used set of Java libraries providing Unicode and Globalization support for software applications."
+MY_PV=${PV//./_}
+
+SRC_URI="http://download.icu-project.org/files/${PN}/${PV}/${PN}src_${MY_PV}.jar
+ doc? ( http://download.icu-project.org/files/${PN}/${PV}/${PN}docs_${MY_PV}.jar )"
+
+HOMEPAGE="http://www.icu-project.org/"
+LICENSE="icu"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~x86 ~x86-fbsd"
+
+RDEPEND=">=virtual/jre-1.4"
+
+DEPEND="test? ( || ( =virtual/jdk-1.5* =virtual/jdk-1.4* ) )
+ !test? ( >=virtual/jdk-1.4 )"
+
+IUSE="doc test"
+
+S="${WORKDIR}"
+
+src_unpack() {
+ jar -xf "${DISTDIR}/${PN}src_${MY_PV}.jar" || die "Failed to unpack"
+
+ if use doc; then
+ mkdir docs; cd docs
+ jar -xf "${DISTDIR}/${PN}docs_${MY_PV}.jar" || die "Failed to unpack docs"
+ fi
+}
+
+src_compile() {
+ # Classes extending CharsetICU not implementing Comparable
+ # Breaks with ecj on jdk 1.5+, javac doesn't mind - Sun's hack?
+ # Restricting to javac (didn't even care to try jikes) is better
+ # than forcing 1.4
+ java-pkg_force-compiler javac
+ eant jar || die "Compile failed"
+}
+
+src_install() {
+ java-osgi_newjar-fromfile "${PN}.jar" "${FILESDIR}/icu4j-${PV}-manifest" \
+ "International Components for Unicode for Java (ICU4J)"
+ java-pkg_dojar "${PN}-charsets.jar"
+
+ use doc && dohtml -r readme.html docs/*
+ use source && java-pkg_dosrc src/*
+}
+
+# Following tests will fail in Sun JDK 6 (at least):
+# toUnicode: http://bugs.icu-project.org/trac/ticket/5663
+# TimeZoneTransitionAdd: http://bugs.icu-project.org/trac/ticket/5887
+# These are bugs in the tests themselves, not in the library
+
+src_test() {
+ eant check
+}