summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKarl Trygve Kalleberg <karltk@gentoo.org>2004-12-18 20:03:54 +0000
committerKarl Trygve Kalleberg <karltk@gentoo.org>2004-12-18 20:03:54 +0000
commitf3c6576074267dbc024cdff4d0c9463d7359370a (patch)
treeadaaa103dba096d805c72b8bb40d8a9ce8667016 /dev-java
parentFixed SRC_URI. (Manifest recommit) (diff)
downloadgentoo-2-f3c6576074267dbc024cdff4d0c9463d7359370a.tar.gz
gentoo-2-f3c6576074267dbc024cdff4d0c9463d7359370a.tar.bz2
gentoo-2-f3c6576074267dbc024cdff4d0c9463d7359370a.zip
Initial import. Fixes #14361.
Diffstat (limited to 'dev-java')
-rw-r--r--dev-java/castor/ChangeLog9
-rw-r--r--dev-java/castor/Manifest5
-rw-r--r--dev-java/castor/castor-0.9.5.3.ebuild71
-rw-r--r--dev-java/castor/files/build-xml.patch47
-rw-r--r--dev-java/castor/files/digest-castor-0.9.5.31
-rw-r--r--dev-java/castor/metadata.xml14
6 files changed, 147 insertions, 0 deletions
diff --git a/dev-java/castor/ChangeLog b/dev-java/castor/ChangeLog
new file mode 100644
index 000000000000..95a2c4e94644
--- /dev/null
+++ b/dev-java/castor/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for dev-java/castor
+# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/castor/ChangeLog,v 1.1 2004/12/18 20:03:54 karltk Exp $
+
+*castor-0.9.5.3 (18 Dec 2004)
+
+ 18 Dec 2004; Karl Trygve Kalleberg <karltk@gentoo.org> castor-0.9.5.3.ebuild:
+ Initial import. Ebuild submitted by the productive Jan Brinkmann
+ <lucky@the-luckyduck.de>, fixes #14361.
diff --git a/dev-java/castor/Manifest b/dev-java/castor/Manifest
new file mode 100644
index 000000000000..d533562c59bf
--- /dev/null
+++ b/dev-java/castor/Manifest
@@ -0,0 +1,5 @@
+MD5 1412f18fa9dca3618fba3700859a0421 castor-0.9.5.3.ebuild 1492
+MD5 54234aa4214bb5e5b3cbbc56ec2e8478 ChangeLog 273
+MD5 0637a933ecb6e8cedfc4ddfcf3491728 metadata.xml 310
+MD5 925da383ab0658b27587273d0f315f06 files/build-xml.patch 2859
+MD5 943c414729ed76f67dc46a6373bd6094 files/digest-castor-0.9.5.3 68
diff --git a/dev-java/castor/castor-0.9.5.3.ebuild b/dev-java/castor/castor-0.9.5.3.ebuild
new file mode 100644
index 000000000000..9bdea5dbc23b
--- /dev/null
+++ b/dev-java/castor/castor-0.9.5.3.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/castor/castor-0.9.5.3.ebuild,v 1.1 2004/12/18 20:03:54 karltk Exp $
+
+inherit eutils java-pkg
+
+DESCRIPTION="Data binding framework for Java"
+SRC_URI="ftp://ftp.exolab.org/pub/castor/castor_${PV}/castor-${PV}-src.tgz"
+HOMEPAGE="http://castor.exolab.org/"
+LICENSE="Exolab"
+KEYWORDS="~x86"
+SLOT="0.9"
+IUSE="doc"
+
+DEPEND=">=virtual/jdk-1.4
+ ${RDEPEND}"
+
+RDEPEND=">=virtual/jre-1.4
+ >=dev-java/ant-core-1.5
+ >=dev-java/adaptx-0.9.5.3
+ >=dev-java/commons-logging-1.0.4
+ >=dev-java/oro-2.0.5
+ >=dev-java/regexp-1.3
+ >=dev-java/jta-1.0.1
+ >=dev-java/ldapsdk-4.1.7
+ >=dev-java/junit-3.8
+ >=dev-java/log4j-1.2.8
+ >=dev-java/jdbc2-postgresql-7.3
+ =dev-java/servletapi-2.3*
+ =dev-java/xerces-1.3*"
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}/src
+ epatch ${FILESDIR}/build-xml.patch
+
+ cd ${S}/lib
+ rm -f *.jar
+ java-pkg_jar-from adaptx-0.9
+ java-pkg_jar-from ant-core ant.jar
+ java-pkg_jar-from commons-logging
+ java-pkg_jar-from oro
+ java-pkg_jar-from regexp
+ java-pkg_jar-from jta
+ java-pkg_jar-from junit
+ java-pkg_jar-from log4j
+ java-pkg_jar-from jdbc2-postgresql-6
+ java-pkg_jar-from servletapi-2.3
+ java-pkg_jar-from xerces-1.3
+ java-pkg_jar-from ldapsdk-4.1 ldapjdk.jar
+}
+
+
+src_compile() {
+ cd ${S}/src
+
+ local antflags="jar"
+ if use doc; then
+ antflags="${antflags} javadoc"
+ fi
+ ant ${antflags} || die "compile failed"
+}
+
+src_install() {
+ java-pkg_dojar dist/*.jar
+
+ if use doc; then
+ java-pkg_dohtml -r build/doc/javadoc/*
+ fi
+}
diff --git a/dev-java/castor/files/build-xml.patch b/dev-java/castor/files/build-xml.patch
new file mode 100644
index 000000000000..283ee0aff0bc
--- /dev/null
+++ b/dev-java/castor/files/build-xml.patch
@@ -0,0 +1,47 @@
+--- build.xml.orig 2004-12-12 13:56:30.000000000 +0100
++++ build.xml 2004-12-13 17:56:46.220717520 +0100
+@@ -148,7 +148,7 @@
+
+ <target name="main" depends="prepare"
+ description="The default target for compilation; includes debug and deprecation info">
+- <javac srcdir="${main}" destdir="${classes}" excludes="${excludes}" debug="on" deprecation="${deprecation}">
++ <javac srcdir="${main}" destdir="${classes}" excludes="${excludes}" debug="on" deprecation="${deprecation}" source="1.4" target="1.4">
+ <classpath refid="build.classpath"/>
+ </javac>
+ <copy todir="${classes}">
+@@ -163,7 +163,7 @@
+
+ <target name="main.opt" depends="prepare"
+ description="Same as the default target, but with optimization, no debug and no deprecation">
+- <javac srcdir="${main}" destdir="${classes}" excludes="${excludes}" debug="${main.opt.debug}" deprecation="off" optimize="on">
++ <javac srcdir="${main}" destdir="${classes}" excludes="${excludes}" debug="${main.opt.debug}" deprecation="off" optimize="on" source="1.4" target="1.4">
+ <classpath refid="build.classpath"/>
+ </javac>
+ <copy todir="${classes}">
+@@ -176,7 +176,7 @@
+ <target name="examples" depends="prepare, main"
+ description="Builds the example packages (including debugging info) and creates the webapp war file for the servlet example">
+ <mkdir dir="${build}/examples"/>
+- <javac srcdir="${source}/examples" destdir="${build}/examples" debug="on" deprecation="${deprecation}" excludes="${exampleexcludes}">
++ <javac srcdir="${source}/examples" destdir="${build}/examples" debug="on" deprecation="${deprecation}" excludes="${exampleexcludes}" source="1.4" target="1.4">
+ <classpath refid="build.classpath"/>
+ </javac>
+
+@@ -219,7 +219,7 @@
+
+ <target name="tests" depends="prepare" description="Build the tests packages">
+ <mkdir dir="${build}/tests"/>
+- <javac srcdir="${source}/tests" destdir="${build}/tests" excludes="${testexcludes}" debug="on" deprecation="${deprecation}">
++ <javac srcdir="${source}/tests" destdir="${build}/tests" excludes="${testexcludes}" debug="on" deprecation="${deprecation}" source="1.4" target="1.4">
+ <classpath refid="build.classpath"/>
+ </javac>
+
+@@ -467,7 +467,7 @@
+ <arg value="-types"/>
+ <arg value="j2"/>
+ </java>
+- <javac destdir="${classes}" excludes="${excludes}" debug="${main.opt.debug}" deprecation="off" optimize="on">
++ <javac destdir="${classes}" excludes="${excludes}" debug="${main.opt.debug}" deprecation="off" optimize="on" source="1.4" target="1.4">
+ <src path="${gen.src}" />
+ <classpath refid="build.classpath"/>
+ </javac>
diff --git a/dev-java/castor/files/digest-castor-0.9.5.3 b/dev-java/castor/files/digest-castor-0.9.5.3
new file mode 100644
index 000000000000..7e60db812da1
--- /dev/null
+++ b/dev-java/castor/files/digest-castor-0.9.5.3
@@ -0,0 +1 @@
+MD5 ca93b19f1300a5701d8401bcfb333402 castor-0.9.5.3-src.tgz 5562692
diff --git a/dev-java/castor/metadata.xml b/dev-java/castor/metadata.xml
new file mode 100644
index 000000000000..68204108338b
--- /dev/null
+++ b/dev-java/castor/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+<herd>java</herd>
+
+<longdescription>
+
+Castor is an Open Source data binding framework for Java[tm]. It's the shortest
+path between Java objects, XML documents and relational tables. Castor provides
+Java-to-XML binding, Java-to-SQL persistence, and more.
+
+</longdescription>
+</pkgmetadata>