summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2008-10-07 09:42:00 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2008-10-07 09:42:00 +0000
commit41cca95427c7c10c8b3d85228fa958fd2f9de00a (patch)
tree8aaf4117303b9f2b3d5aeae5d79a28f0e880ffed /dev-lang/R
parentFix yesno.sh test failure. (diff)
downloadgentoo-2-41cca95427c7c10c8b3d85228fa958fd2f9de00a.tar.gz
gentoo-2-41cca95427c7c10c8b3d85228fa958fd2f9de00a.tar.bz2
gentoo-2-41cca95427c7c10c8b3d85228fa958fd2f9de00a.zip
Added soname to libRmath, closing bug #235830. Changed herd from sci to sci-mathematics. Removed older versions
(Portage version: 2.2_rc11/cvs/Linux 2.6.25-gentoo-r7 x86_64)
Diffstat (limited to 'dev-lang/R')
-rw-r--r--dev-lang/R/ChangeLog7
-rw-r--r--dev-lang/R/R-2.2.1-r1.ebuild114
-rw-r--r--dev-lang/R/R-2.6.1-r1.ebuild140
-rw-r--r--dev-lang/R/R-2.7.2.ebuild15
-rw-r--r--dev-lang/R/metadata.xml2
5 files changed, 19 insertions, 259 deletions
diff --git a/dev-lang/R/ChangeLog b/dev-lang/R/ChangeLog
index a314fc13f1d4..f5b73aca6018 100644
--- a/dev-lang/R/ChangeLog
+++ b/dev-lang/R/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-lang/R
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/R/ChangeLog,v 1.134 2008/09/06 21:39:55 dertobi123 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/R/ChangeLog,v 1.135 2008/10/07 09:42:00 bicatali Exp $
+
+ 07 Oct 2008; Sébastien Fabbro <bicatali@gentoo.org> metadata.xml,
+ -R-2.2.1-r1.ebuild, -R-2.6.1-r1.ebuild, R-2.7.2.ebuild:
+ Added soname to libRmath, closing bug #235830. Changed herd from sci to
+ sci-mathematics. Removed older versions.
06 Sep 2008; Tobias Scherbaum <dertobi123@gentoo.org> R-2.7.1.ebuild:
ppc stable, bug #235822
diff --git a/dev-lang/R/R-2.2.1-r1.ebuild b/dev-lang/R/R-2.2.1-r1.ebuild
deleted file mode 100644
index 927a43607533..000000000000
--- a/dev-lang/R/R-2.2.1-r1.ebuild
+++ /dev/null
@@ -1,114 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/R/R-2.2.1-r1.ebuild,v 1.10 2008/02/26 20:05:12 bicatali Exp $
-
-inherit fortran toolchain-funcs flag-o-matic
-
-DESCRIPTION="R is GNU S - A language and environment for statistical computing and graphics."
-HOMEPAGE="http://www.r-project.org/"
-SRC_URI="mirror://cran/src/base/R-2/${P}.tar.gz"
-
-LICENSE="GPL-2 LGPL-2.1"
-SLOT="0"
-KEYWORDS="amd64 ia64 ppc ppc64 sparc x86"
-IUSE="blas jpeg nls png readline tk X lapack"
-
-RDEPEND=">=dev-lang/perl-5.6.1-r3
- >=dev-libs/libpcre-7.3
- app-arch/bzip2
- readline? ( >=sys-libs/readline-4.1-r3 )
- jpeg? ( >=media-libs/jpeg-6b-r2 )
- png? ( >=media-libs/libpng-1.2.1 )
- blas? ( virtual/blas )
- lapack? ( virtual/lapack )
- tk? ( dev-lang/tk
- dev-lang/tcl )
- X? ( x11-libs/libX11 )"
-DEPEND="${RDEPEND}
- X? ( x11-proto/xproto
- x11-libs/libXt
- x11-libs/libX11 )"
-
-AT_M4DIR="${S}/m4"
-
-pkg_setup() {
- # Test for a 64 bit architecture - f2c won't work on 64 bit archs with R.
- # Thanks to vapier for providing the test.
- cd "${T}"
- echo 'int main(){}' > test.c
- $(tc-getCC) -c test.c -o test.o
- if file test.o | grep -qs 64-bit ; then
- einfo "64 bit architecture detected, using g77 or gfortran."
- FORTRAN="gfortran g77 ifc"
- else
- FORTRAN="gfortran g77 f2c"
- fi
- rm -f test.{c,o}
- fortran_pkg_setup
-
- filter-ldflags -Wl,-Bdirect -Bdirect
-}
-
-src_compile() {
- local myconf="--enable-R-profiling --enable-R-shlib --enable-linux-lfs"
-
- if use tk; then
- #configure needs to find the files tclConfig.sh and tkConfig.sh
- myconf="${myconf} --with-tcltk --with-tcl-config=/usr/lib/tclConfig.sh
- --with-tk-config=/usr/lib/tkConfig.sh"
- else
- myconf="${myconf} --without-tcltk"
- fi
-
- econf \
- --with-system-zlib \
- --with-system-bzlib \
- --with-system-pcre \
- $(use_enable nls) \
- $(use_with blas) \
- $(use_with lapack) \
- $(use_with jpeg jpeglib) \
- $(use_with png libpng) \
- $(use_with readline) \
- $(use_with X x) \
- ${myconf} || die "econf failed"
- emake || die "emake failed"
-}
-
-src_install() {
- make \
- prefix="${D}"/usr \
- mandir="${D}"/usr/share/man \
- infodir="${D}"/usr/share/info \
- rhome="${D}"/usr/$(get_libdir)/R \
- install || die "Installation Failed"
-
- # fix the R wrapper script to have the correct R_HOME_DIR
- # sed regexp borrowed from included debian rules
- sed \
- -e "/^R_HOME_DIR=.*/s::R_HOME_DIR=/usr/$(get_libdir)/R:" \
- -i "${D}"/usr/$(get_libdir)/R/bin/R \
- || die "sed failed."
-
- # The same kinds of seds are needed for these variables too, see bug 115140
- sed \
- -e "/^R_SHARE_DIR=.*/s::R_SHARE_DIR=/usr/$(get_libdir)/R/share:" \
- -e "/^R_INCLUDE_DIR=.*/s::R_INCLUDE_DIR=/usr/$(get_libdir)/R/include:" \
- -e "/^R_DOC_DIR=.*/s::R_DOC_DIR=/usr/$(get_libdir)/R/doc:" \
- -i "${D}"/usr/$(get_libdir)/R/bin/R \
- || die "sed failed."
-
- # R installs two identical wrappers under /usr/bin and /usr/lib/R/bin/
- # the 2nd one is corrected by above sed, the first is replaced by a symlink
- cd "${D}"/usr/bin/
- rm R
- dosym ../$(get_libdir)/R/bin/R /usr/bin/R
- dodir /etc/env.d
- echo -n \
- "LDPATH=\"/usr/$(get_libdir)/R/lib\"" \
- > "${D}"/etc/env.d/99R
- cd "${S}"
-
- dodoc AUTHORS BUGS COPYING* ChangeLog FAQ *NEWS README \
- RESOURCES THANKS VERSION Y2K
-}
diff --git a/dev-lang/R/R-2.6.1-r1.ebuild b/dev-lang/R/R-2.6.1-r1.ebuild
deleted file mode 100644
index aa3ef3c18052..000000000000
--- a/dev-lang/R/R-2.6.1-r1.ebuild
+++ /dev/null
@@ -1,140 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/R/R-2.6.1-r1.ebuild,v 1.14 2008/08/29 00:34:48 mr_bones_ Exp $
-
-inherit fortran flag-o-matic bash-completion
-
-DESCRIPTION="Language and environment for statistical computing and graphics"
-HOMEPAGE="http://www.r-project.org/"
-SRC_URI="mirror://cran/src/base/R-2/${P}.tar.gz
- bash-completion? ( mirror://gentoo/R.bash_completion.bz2 )"
-
-LICENSE="GPL-2 LGPL-2.1"
-SLOT="0"
-KEYWORDS="alpha amd64 hppa ia64 ppc ppc64 sparc x86 ~x86-fbsd"
-
-IUSE="doc java jpeg lapack minimal nls png readline tk X"
-
-# common depends
-CDEPEND="dev-lang/perl
- >=dev-libs/libpcre-7.3
- app-arch/bzip2
- virtual/blas
- virtual/ghostscript
- readline? ( sys-libs/readline )
- jpeg? ( media-libs/jpeg )
- png? ( media-libs/libpng )
- lapack? ( virtual/lapack )
- tk? ( dev-lang/tk )
- X? ( x11-libs/libXmu x11-misc/xdg-utils )"
-
-DEPEND="${CDEPEND}
- dev-util/pkgconfig
- doc? ( virtual/latex-base
- || ( dev-texlive/texlive-fontsrecommended virtual/tetex ) )"
-
-RDEPEND="${CDEPEND}
- app-arch/unzip
- app-arch/zip
- java? ( >=virtual/jre-1.5 )"
-
-R_HOME=/usr/$(get_libdir)/R
-
-pkg_setup() {
- FORTRAN="gfortran ifc g77"
- fortran_pkg_setup
- export FFLAGS="${FFLAGS:--O2}"
- [[ ${FORTRANC} = gfortran || ${FORTRANC} = if* ]] && \
- export FCFLAGS="${FCFLAGS:-${FFLAGS}}"
-
- filter-ldflags -Wl,-Bdirect -Bdirect
-
- # this is needed to properly compile additional R packages
- # (see bug #152379)
- append-flags -std=gnu99
-
- # this is needed for linking on ppc64 (see bug #210229)
- use ppc64 && append-flags -mminimal-toc
-}
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}"/${PN}-javareconf.patch
-}
-
-src_compile() {
- # fix packages.html for doc (bug #205103)
- # check in later versions if fixed
- sed -i \
- -e "s:../../library:../../../../$(get_libdir)/R/library:g" \
- src/library/tools/R/packageshtml.R \
- || die "sed failed"
-
- use lapack && \
- export LAPACK_LIBS="$(pkg-config --libs lapack)"
-
- if use X; then
- export R_BROWSER="$(type -p xdg-open)"
- export R_PDFVIEWER="$(type -p xdg-open)"
- fi
-
- econf \
- --enable-R-profiling \
- --enable-memory-profiling \
- --enable-R-shlib \
- --enable-linux-lfs \
- --with-system-zlib \
- --with-system-bzlib \
- --with-system-pcre \
- --with-blas="$(pkg-config --libs blas)" \
- --docdir=/usr/share/doc/${PF} \
- rdocdir=/usr/share/doc/${PF} \
- $(use_enable nls) \
- $(use_with lapack) \
- $(use_with tk tcltk) \
- $(use_with jpeg jpeglib) \
- $(use_with !minimal recommended-packages) \
- $(use_with png libpng) \
- $(use_with readline) \
- $(use_with X x) \
- || die "econf failed"
- emake || die "emake failed"
- if use doc; then
- export VARTEXFONTS="${T}/fonts"
- emake info pdf || die "emake docs failed"
- fi
-
- emake -j1 -C src/nmath/standalone || die "emake math library failed"
-}
-
-src_install() {
- # -j1 because creates various dirs sequentially (hit should be small)
- emake -j1 DESTDIR="${D}" install || die "emake install failed"
-
- if use doc; then
- emake DESTDIR="${D}" \
- install-info install-pdf || die "emake install docs failed"
- fi
-
- emake -j1 \
- -C src/nmath/standalone \
- DESTDIR="${D}" install \
- || die "emake install math library failed"
-
- # env file
- cat > 99R <<-EOF
- LDPATH=${R_HOME}/lib
- R_HOME=${R_HOME}
- EOF
- doenvd 99R || die "doenvd failed"
-
- dobashcompletion "${WORKDIR}"/R.bash_completion
-}
-
-pkg_config() {
- if use java; then
- einfo "Re-initializing java paths for ${P}"
- R CMD javareconf
- fi
-}
diff --git a/dev-lang/R/R-2.7.2.ebuild b/dev-lang/R/R-2.7.2.ebuild
index 92d02a421a58..310f5d881004 100644
--- a/dev-lang/R/R-2.7.2.ebuild
+++ b/dev-lang/R/R-2.7.2.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/R/R-2.7.2.ebuild,v 1.1 2008/08/27 23:01:40 markusle Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/R/R-2.7.2.ebuild,v 1.2 2008/10/07 09:42:00 bicatali Exp $
-inherit fortran flag-o-matic bash-completion
+inherit fortran flag-o-matic bash-completion versionator
DESCRIPTION="Language and environment for statistical computing and graphics"
HOMEPAGE="http://www.r-project.org/"
@@ -126,7 +126,10 @@ src_compile() {
emake info pdf || die "emake docs failed"
fi
- emake -j1 -C src/nmath/standalone || die "emake math library failed"
+ RMATH_V=0.0.0
+ emake -j1 -C src/nmath/standalone \
+ libRmath_la_LDFLAGS=-Wl,-soname,libRmath.so.${RMATH_V} \
+ || die "emake math library failed"
}
src_install() {
@@ -143,6 +146,12 @@ src_install() {
DESTDIR="${D}" install \
|| die "emake install math library failed"
+ local mv=$(get_major_version ${RMATH_V})
+ mv "${D}"/usr/$(get_libdir)/libRmath.so \
+ "${D}"/usr/$(get_libdir)/libRmath.so.${RMATH_V}
+ dosym libRmath.so.${RMATH_V} /usr/$(get_libdir)/libRmath.so.${mv}
+ dosym libRmath.so.${mv} /usr/$(get_libdir)/libRmath.so
+
# env file
cat > 99R <<-EOF
LDPATH=${R_HOME}/lib
diff --git a/dev-lang/R/metadata.xml b/dev-lang/R/metadata.xml
index a403327c2c84..ec8fee50f867 100644
--- a/dev-lang/R/metadata.xml
+++ b/dev-lang/R/metadata.xml
@@ -1,7 +1,7 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<herd>sci</herd>
+<herd>sci-mathematics</herd>
<longdescription lang="en">
R is GNU S, a system for statistical computation and graphics. It
consists of a language plus a run-time environment with graphics, a