summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuca Barbato <lu_zero@gentoo.org>2006-06-28 10:11:03 +0000
committerLuca Barbato <lu_zero@gentoo.org>2006-06-28 10:11:03 +0000
commit6ffe6156a2a26dc3ea9014ce12461601290977a0 (patch)
tree243189a7b99aad28480f4769e4ef6f7f190cb616 /dev-lang/R
parentdhcp-3.0.4 64 bit issues fixed, removing from mask (diff)
downloadgentoo-2-6ffe6156a2a26dc3ea9014ce12461601290977a0.tar.gz
gentoo-2-6ffe6156a2a26dc3ea9014ce12461601290977a0.tar.bz2
gentoo-2-6ffe6156a2a26dc3ea9014ce12461601290977a0.zip
s:-fpic:-fPIC:g
(Portage version: 2.1.1_pre1-r5)
Diffstat (limited to 'dev-lang/R')
-rw-r--r--dev-lang/R/ChangeLog5
-rw-r--r--dev-lang/R/R-2.3.1.ebuild7
2 files changed, 10 insertions, 2 deletions
diff --git a/dev-lang/R/ChangeLog b/dev-lang/R/ChangeLog
index 8e69bde7971c..8147dfc12694 100644
--- a/dev-lang/R/ChangeLog
+++ b/dev-lang/R/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-lang/R
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/R/ChangeLog,v 1.75 2006/06/17 21:13:18 kugelfang Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/R/ChangeLog,v 1.76 2006/06/28 10:11:03 lu_zero Exp $
+
+ 28 Jun 2006; Luca Barbato <lu_zero@gentoo.org> R-2.3.1.ebuild:
+ Made it use -fPIC instead of -fpic
17 Jun 2006; Danny van Dyk <kugelfang@gentoo.org> R-2.2.1.ebuild:
Marked stable on ia64.
diff --git a/dev-lang/R/R-2.3.1.ebuild b/dev-lang/R/R-2.3.1.ebuild
index 90c236ff1025..efa1118b83ea 100644
--- a/dev-lang/R/R-2.3.1.ebuild
+++ b/dev-lang/R/R-2.3.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/R/R-2.3.1.ebuild,v 1.2 2006/06/02 20:13:01 kugelfang Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/R/R-2.3.1.ebuild,v 1.3 2006/06/28 10:11:03 lu_zero Exp $
inherit fortran toolchain-funcs flag-o-matic
@@ -48,6 +48,11 @@ pkg_setup() {
filter-ldflags -Wl,-Bdirect -Bdirect
}
+src_unpack() {
+ unpack ${A}
+ sed -i -e "s:-fpic:-fPIC:g" ${S}/configure
+}
+
src_compile() {
local myconf="--enable-R-profiling --enable-R-shlib --enable-linux-lfs"