summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2011-02-02 17:54:35 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2011-02-02 17:54:35 +0000
commitbbe324b324cd95ec7540f930d2780d755e153fc8 (patch)
treee40b7ae941ce1b9c945e1bcc73a50a8cc579da86 /dev-lang/bas/files
parentFix duplicate items in GNU Info directory, upstream bug 7942. (diff)
downloadgentoo-2-bbe324b324cd95ec7540f930d2780d755e153fc8.tar.gz
gentoo-2-bbe324b324cd95ec7540f930d2780d755e153fc8.tar.bz2
gentoo-2-bbe324b324cd95ec7540f930d2780d755e153fc8.zip
Initial commit wrt #353356 by Kevin McCarthy.
(Portage version: 2.2.0_alpha19/cvs/Linux x86_64)
Diffstat (limited to 'dev-lang/bas/files')
-rw-r--r--dev-lang/bas/files/bas-2.1-configure.patch28
-rw-r--r--dev-lang/bas/files/bas-2.1-makefile.patch49
2 files changed, 77 insertions, 0 deletions
diff --git a/dev-lang/bas/files/bas-2.1-configure.patch b/dev-lang/bas/files/bas-2.1-configure.patch
new file mode 100644
index 000000000000..2999db9327a2
--- /dev/null
+++ b/dev-lang/bas/files/bas-2.1-configure.patch
@@ -0,0 +1,28 @@
+Remove hardcoded CFLAG -pipe
+Remove hardcoded LDFLAG -g
+
+Disable check for lrint to fix compile warning.
+
+Patch by Kevin McCarthy <signals42@gmail.com>
+
+--- configure.in
++++ configure.in
+@@ -31,8 +31,8 @@
+ AC_PROG_CC
+ if test "$GCC" = yes
+ then
+- CFLAGS="${CFLAGS} ${EXTRA_GCFLAGS}-pipe -Wall -Wno-unused -Wshadow -Wbad-function-cast -Wmissing-prototypes -Wstrict-prototypes -Wcast-align -Wcast-qual -Wpointer-arith -Wwrite-strings -Wmissing-declarations -Wnested-externs -Wundef -pedantic -fno-common"
+- LDFLAGS="${LDFLAGS} ${EXTRA_GLDFLAGS}-g"
++ CFLAGS="${CFLAGS} ${EXTRA_GCFLAGS} -Wall -Wno-unused -Wshadow -Wbad-function-cast -Wmissing-prototypes -Wstrict-prototypes -Wcast-align -Wcast-qual -Wpointer-arith -Wwrite-strings -Wmissing-declarations -Wnested-externs -Wundef -pedantic -fno-common"
++ LDFLAGS="${LDFLAGS} ${EXTRA_GLDFLAGS}"
+ else
+ CFLAGS="${CFLAGS} ${EXTRA_CFLAGS}"
+ LDFLAGS="${LDFLAGS} ${EXTRA_LDFLAGS}"
+@@ -65,7 +65,6 @@
+ exit 1
+ fi
+
+-AC_CHECK_FUNCS(lrint)
+ AC_CHECK_FUNCS(nanosleep)
+
+ AC_CHECK_FUNCS(tgetent,have_tgetent=yes)
diff --git a/dev-lang/bas/files/bas-2.1-makefile.patch b/dev-lang/bas/files/bas-2.1-makefile.patch
new file mode 100644
index 000000000000..3be4bb09eafa
--- /dev/null
+++ b/dev-lang/bas/files/bas-2.1-makefile.patch
@@ -0,0 +1,49 @@
+Fixes makefile.in to respect DESTDIR during install
+Fixes makefile.in to use $MAKE instead of 'make'
+Fixes makefile.in to respect AR during libbas build
+
+Patch by Kevin McCarthy <signals42@gmail.com>
+
+--- Makefile.in
++++ Makefile.in
+@@ -27,7 +27,7 @@
+ libbas.a: auto.o bas.o fs.o global.o token.o program.o \
+ str.o value.o var.o
+ rm -f $@
+- ar cq $@ auto.o bas.o fs.o global.o token.o program.o \
++ $(AR) cq $@ auto.o bas.o fs.o global.o token.o program.o \
+ str.o value.o var.o
+ @RANLIB@ libbas.a
+
+@@ -35,7 +35,7 @@
+ install-po-no:
+ install-po-yes: $(CATALOGS)
+ for cat in $(CATALOGS); do \
+- dir=$(localedir)/`basename $$cat .mo`/LC_MESSAGES; \
++ dir=$(DESTDIR)/$(localedir)/`basename $$cat .mo`/LC_MESSAGES; \
+ [ -d $$dir ] || @INSTALL@ -m 755 -d $$dir; \
+ @INSTALL@ -m 644 $$cat $$dir/bas.mo; \
+ done
+@@ -44,14 +44,14 @@
+ for i in test/test*; do ./$$i || break; done
+
+ install: all
+- @INSTALL@ -m 755 -d @bindir@
+- @INSTALL@ bas @bindir@/bas
+- @INSTALL@ -m 755 -d @libdir@
+- @INSTALL@ -m 644 libbas.a @libdir@/libbas.a
+- @RANLIB@ @libdir@/libbas.a
+- @INSTALL@ -m 755 -d @mandir@/man1
+- @INSTALL@ -m 644 bas.1 @mandir@/man1/bas.1
+- make install-po
++ @INSTALL@ -m 755 -d $(DESTDIR)/@bindir@
++ @INSTALL@ bas $(DESTDIR)/@bindir@/bas
++ @INSTALL@ -m 755 -d $(DESTDIR)/@libdir@
++ @INSTALL@ -m 644 libbas.a $(DESTDIR)/@libdir@/libbas.a
++ @RANLIB@ $(DESTDIR)/@libdir@/libbas.a
++ @INSTALL@ -m 755 -d $(DESTDIR)/@mandir@/man1
++ @INSTALL@ -m 644 bas.1 $(DESTDIR)/@mandir@/man1/bas.1
++ $(MAKE) install-po
+
+ .c.o:
+ $(CC) -c $(CPPFLAGS) $(CFLAGS) $<