summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2007-02-07 16:41:43 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2007-02-07 16:41:43 +0000
commit892d5d30ed5852f6cddca8b7aa1199925c91f320 (patch)
treec361023375a4ef97e88812a372749340bdd44691 /dev-lang/cfortran/cfortran-4.4.ebuild
parentAdd blocker against old versions to make sure there are no more file-collisio... (diff)
downloadgentoo-2-892d5d30ed5852f6cddca8b7aa1199925c91f320.tar.gz
gentoo-2-892d5d30ed5852f6cddca8b7aa1199925c91f320.tar.bz2
gentoo-2-892d5d30ed5852f6cddca8b7aa1199925c91f320.zip
cfortran initial import
(Portage version: 2.1.1-r2)
Diffstat (limited to 'dev-lang/cfortran/cfortran-4.4.ebuild')
-rw-r--r--dev-lang/cfortran/cfortran-4.4.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/dev-lang/cfortran/cfortran-4.4.ebuild b/dev-lang/cfortran/cfortran-4.4.ebuild
new file mode 100644
index 000000000000..cba918c32b72
--- /dev/null
+++ b/dev-lang/cfortran/cfortran-4.4.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/cfortran/cfortran-4.4.ebuild,v 1.1 2007/02/07 16:41:43 bicatali Exp $
+
+inherit eutils
+
+DEB_PR="11"
+
+DESCRIPTION="Header file allowing to call Fortran routines from C and C++"
+SRC_URI="mirror://debian/pool/main/c/${PN}/${PN}_${PV}.orig.tar.gz
+ mirror://debian/pool/main/c/${PN}/${PN}_${PV}-${DEB_PR}.diff.gz"
+HOMEPAGE="http://www-zeus.desy.de/~burow/cfortran/"
+KEYWORDS="~amd64 ~x86"
+LICENSE="LGPL-2"
+IUSE="examples"
+SLOT="0"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${WORKDIR}"/${PN}_${PV}-${DEB_PR}.diff
+ if use examples; then
+ tar xfz cfortran.examples.tar.gz
+ mv eg examples
+ ln -sfn sz1.c examples/sz1/sz1.C
+ ln -sfn pz.c examples/pz/pz.C
+ fi
+}
+
+src_compile() {
+ einfo "No compilation neccessary"
+}
+
+src_install() {
+ insinto /usr/include/cfortran
+ doins cfortran.h
+ dosym /usr/include/cfortran/cfortran.h /usr/include/cfortran.h
+ dodoc cfortran.doc debian/{NEWS,changelog,copyright}
+ insinto /usr/share/doc/${PF}
+ doins cfortran.html index.htm cfortest.c cfortex.f
+ use examples && doins -r examples
+}