summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2001-04-28 18:59:57 +0000
committerAchim Gottinger <achim@gentoo.org>2001-04-28 18:59:57 +0000
commit7fa42706c9e5b9231237592286af1aa9926de7bc (patch)
tree5b39923c68b4b9b653267552ab7d6424e7b788c6 /dev-lang/entity
parentMoved to php (diff)
downloadgentoo-2-7fa42706c9e5b9231237592286af1aa9926de7bc.tar.gz
gentoo-2-7fa42706c9e5b9231237592286af1aa9926de7bc.tar.bz2
gentoo-2-7fa42706c9e5b9231237592286af1aa9926de7bc.zip
*** empty log message ***
Diffstat (limited to 'dev-lang/entity')
-rw-r--r--dev-lang/entity/entity-0.7.2.ebuild69
1 files changed, 58 insertions, 11 deletions
diff --git a/dev-lang/entity/entity-0.7.2.ebuild b/dev-lang/entity/entity-0.7.2.ebuild
index 6f411586e69b..bf0bbf5305bc 100644
--- a/dev-lang/entity/entity-0.7.2.ebuild
+++ b/dev-lang/entity/entity-0.7.2.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Your Name <your email>
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/entity/entity-0.7.2.ebuild,v 1.1 2001/04/28 13:02:22 achim Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/entity/entity-0.7.2.ebuild,v 1.2 2001/04/28 18:59:57 achim Exp $
A=${P}.tar.gz
S=${WORKDIR}/${P}
@@ -11,25 +11,72 @@ HOMEPAGE="http://www.entity.cx"
DEPEND=">=media-libs/imlib-1.9.8.1
>=dev-libs/libpcre-3.2
- >=dev-lang/tcl-tk-8.1.1
- >=sys-devel/perl-5.6"
+ tcltk? ( >=dev-lang/tcl-tk-8.1.1 )
+ perl? ( >=sys-devel/perl-5.6 )
+ python? ( >=dev-lang/python-2.0 )
+ sdl? ( >=media-libs/libsdl-1.1.7 )
+ ssl? ( >=dev-libs/openssl-0.9.6 )
+ gnome? ( >=gnome-base/gnome-libs-1.2.13 )"
src_compile() {
-
- try DEBIAN_ENTITY_MAGIC=voodoo ./configure --prefix=/usr --host=${CHOST} \
+ echo $USE
+ local myconf
+ if [ "`use tcltk`" ]
+ then
+ myconf="--enable-tcl=module --with-tcl=/usr/lib"
+ fi
+ if [ "`use perl`" ]
+ then
+ myconf="$myconf --enable-perl=static"
+ fi
+ if [ "`use python`" ]
+ then
+ myconf="$myconf --enable-python=static"
+ fi
+ if [ "`use ssl`" ]
+ then
+ myconf="$myconf --enable-openssl"
+ fi
+ if [ "`use sdl`" ]
+ then
+ myconf="$myconf --enable-sdl"
+ fi
+ if [ "`use gnome`" ]
+ then
+ myconf="$myconf --enable-gnome"
+ fi
+ try DEBIAN_ENTITY_MAGIC=\"voodoo\" ./configure --prefix=/usr --mandir=/usr/share/man --host=${CHOST} \
--enable-exec-class=yes \
--enable-gtk=module \
- --enable-perl=static --enable-python=no \
- --enable-tcl=module --with-tcl=/usr/lib \
- --enable-c=module \
- --enable-javascript=yes --with-included-njs
- try make
+ --enable-c=module $myconf \
+ --enable-javascript=yes --with-included-njs --enable-csinc
+ try make LDFLAGS=\"-L/usr/lib/python2.0/config/ -lz\"
+
}
src_install () {
+ make DESTDIR=${D} LD_LIBRARY_PATH=${D}/usr/lib install
+ insinto /usr/share/entity/stembuilder
+ doins stembuilder/*.e
+ chmod +x ${D}/usr/share/entity/stembuilder/stembuilder.e
+ insinto /usr/share/entity/apps
+ doins apps/*.e
+ chmod +x ${D}/usr/share/entity/apps/{enview,ev}.e
+ exeinto /usr/share/entity/examples
+ doexe examples/*.e
+ insinto /usr/share/entity/stembuilder/images
+ doins stembuilder/images/*.xpm
- make DESTDIR=${D} install
+ dodoc AUTHORS COPYING ChangeLog LICENSE NEWS README TODO
+ docinto txt
+ dodoc docs/README* docs/*.txt docs/*.ascii
+ docinto html
+ dodoc docs/*.html
+ docinto print
+ dodoc docs/*.ps
+ docinto sgml
+ dodoc docs/*.sgml
}