summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2013-02-02 08:25:07 +0000
committerPatrick Lauer <patrick@gentoo.org>2013-02-02 08:25:07 +0000
commit82bd129b44ad15dfc8bd7d82a6e4e7682735abd3 (patch)
tree1800a4f5cb4163d53979b7fb74f6f0d1cd1cc32f /dev-lang/fpc-ide/fpc-ide-2.6.0.ebuild
parentBump (diff)
downloadgentoo-2-82bd129b44ad15dfc8bd7d82a6e4e7682735abd3.tar.gz
gentoo-2-82bd129b44ad15dfc8bd7d82a6e4e7682735abd3.tar.bz2
gentoo-2-82bd129b44ad15dfc8bd7d82a6e4e7682735abd3.zip
Bump
(Portage version: 2.2.0_alpha161/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'dev-lang/fpc-ide/fpc-ide-2.6.0.ebuild')
-rw-r--r--dev-lang/fpc-ide/fpc-ide-2.6.0.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/dev-lang/fpc-ide/fpc-ide-2.6.0.ebuild b/dev-lang/fpc-ide/fpc-ide-2.6.0.ebuild
new file mode 100644
index 000000000000..82dcfad47b27
--- /dev/null
+++ b/dev-lang/fpc-ide/fpc-ide-2.6.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/fpc-ide/fpc-ide-2.6.0.ebuild,v 1.1 2013/02/02 08:25:07 patrick Exp $
+
+EAPI=5
+
+S="${WORKDIR}/fpcbuild-${PV}/fpcsrc/ide"
+
+HOMEPAGE="http://www.freepascal.org/"
+DESCRIPTION="Free Pascal Compiler Integrated Development Environment"
+SRC_URI="mirror://sourceforge/freepascal/fpcbuild-${PV}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2 LGPL-2.1-with-linking-exception"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+DEPEND="~dev-lang/fpc-${PV}"
+RDEPEND="${DEPEND}"
+
+# test gives compile errors, was not updated with fpc changes
+RESTRICT="test"
+
+src_prepare() {
+ find "${WORKDIR}" -name Makefile -exec sed -i -e 's/ -Xs / /g' {} + || die
+
+ # Use default configuration (minus stripping) unless specifically requested otherwise
+ if ! test ${PPC_CONFIG_PATH+set}; then
+ local FPCVER=$(fpc -iV)
+ export PPC_CONFIG_PATH="${WORKDIR}"
+ sed -e 's/^FPBIN=/#&/' /usr/lib/fpc/${FPCVER}/samplecfg |
+ sh -s /usr/lib/fpc/${FPCVER} "${PPC_CONFIG_PATH}" || die
+ sed -i -e '/^-Xs/d' "${PPC_CONFIG_PATH}"/fpc.cfg || die
+ fi
+}
+
+src_compile() {
+ emake -j1 || die "make failed"
+}
+
+src_install() {
+ emake -j1 INSTALL_PREFIX="${D}"usr install || die "make install failed"
+}
+
+pkg_postinst() {
+ einfo "To read the documentation, enable the doc USE flag for dev-lang/fpc,"
+ einfo "and add /usr/share/doc/fpc-${PV}/fpctoc.htx to the Help Files list."
+}