summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2011-04-08 21:37:21 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2011-04-08 21:37:21 +0000
commitef83b123c6d14307c41fb29c19286fc2e68f2efd (patch)
tree5a1cf5aadd3c99952a22e47efcfcd25ea78b066c /dev-lang/gdl
parentNow builds a shared library, older static non-PIC library is built with use f... (diff)
downloadgentoo-2-ef83b123c6d14307c41fb29c19286fc2e68f2efd.tar.gz
gentoo-2-ef83b123c6d14307c41fb29c19286fc2e68f2efd.tar.bz2
gentoo-2-ef83b123c6d14307c41fb29c19286fc2e68f2efd.zip
Version bump. Now really unbundle antlr
(Portage version: 2.1.9.45/cvs/Linux x86_64)
Diffstat (limited to 'dev-lang/gdl')
-rw-r--r--dev-lang/gdl/ChangeLog8
-rw-r--r--dev-lang/gdl/files/gdl-0.9.1-antlr.patch38
-rw-r--r--dev-lang/gdl/gdl-0.9-r1.ebuild4
-rw-r--r--dev-lang/gdl/gdl-0.9.1.ebuild103
4 files changed, 150 insertions, 3 deletions
diff --git a/dev-lang/gdl/ChangeLog b/dev-lang/gdl/ChangeLog
index e5ed9e527eab..4ba6b25b30d0 100644
--- a/dev-lang/gdl/ChangeLog
+++ b/dev-lang/gdl/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-lang/gdl
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/gdl/ChangeLog,v 1.23 2011/01/04 05:04:15 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/gdl/ChangeLog,v 1.24 2011/04/08 21:37:21 bicatali Exp $
+
+*gdl-0.9.1 (08 Apr 2011)
+
+ 08 Apr 2011; Sébastien Fabbro <bicatali@gentoo.org> gdl-0.9-r1.ebuild,
+ +gdl-0.9.1.ebuild, +files/gdl-0.9.1-antlr.patch:
+ Version bump. Now really unbundle antlr
*gdl-0.9-r1 (04 Jan 2011)
diff --git a/dev-lang/gdl/files/gdl-0.9.1-antlr.patch b/dev-lang/gdl/files/gdl-0.9.1-antlr.patch
new file mode 100644
index 000000000000..24e69e51dc77
--- /dev/null
+++ b/dev-lang/gdl/files/gdl-0.9.1-antlr.patch
@@ -0,0 +1,38 @@
+--- gnudatalanguage-0.9.1.orig/src/Makefile.am
++++ gnudatalanguage-0.9.1/src/Makefile.am
+@@ -1,6 +1,6 @@
+ # set the include path found by configure
+ INCLUDES = $(EXT_INCLUDES) $(all_includes)
+-SUBDIRS = antlr pro
++SUBDIRS = pro
+ noinst_HEADERS = gdlwidget.hpp prognode.hpp prognodeexpr.hpp
+
+ cpp_hpp_files = accessdesc.hpp arrayindex.hpp assocdata.cpp assocdata.hpp \
+@@ -57,7 +57,7 @@ gdl_SOURCES = $(cpp_hpp_files) gdl.cpp l
+ gdl_CXXFLAGS = $(AM_CXXFLAGS)
+ # the library search path.
+ gdl_LDFLAGS = $(all_libraries)
+-gdl_LDADD = $(top_builddir)/src/antlr/libantlr.a -L/usr/X11R6/lib64 -L/usr/X11R6/lib -lX11
++gdl_LDADD = -lantlr -L/usr/X11R6/lib64 -L/usr/X11R6/lib -lX11
+ endif
+
+ # build as library (for python module)
+@@ -73,6 +73,6 @@ else
+ libgdl_la_LDFLAGS = $(all_libraries) -Wl,-z,muldefs
+ endif
+
+-libgdl_la_LIBADD = $(top_builddir)/src/antlr/libantlr.la -L/usr/X11R6/lib64 -L/usr/X11R6/lib -lX11
++libgdl_la_LIBADD = -lantlr -L/usr/X11R6/lib64 -L/usr/X11R6/lib -lX11
+ endif
+
+--- gnudatalanguage-0.9.orig/configure.in
++++ gnudatalanguage-0.9/configure.in
+@@ -1074,7 +1074,7 @@ dnl AC_CHECK_FUNCS(strdup strtod strtol
+ dnl perform program name transformation
+ dnl AC_ARG_PROGRAM
+
+-AC_CONFIG_FILES(Makefile src/Makefile src/antlr/Makefile src/pro/Makefile src/pro/dicom/Makefile testsuite/Makefile doc/Makefile)
++AC_CONFIG_FILES(Makefile src/Makefile src/pro/Makefile src/pro/dicom/Makefile testsuite/Makefile doc/Makefile)
+ AC_OUTPUT
+
+ dnl == summary table =======================================
diff --git a/dev-lang/gdl/gdl-0.9-r1.ebuild b/dev-lang/gdl/gdl-0.9-r1.ebuild
index 0874d4f87bcf..71bda1b75bb7 100644
--- a/dev-lang/gdl/gdl-0.9-r1.ebuild
+++ b/dev-lang/gdl/gdl-0.9-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/gdl/gdl-0.9-r1.ebuild,v 1.1 2011/01/04 05:04:15 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/gdl/gdl-0.9-r1.ebuild,v 1.2 2011/04/08 21:37:21 bicatali Exp $
EAPI=3
@@ -36,7 +36,7 @@ RDEPEND="sys-libs/readline
wxwidgets? ( x11-libs/wxGTK:2.8[X] )"
DEPEND="${RDEPEND}
- dev-java/antlr"
+ dev-java/antlr:0"
pkg_setup() {
use wxwidgets && wxwidgets_pkg_setup
diff --git a/dev-lang/gdl/gdl-0.9.1.ebuild b/dev-lang/gdl/gdl-0.9.1.ebuild
new file mode 100644
index 000000000000..67cc73d7cb9e
--- /dev/null
+++ b/dev-lang/gdl/gdl-0.9.1.ebuild
@@ -0,0 +1,103 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/gdl/gdl-0.9.1.ebuild,v 1.1 2011/04/08 21:37:21 bicatali Exp $
+
+EAPI=3
+
+WX_GTK_VER="2.8"
+PYTHON_DEPEND="python? 2"
+SUPPORT_PYTHON_ABIS="1"
+
+inherit autotools eutils wxwidgets python
+
+RESTRICT_PYTHON_ABIS="3.*"
+
+DESCRIPTION="An Interactive Data Language compatible incremental compiler"
+HOMEPAGE="http://gnudatalanguage.sourceforge.net/"
+SRC_URI="mirror://sourceforge/gnudatalanguage/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="fftw grib hdf hdf5 imagemagick netcdf openmp python udunits wxwidgets X"
+
+RDEPEND="sys-libs/readline
+ sys-libs/ncurses
+ sci-libs/gsl
+ sci-libs/plplot
+ fftw? ( >=sci-libs/fftw-3 )
+ grib? ( sci-libs/grib_api )
+ hdf? ( sci-libs/hdf )
+ hdf5? ( sci-libs/hdf5 )
+ imagemagick? ( media-gfx/imagemagick )
+ netcdf? ( sci-libs/netcdf )
+ python? ( dev-python/matplotlib )
+ udunits? ( >=sci-libs/udunits-2 )
+ wxwidgets? ( x11-libs/wxGTK:2.8[X] )"
+
+DEPEND="${RDEPEND}
+ >=dev-java/antlr-2.7.7-r2:0[cxx]"
+
+pkg_setup() {
+ use wxwidgets && wxwidgets_pkg_setup
+}
+
+src_prepare() {
+ use hdf5 && has_version sci-libs/hdf5[mpi] && export CXX=mpicxx
+
+ epatch \
+ "${FILESDIR}"/${PN}-0.9_rc2-gcc4.4.patch \
+ "${FILESDIR}"/${PN}-0.9_rc4-gcc4.3.patch \
+ "${FILESDIR}"/${PN}-0.9.1-antlr.patch
+
+ rm -rf src/antlr
+ # adjust the *.pro file install path
+ sed -i \
+ -e "s:datasubdir=.*$:datasubdir=\"${PN}\":" \
+ configure.in || die "Failed to fix *.pro install patch."
+ eautoreconf
+ use python && python_copy_sources
+}
+
+src_configure() {
+ configuration() {
+ econf \
+ $(use_with X x) \
+ $(use_with fftw) \
+ $(use_with grib) \
+ $(use_with hdf) \
+ $(use_with hdf5) \
+ $(use_with netcdf) \
+ $(use_with imagemagick Magick) \
+ $(use_with openmp) \
+ $(use_with udunits) \
+ $(use_with wxwidgets wxWidgets) \
+ $@
+ }
+ configuration --disable-python_module
+ use python && \
+ python_execute_function -s configuration --enable-python_module
+}
+
+src_compile() {
+ default
+ use python && python_src_compile
+}
+
+src_test() {
+ cd "${S}"/testsuite
+ echo ".r test_suite" | ../src/gdl
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ if use python; then
+ installation() {
+ exeinto $(python_get_sitedir)
+ newexe src/.libs/libgdl.so.0.0.0 GDL.so
+ }
+ python_execute_function -s installation
+ dodoc PYTHON.txt
+ fi
+ dodoc README AUTHORS ChangeLog NEWS TODO HACKING
+}