summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2006-02-15 00:12:42 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2006-02-15 00:12:42 +0000
commitdd019bfb6637431595ea45f424c5f7ab5ae0db56 (patch)
tree458c80be4bb019c1527170d2ed904b766b12480b /dev-lang/gforth/gforth-0.6.2-r1.ebuild
parentStable on amd64. Bug #122755. (diff)
downloadgentoo-2-dd019bfb6637431595ea45f424c5f7ab5ae0db56.tar.gz
gentoo-2-dd019bfb6637431595ea45f424c5f7ab5ae0db56.tar.bz2
gentoo-2-dd019bfb6637431595ea45f424c5f7ab5ae0db56.zip
Added metadata.xml; Added self to it as new maintainer; Applied patch described in Bug #113296; Added dependency on dev-libs/ffcall which resolves Bug #113211.
(Portage version: 2.1_pre4-r1)
Diffstat (limited to 'dev-lang/gforth/gforth-0.6.2-r1.ebuild')
-rw-r--r--dev-lang/gforth/gforth-0.6.2-r1.ebuild64
1 files changed, 64 insertions, 0 deletions
diff --git a/dev-lang/gforth/gforth-0.6.2-r1.ebuild b/dev-lang/gforth/gforth-0.6.2-r1.ebuild
new file mode 100644
index 000000000000..c6717a4666d1
--- /dev/null
+++ b/dev-lang/gforth/gforth-0.6.2-r1.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/gforth/gforth-0.6.2-r1.ebuild,v 1.1 2006/02/15 00:12:42 mkennedy Exp $
+
+inherit elisp-common eutils toolchain-funcs
+
+DESCRIPTION="GNU Forth is a fast and portable implementation of the ANSI Forth language"
+HOMEPAGE="http://www.gnu.org/software/gforth"
+SRC_URI="http://www.complang.tuwien.ac.at/forth/gforth/${P}.tar.gz
+ http://www.complang.tuwien.ac.at/forth/gforth/Patches/${PV}-debug.diff"
+
+LICENSE="GPL-2"
+SLOT="0"
+# KEYWORDS="~amd64 ~ppc ~ppc-macos ~x86"
+KEYWORDS=" ~ppc ~x86" # dev-libs/ffcall needs to be keyworded for amd64 and ppc-macos
+IUSE="emacs"
+
+DEPEND="virtual/libc
+ dev-libs/ffcall
+ emacs? ( virtual/emacs )"
+
+SITEFILE=50gforth-gentoo.el
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/gforth.el-gentoo.patch || die
+ epatch ${FILESDIR}/${PV}-c-to-forth-to-c.patch || die
+ epatch ${DISTDIR}/${PV}-debug.diff || die
+
+}
+
+src_compile() {
+ econf CC="$(tc-getCC) -fno-reorder-blocks -fno-inline" --enable-force-reg || die "econf failed"
+ make || die
+ if use emacs; then
+ elisp-comp *.el || die
+ fi
+}
+
+src_install() {
+ make \
+ libdir=${D}/usr/lib \
+ infodir=${D}/usr/share/info \
+ mandir=${D}/usr/share/man \
+ datadir=${D}/usr/share \
+ bindir=${D}/usr/bin \
+ install || die
+
+ dodoc AUTHORS BUGS ChangeLog NEWS* README* ToDo doc/glossaries.doc doc/*.ps
+
+ if use emacs; then
+ elisp-install ${PN} *.el *.elc
+ elisp-site-file-install ${FILESDIR}/${SITEFILE}
+ fi
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}