summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2003-04-02 10:59:32 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2003-04-02 10:59:32 +0000
commit033d52e0b2c940c4adfe29069a899e60b22bdbc3 (patch)
tree25c89f0f13af20589abe1a595b7d62d595c108f0 /dev-lang/gforth
parentnew use flag: emacs (diff)
downloadgentoo-2-033d52e0b2c940c4adfe29069a899e60b22bdbc3.tar.gz
gentoo-2-033d52e0b2c940c4adfe29069a899e60b22bdbc3.tar.bz2
gentoo-2-033d52e0b2c940c4adfe29069a899e60b22bdbc3.zip
minor version bump, ebuild clean up, added USE flag for emacs
Diffstat (limited to 'dev-lang/gforth')
-rw-r--r--dev-lang/gforth/ChangeLog8
-rw-r--r--dev-lang/gforth/files/50gforth-gentoo.el7
-rw-r--r--dev-lang/gforth/files/digest-gforth-0.6.11
-rw-r--r--dev-lang/gforth/files/gforth.el-gentoo.patch40
-rw-r--r--dev-lang/gforth/gforth-0.6.1.ebuild58
5 files changed, 113 insertions, 1 deletions
diff --git a/dev-lang/gforth/ChangeLog b/dev-lang/gforth/ChangeLog
index 326a77d7752b..0671628d422c 100644
--- a/dev-lang/gforth/ChangeLog
+++ b/dev-lang/gforth/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-lang/gforth
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/gforth/ChangeLog,v 1.2 2003/02/12 05:56:02 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/gforth/ChangeLog,v 1.3 2003/04/02 10:59:32 mkennedy Exp $
+
+*gforth-0.6.1 (02 Apr 2003)
+
+ 02 Apr 2003; Matthew Kennedy <mkennedy@gentoo.org> gforth-0.6.1.ebuild,
+ files/50gforth-gentoo.el, files/gforth.el-gentoo.patch:
+ minor version bump, ebuild clean up, support for emacs USE flag
*gforth-0.5.0.ebuild (04 ñÎ× 2003)
diff --git a/dev-lang/gforth/files/50gforth-gentoo.el b/dev-lang/gforth/files/50gforth-gentoo.el
new file mode 100644
index 000000000000..b2be92698bbb
--- /dev/null
+++ b/dev-lang/gforth/files/50gforth-gentoo.el
@@ -0,0 +1,7 @@
+
+;;; gforth site-lisp configuration
+
+(add-to-list 'load-path "@SITELISP@")
+
+(autoload 'forth-mode "gforth" "Autoload for `forth-mode'." t)
+(autoload 'run-forth "gforth" "Autoload for `run-forth'." t)
diff --git a/dev-lang/gforth/files/digest-gforth-0.6.1 b/dev-lang/gforth/files/digest-gforth-0.6.1
new file mode 100644
index 000000000000..b92a126aa04f
--- /dev/null
+++ b/dev-lang/gforth/files/digest-gforth-0.6.1
@@ -0,0 +1 @@
+MD5 91855c11c3989d0ba92139e278f047d0 gforth-0.6.1.tar.gz 1892711
diff --git a/dev-lang/gforth/files/gforth.el-gentoo.patch b/dev-lang/gforth/files/gforth.el-gentoo.patch
new file mode 100644
index 000000000000..163c90858800
--- /dev/null
+++ b/dev-lang/gforth/files/gforth.el-gentoo.patch
@@ -0,0 +1,40 @@
+--- gforth.el 2003-03-09 09:05:33.000000000 -0600
++++ gforth.el~ 2003-04-02 04:34:42.000000000 -0600
+@@ -65,22 +65,24 @@
+ (or (< emacs-major-version major)
+ (and (= emacs-major-version major) (< emacs-minor-version minor))))
+
+-;; Code ripped from `subr.el' for compatability with Emacs versions
+-;; prior to 20.1
+-(eval-when-compile
+- (if (forth-emacs-older 20 1)
+- (progn
+- (defmacro when (cond &rest body)
+- "If COND yields non-nil, do BODY, else return nil."
+- (list 'if cond (cons 'progn body)))
+- (defmacro unless (cond &rest body)
+- "If COND yields nil, do BODY, else return nil."
+- (cons 'if (cons cond (cons nil body)))))))
++;; ;; Code ripped from `subr.el' for compatability with Emacs versions
++;; ;; prior to 20.1
++;; (eval-when-compile
++;; (if (forth-emacs-older 20 1)
++;; (progn
++;; (defmacro when (cond &rest body)
++;; "If COND yields non-nil, do BODY, else return nil."
++;; (list 'if cond (cons 'progn body)))
++;; (defmacro unless (cond &rest body)
++;; "If COND yields nil, do BODY, else return nil."
++;; (cons 'if (cons cond (cons nil body)))))))
+
+ ;; `no-error' argument of require not supported in Emacs versions
+ ;; prior to 20.4 :-(
+-(defun forth-require (feature)
+- (condition-case err (require feature) (error nil)))
++
++(eval-when-compile
++ (defun forth-require (feature)
++ (condition-case err (require feature) (error nil))))
+
+ (require 'font-lock)
+
diff --git a/dev-lang/gforth/gforth-0.6.1.ebuild b/dev-lang/gforth/gforth-0.6.1.ebuild
new file mode 100644
index 000000000000..16c1fcfe4294
--- /dev/null
+++ b/dev-lang/gforth/gforth-0.6.1.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/gforth/gforth-0.6.1.ebuild,v 1.1 2003/04/02 10:59:32 mkennedy Exp $
+
+IUSE="emacs"
+
+inherit elisp
+
+S=${WORKDIR}/${P}
+DESCRIPTION="GNU Forth is a fast and portable implementation of the ANSI Forth language"
+HOMEPAGE="http://www.gnu.org/software/gforth"
+SRC_URI="http://www.complang.tuwien.ac.at/forth/gforth/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+
+DEPEND="virtual/glibc
+ emacs? ( virtual/emacs )"
+
+SITEFILE=50gforth-gentoo.el
+
+src_unpack() {
+ unpack ${A}
+ cd ${S} && patch -p0 <${FILESDIR}/gforth.el-gentoo.patch || die
+}
+
+src_compile() {
+ econf --enable-force-reg --without-debug || die "./configure failed"
+ make XCFLAGS="" ENGINE_FLAGS="" || die
+
+ use emacs && emacs --batch -f batch-byte-compile --no-site-file --no-init-file *.el
+}
+
+src_install () {
+ make install libdir=${D}/usr/lib \
+ infodir=${D}/usr/share/info \
+ mandir=${D}/usr/share/man \
+ datadir=${D}/usr/share \
+ bindir=${D}/usr/bin \
+ install || die
+
+ dodoc AUTHORS BUGS COPYING* ChangeLog NEWS* README* ToDo doc/glossaries.doc doc/*.ps
+
+ if use emacs
+ then
+ elisp-install ${PN} *.el *.elc
+ elisp-site-file-install ${FILESDIR}/${SITEFILE}
+ fi
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}