summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndres Loeh <kosmikus@gentoo.org>2004-03-31 09:20:12 +0000
committerAndres Loeh <kosmikus@gentoo.org>2004-03-31 09:20:12 +0000
commit0a456ba71f655799481c270cd757c111e5cda5ca (patch)
tree73e88e3804490aa8ca363232d2b54e1774c86290 /dev-lang/ghc-bin/ghc-bin-5.04.3.ebuild
parentNew version, masked for now (Manifest recommit) (diff)
downloadgentoo-2-0a456ba71f655799481c270cd757c111e5cda5ca.tar.gz
gentoo-2-0a456ba71f655799481c270cd757c111e5cda5ca.tar.bz2
gentoo-2-0a456ba71f655799481c270cd757c111e5cda5ca.zip
marked ghc-bin-6.2 stable, removed ghc-bin-5.X
Diffstat (limited to 'dev-lang/ghc-bin/ghc-bin-5.04.3.ebuild')
-rw-r--r--dev-lang/ghc-bin/ghc-bin-5.04.3.ebuild63
1 files changed, 0 insertions, 63 deletions
diff --git a/dev-lang/ghc-bin/ghc-bin-5.04.3.ebuild b/dev-lang/ghc-bin/ghc-bin-5.04.3.ebuild
deleted file mode 100644
index d87f9b3fa25b..000000000000
--- a/dev-lang/ghc-bin/ghc-bin-5.04.3.ebuild
+++ /dev/null
@@ -1,63 +0,0 @@
-# Copyright 1999-2004 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ghc-bin/ghc-bin-5.04.3.ebuild,v 1.5 2004/03/23 00:29:48 mattam Exp $
-
-IUSE="opengl"
-
-S="${WORKDIR}/ghc-${PV}"
-DESCRIPTION="Glasgow Haskell Compiler"
-SRC_URI=" ppc? ( http://www.haskell.org/ghc/dist/${PV}/ghc-${PV}-powerpc-unknown-linux.tar.bz2 )
-x86? ( http://www.haskell.org/ghc/dist/${PV}/ghc-${PV}-i386-unknown-linux.tar.bz2 )"
-HOMEPAGE="http://www.haskell.org"
-
-LICENSE="as-is"
-KEYWORDS="x86 ppc -sparc -alpha"
-SLOT="0"
-
-LOC="/opt/ghc"
-
-DEPEND="virtual/glibc"
-RDEPEND=">=dev-lang/perl-5.6.1
- >=sys-devel/gcc-2.95.3
- >=dev-libs/gmp-4.1
- opengl? ( virtual/opengl
- virtual/glu
- virtual/glut )"
-
-PROVIDE="virtual/ghc"
-
-src_compile() {
- econf || die "./configure failed"
-}
-
-src_install () {
- make \
- prefix=${D}${LOC} \
- datadir=${D}${LOC}/share \
- mandir=${D}${LOC}/share/man \
- infodir=${D}${LOC}/share/info \
- install || die
-
- # Install documentation.
- dodoc ANNOUNCE INSTALL LICENSE README VERSION
-
- cd ${D}${LOC}/share
- mv hslibs.ps users_guide.ps html ${D}/usr/share/doc/${PF}
-
- #ghc seems to set locations in wrapper scripts from make install
- #need to strip the ${D} part out
- cd ${D}${LOC}/bin
- clean_wrappers ghc-${PV} ghci-${PV} ghc-pkg-${PV} hsc2hs
-
- insinto /etc/env.d
- doins ${FILESDIR}/10ghc
-}
-
-clean_wrappers () {
- for i in $*; do
- mv ${i} ${i}-orig
- sed -e "s:${D}::" ${i}-orig > ${i}
- chmod a+x ${i}
- rm ${i}-orig
- done
-}