summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2010-07-14 09:02:35 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2010-07-14 09:02:35 +0000
commitadbca15cce5ddbc6c3c64f713c092172f3ff3d4e (patch)
tree1525efee38f77b301e3f0ba6941c8c1137847f64 /dev-lang/ghc/ghc-6.8.2-r1.ebuild
parentStable on amd64 wrt bug #328071 (diff)
downloadgentoo-2-adbca15cce5ddbc6c3c64f713c092172f3ff3d4e.tar.gz
gentoo-2-adbca15cce5ddbc6c3c64f713c092172f3ff3d4e.tar.bz2
gentoo-2-adbca15cce5ddbc6c3c64f713c092172f3ff3d4e.zip
Added ability to bootstrap ghc on systems with gmp-5
To understand why it is supposed to work, please, read comments in dev-lang/ghc/files/ghc-apply-gmp-hack (Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'dev-lang/ghc/ghc-6.8.2-r1.ebuild')
-rw-r--r--dev-lang/ghc/ghc-6.8.2-r1.ebuild6
1 files changed, 4 insertions, 2 deletions
diff --git a/dev-lang/ghc/ghc-6.8.2-r1.ebuild b/dev-lang/ghc/ghc-6.8.2-r1.ebuild
index 69fd56cbf92c..d6f6bdbe92fe 100644
--- a/dev-lang/ghc/ghc-6.8.2-r1.ebuild
+++ b/dev-lang/ghc/ghc-6.8.2-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ghc/ghc-6.8.2-r1.ebuild,v 1.3 2010/07/01 20:27:50 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ghc/ghc-6.8.2-r1.ebuild,v 1.4 2010/07/14 09:02:35 slyfox Exp $
# Brief explanation of the bootstrap logic:
#
@@ -28,7 +28,7 @@
# re-emerge ghc (or ghc-bin). People using vanilla gcc can switch between
# gcc-3.x and 4.x with no problems.
-inherit base bash-completion eutils flag-o-matic toolchain-funcs ghc-package versionator
+inherit base bash-completion eutils flag-o-matic multilib toolchain-funcs ghc-package versionator
DESCRIPTION="The Glasgow Haskell Compiler"
HOMEPAGE="http://www.haskell.org/ghc/"
@@ -137,6 +137,8 @@ pkg_setup() {
src_unpack() {
base_src_unpack
+ source "${FILESDIR}/ghc-apply-gmp-hack" "$(get_libdir)"
+
ghc_setup_cflags
# Modify the ghc driver script to use GHC_CFLAGS