summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuis Francisco Araujo <araujo@gentoo.org>2011-10-10 21:29:46 +0000
committerLuis Francisco Araujo <araujo@gentoo.org>2011-10-10 21:29:46 +0000
commitbc1fad4b41d07e9fb2fae479f883cbba320ac9ee (patch)
tree686f437b88f2b9d071a91afb717c41ddf82cc874 /dev-lang/gnu-smalltalk/gnu-smalltalk-3.2.4.ebuild
parentarm stable, bug #385221 (diff)
downloadgentoo-2-bc1fad4b41d07e9fb2fae479f883cbba320ac9ee.tar.gz
gentoo-2-bc1fad4b41d07e9fb2fae479f883cbba320ac9ee.tar.bz2
gentoo-2-bc1fad4b41d07e9fb2fae479f883cbba320ac9ee.zip
Use EAPI=3. Include src_prepare and src_configure
(Portage version: 2.1.10.25/cvs/Linux x86_64)
Diffstat (limited to 'dev-lang/gnu-smalltalk/gnu-smalltalk-3.2.4.ebuild')
-rw-r--r--dev-lang/gnu-smalltalk/gnu-smalltalk-3.2.4.ebuild13
1 files changed, 7 insertions, 6 deletions
diff --git a/dev-lang/gnu-smalltalk/gnu-smalltalk-3.2.4.ebuild b/dev-lang/gnu-smalltalk/gnu-smalltalk-3.2.4.ebuild
index bbb2f9e316e7..b94e45fa893d 100644
--- a/dev-lang/gnu-smalltalk/gnu-smalltalk-3.2.4.ebuild
+++ b/dev-lang/gnu-smalltalk/gnu-smalltalk-3.2.4.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/gnu-smalltalk/gnu-smalltalk-3.2.4.ebuild,v 1.1 2011/10/09 23:25:33 araujo Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/gnu-smalltalk/gnu-smalltalk-3.2.4.ebuild,v 1.2 2011/10/10 21:29:46 araujo Exp $
-EAPI="0"
+EAPI="3"
inherit elisp-common flag-o-matic eutils
@@ -30,13 +30,11 @@ S="${WORKDIR}/smalltalk-${PV}"
SITEFILE=50gnu-smalltalk-gentoo.el
-src_unpack() {
- unpack ${A}
- cd "${S}"
+src_prepare() {
epatch "${FILESDIR}"/SequenceableCollection-size-3.2.4.patch
}
-src_compile() {
+src_configure() {
replace-flags '-O3' '-O2'
econf \
--libdir=/usr/$(get_libdir) \
@@ -49,6 +47,9 @@ src_compile() {
$(use_with tk tcl /usr/$(get_libdir)) \
$(use_with tk tk /usr/$(get_libdir)) \
$(use_enable gtk gtk)
+}
+
+src_compile() {
emake || die "emake failed"
use emacs && elisp-compile *.el
}