summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuis Francisco Araujo <araujo@gentoo.org>2008-01-13 23:03:40 +0000
committerLuis Francisco Araujo <araujo@gentoo.org>2008-01-13 23:03:40 +0000
commit0acbc630f1f3f9a26c31057249ad7cc9972711b4 (patch)
tree3f7765af8fd6b37ac4ff7f474a8c763ab6b23a16 /dev-lang/gnu-smalltalk
parentinitial commit, basic ebuild contributed by Michael <gentoo AT webhippo DOT o... (diff)
downloadgentoo-2-0acbc630f1f3f9a26c31057249ad7cc9972711b4.tar.gz
gentoo-2-0acbc630f1f3f9a26c31057249ad7cc9972711b4.tar.bz2
gentoo-2-0acbc630f1f3f9a26c31057249ad7cc9972711b4.zip
Adding new version and fixing libsigsegv collision. Fixing bugs #197251 , #205342
(Portage version: 2.1.4)
Diffstat (limited to 'dev-lang/gnu-smalltalk')
-rw-r--r--dev-lang/gnu-smalltalk/ChangeLog10
-rw-r--r--dev-lang/gnu-smalltalk/files/digest-gnu-smalltalk-3.03
-rw-r--r--dev-lang/gnu-smalltalk/gnu-smalltalk-3.0.ebuild62
3 files changed, 73 insertions, 2 deletions
diff --git a/dev-lang/gnu-smalltalk/ChangeLog b/dev-lang/gnu-smalltalk/ChangeLog
index 3cb4334a8ee0..693cb6eebdeb 100644
--- a/dev-lang/gnu-smalltalk/ChangeLog
+++ b/dev-lang/gnu-smalltalk/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-lang/gnu-smalltalk
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/gnu-smalltalk/ChangeLog,v 1.31 2007/09/23 18:31:15 araujo Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/gnu-smalltalk/ChangeLog,v 1.32 2008/01/13 23:03:40 araujo Exp $
+
+*gnu-smalltalk-3.0 (13 Jan 2008)
+
+ 13 Jan 2008; Luis F. Araujo <araujo@gentoo.org> +gnu-smalltalk-3.0.ebuild:
+ Adding new version and fixing libsigsegv collision. Fixing bugs #197251 ,
+ #205342
*gnu-smalltalk-2.3.6 (23 Sep 2007)
diff --git a/dev-lang/gnu-smalltalk/files/digest-gnu-smalltalk-3.0 b/dev-lang/gnu-smalltalk/files/digest-gnu-smalltalk-3.0
new file mode 100644
index 000000000000..14bf74651a46
--- /dev/null
+++ b/dev-lang/gnu-smalltalk/files/digest-gnu-smalltalk-3.0
@@ -0,0 +1,3 @@
+MD5 8dd423609673edfa62694142db773a56 smalltalk-3.0.tar.gz 4599090
+RMD160 d0c9400d312ce0a830d3cc916ce0cb588e5ef184 smalltalk-3.0.tar.gz 4599090
+SHA256 e97afcfbd2cd269d13c095ae71770c01f10f5e912aae824aaccc92bce62d50a7 smalltalk-3.0.tar.gz 4599090
diff --git a/dev-lang/gnu-smalltalk/gnu-smalltalk-3.0.ebuild b/dev-lang/gnu-smalltalk/gnu-smalltalk-3.0.ebuild
new file mode 100644
index 000000000000..1ad88444751e
--- /dev/null
+++ b/dev-lang/gnu-smalltalk/gnu-smalltalk-3.0.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/gnu-smalltalk/gnu-smalltalk-3.0.ebuild,v 1.1 2008/01/13 23:03:40 araujo Exp $
+
+inherit elisp-common flag-o-matic eutils
+
+DESCRIPTION="GNU Smalltalk"
+HOMEPAGE="http://smalltalk.gnu.org"
+SRC_URI="http://ftp.gnu.org/gnu/smalltalk/smalltalk-${PV}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="tk readline emacs gtk gmp"
+
+DEPEND="sys-libs/gdbm
+ sys-apps/debianutils
+ !dev-libs/libsigsegv
+ emacs? ( virtual/emacs )
+ readline? ( sys-libs/readline )
+ tk? ( dev-lang/tk )
+ gtk? ( =x11-libs/gtk+-2* )
+ gmp? ( dev-libs/gmp )"
+RDEPEND=""
+
+S="${WORKDIR}/smalltalk-${PV}"
+
+SITEFILE=50gnu-smalltalk-gentoo.el
+
+src_compile() {
+ replace-flags '-O3' '-O2'
+ ./configure --prefix=/usr \
+ `use_with emacs emacs` \
+ `use_with readline readline` \
+ `use_with gmp gmp` \
+ `use_with tk tcl /usr/lib` \
+ `use_with tk tk /usr/lib` \
+ `use_enable gtk gtk` \
+ || die
+ emake || die "emake failed"
+ use emacs && elisp-compile *.el
+}
+
+src_install() {
+ make prefix="${D}/usr" mandir="${D}/usr/share/man" \
+ infodir="${D}/usr/share/info" \
+ lispdir="${D}/usr/share/emacs/site-lisp/gnu-smalltalk" \
+ libdir="${D}/usr/lib" install || die
+ dodoc AUTHORS COPYING* ChangeLog NEWS README THANKS TODO
+ if use emacs; then
+ elisp-install "${PN}" *.el *.elc
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+ fi
+ fperms 0444 /usr/share/smalltalk/packages.xml
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}