summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorge Shapovalov <george@gentoo.org>2002-12-11 08:04:00 +0000
committerGeorge Shapovalov <george@gentoo.org>2002-12-11 08:04:00 +0000
commitf57156f2a6e76b1c2a1156edc394a563dc58af5e (patch)
tree7b2d28b9d7ddeb64ee9d09d3469d882e78707cc5 /dev-lang/hugs98
parentfixed bug (diff)
downloadgentoo-2-f57156f2a6e76b1c2a1156edc394a563dc58af5e.tar.gz
gentoo-2-f57156f2a6e76b1c2a1156edc394a563dc58af5e.tar.bz2
gentoo-2-f57156f2a6e76b1c2a1156edc394a563dc58af5e.zip
new version
Diffstat (limited to 'dev-lang/hugs98')
-rw-r--r--dev-lang/hugs98/ChangeLog11
-rw-r--r--dev-lang/hugs98/files/digest-hugs98-2002.111
-rw-r--r--dev-lang/hugs98/hugs98-2002.11.ebuild51
3 files changed, 61 insertions, 2 deletions
diff --git a/dev-lang/hugs98/ChangeLog b/dev-lang/hugs98/ChangeLog
index bec8a1a581ad..1cdaef47450f 100644
--- a/dev-lang/hugs98/ChangeLog
+++ b/dev-lang/hugs98/ChangeLog
@@ -1,8 +1,15 @@
# ChangeLog for dev-lang/hugs98
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/hugs98/ChangeLog,v 1.4 2002/12/09 04:20:57 manson Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/hugs98/ChangeLog,v 1.5 2002/12/11 08:04:00 george Exp $
-\* Autoupdate keywords (12-6-02)
+*hugs98-2002.11 (10 Dec 2002)
+
+ 10 Dec 2002; George Shapovalov <george@gentoo.org> hugs98-2002.11.ebuild, files/digest-hugs98-2002.11 :
+
+ new version
+ update submitted by Andres Loeh <andres@cs.uu.nl>, see #11045
+
+* Autoupdate keywords (12-6-02)
06 Dec 2002; Rodney Rees <manson@gentoo.org> changed sparc ~sparc keywords
*hugs98-2000.12-r1 (08 Aug 2002)
diff --git a/dev-lang/hugs98/files/digest-hugs98-2002.11 b/dev-lang/hugs98/files/digest-hugs98-2002.11
new file mode 100644
index 000000000000..0c8f1a229872
--- /dev/null
+++ b/dev-lang/hugs98/files/digest-hugs98-2002.11
@@ -0,0 +1 @@
+MD5 8d3951d991661045713b612bf539c8c9 hugs98-Nov2002.tar.gz 1598806
diff --git a/dev-lang/hugs98/hugs98-2002.11.ebuild b/dev-lang/hugs98/hugs98-2002.11.ebuild
new file mode 100644
index 000000000000..8555ad9b39a3
--- /dev/null
+++ b/dev-lang/hugs98/hugs98-2002.11.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/hugs98/hugs98-2002.11.ebuild,v 1.1 2002/12/11 08:04:00 george Exp $
+
+IUSE=""
+
+MY_P="hugs98-Nov2002"
+S=${WORKDIR}/${MY_P}
+DESCRIPTION="The HUGS98 Haskell interpreter"
+SRC_URI="http://cvs.haskell.org/Hugs/downloads/Nov2002/${MY_P}.tar.gz"
+HOMEPAGE="http://www.haskell.org/hugs"
+
+SLOT="0"
+KEYWORDS="~x86 ~sparc ~sparc64"
+LICENSE="as-is"
+
+DEPEND="virtual/glibc"
+
+src_compile() {
+ local myc
+
+ cd ${S}/src/unix || die
+ ./configure \
+ --host=${CHOST} \
+ --prefix=/usr \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man \
+ --enable-ffi \
+ --enable-double-precision \
+ ${myc} || die "./configure failed"
+ cd ..
+ emake || die
+}
+
+src_install () {
+ cd ${S}/src || die
+ cp HsFFI.h ../include || die
+ make \
+ HUGSDIR=.. \
+ prefix=${D}/usr \
+ mandir=${D}/usr/share/man \
+ infodir=${D}/usr/share/info \
+ install || die
+
+ #somewhat clean-up installation of few docs
+ cd ${S}
+ dodoc Credits License Readme
+ cd ${D}/usr/lib/hugs
+ rm Credits License Readme
+ mv demos/ docs/ ${D}/usr/share/doc/${PF}
+}