summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonnie Berkholz <dberkholz@gentoo.org>2006-08-28 09:11:42 +0000
committerDonnie Berkholz <dberkholz@gentoo.org>2006-08-28 09:11:42 +0000
commit35f641cd1a0f934844f3838d051a17bae5859ef3 (patch)
treeb9222dda378e5d4ca047f48c41e87737e8f378d9 /dev-lang/ifc
parentVersion bump. (diff)
downloadgentoo-2-35f641cd1a0f934844f3838d051a17bae5859ef3.tar.gz
gentoo-2-35f641cd1a0f934844f3838d051a17bae5859ef3.tar.bz2
gentoo-2-35f641cd1a0f934844f3838d051a17bae5859ef3.zip
Bump to latest noncommercial version. Attempt to remove most hardcoded versions from ebuild, although some still exist in filesdir.
(Portage version: 2.1.1_rc1)
Diffstat (limited to 'dev-lang/ifc')
-rw-r--r--dev-lang/ifc/ChangeLog9
-rw-r--r--dev-lang/ifc/files/9.1/05ifc6
-rw-r--r--dev-lang/ifc/files/digest-ifc-9.1.0363
-rw-r--r--dev-lang/ifc/ifc-9.1.036.ebuild131
4 files changed, 148 insertions, 1 deletions
diff --git a/dev-lang/ifc/ChangeLog b/dev-lang/ifc/ChangeLog
index d14141ab865b..2502694400d5 100644
--- a/dev-lang/ifc/ChangeLog
+++ b/dev-lang/ifc/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-lang/ifc
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ifc/ChangeLog,v 1.19 2006/06/05 17:11:48 spyderous Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ifc/ChangeLog,v 1.20 2006/08/28 09:11:42 dberkholz Exp $
+
+*ifc-9.1.036 (28 Aug 2006)
+
+ 28 Aug 2006; Donnie Berkholz <dberkholz@gentoo.org>; +files/9.1/05ifc,
+ +ifc-9.1.036.ebuild:
+ Bump to latest noncommercial version. Attempt to remove most hardcoded
+ versions from ebuild, although some still exist in filesdir.
*ifc-9.0.031 (05 Jun 2006)
diff --git a/dev-lang/ifc/files/9.1/05ifc b/dev-lang/ifc/files/9.1/05ifc
new file mode 100644
index 000000000000..c045af50e031
--- /dev/null
+++ b/dev-lang/ifc/files/9.1/05ifc
@@ -0,0 +1,6 @@
+IA32ROOT=/opt/intel/fortran91
+INTEL_FLEXLM_LICENSE=/opt/intel/fortran91/licenses
+LDPATH=/opt/intel/fortran91/lib
+MANPATH=/opt/intel/fortran91/man
+PATH=/opt/intel/fortran91/bin
+ROOTPATH=/opt/intel/fortran91/bin
diff --git a/dev-lang/ifc/files/digest-ifc-9.1.036 b/dev-lang/ifc/files/digest-ifc-9.1.036
new file mode 100644
index 000000000000..286a2a8a4eda
--- /dev/null
+++ b/dev-lang/ifc/files/digest-ifc-9.1.036
@@ -0,0 +1,3 @@
+MD5 203f59c4cc37aa7b7d629b993978ab93 l_fc_c_9.1.036.tar.gz 138264428
+RMD160 c77f0a89a82adfb4f6da3b149145450695e4621e l_fc_c_9.1.036.tar.gz 138264428
+SHA256 bacb30d8a3c67b641615c8d32fe02f68fad14cd87c2689333566866961e4193c l_fc_c_9.1.036.tar.gz 138264428
diff --git a/dev-lang/ifc/ifc-9.1.036.ebuild b/dev-lang/ifc/ifc-9.1.036.ebuild
new file mode 100644
index 000000000000..a522b30f9e62
--- /dev/null
+++ b/dev-lang/ifc/ifc-9.1.036.ebuild
@@ -0,0 +1,131 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ifc/ifc-9.1.036.ebuild,v 1.1 2006/08/28 09:11:42 dberkholz Exp $
+
+inherit rpm versionator
+
+MAJOR=$(get_major_version ${PV})
+MINOR=$(get_version_component_range 2 ${PV})
+
+DESCRIPTION="Intel Fortran Compiler for Linux"
+HOMEPAGE="http://www.intel.com/software/products/compilers/flin/"
+IUSE=""
+KEYWORDS="~amd64 ~ia64 ~x86"
+LICENSE="ifc-9.0"
+RESTRICT="nostrip fetch"
+SLOT="${MAJOR}.${MINOR}"
+MMV="${MAJOR}.${MINOR}"
+
+SRC_URI="l_fc_c_${PV}.tar.gz"
+DEPEND=">=sys-libs/glibc-2.3.2"
+RDEPEND="sys-devel/gcc"
+S="${WORKDIR}/l_fc_c_${PV}"
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${S} || die
+
+ # The tarball contains rpms for multiple arches, and a lot of
+ # auxiliary rpms common across arches. We must throw away
+ # the arch we're not.
+ case ${ARCH} in
+ amd64)
+ rm -f data/intel-*.{i386,ia64}.rpm
+ ;;
+ ia64)
+ rm -f data/intel-*.{em64t,i386}.rpm
+ ;;
+ x86)
+ rm -f data/intel-*.{em64t,ia64}.rpm
+ ;;
+ esac
+
+ for x in *.rpm
+ do
+ # WORKDIR must be set properly for rpm_unpack()
+ rpm_unpack ${S}/data/${x}
+ done
+
+}
+
+src_compile() {
+ instdir=/opt/intel/fortran${MMV//.}
+
+ for x in opt/intel/*/*/bin/* ; do
+ sed "s|<INSTALLDIR>|${instdir}|g" -i $x
+ done
+
+ # == SRC_BASE
+ eval `grep "^[ ]*PACKAGEID=" ${S}/data/install_fc.sh`
+ einfo "PACKAGEID=${PACKAGEID}"
+
+ # From UNTAG_SUPPORT() in 'install_fc.sh'
+ case ${ARCH} in
+ amd64)
+ SUPPORTFILE=${S}/opt/intel/fce/${MMV}*/doc/fesupport
+ ;;
+ ia64|x86)
+ SUPPORTFILE=${S}/opt/intel/fc/${MMV}*/doc/fsupport
+ ;;
+ esac
+ if [ -f ${SUPPORTFILE} ]
+ then
+ einfo "Untagging: ${SUPPORTFILE}"
+ sed s@\<installpackageid\>@${PACKAGEID}@g ${SUPPORTFILE} > ${SUPPORTFILE}.abs
+ mv ${SUPPORTFILE}.abs ${SUPPORTFILE}
+ chmod 644 ${SUPPORTFILE}
+ fi
+
+ # From UNTAG_SUPPORT_IDB() in 'install_fc.sh'
+ case ${ARCH} in
+ amd64)
+ SUPPORTFILE=${S}/opt/intel/idbe/${MMV}*/doc/idbesupport
+ ;;
+ ia64 | x86)
+ SUPPORTFILE=${S}/opt/intel/idb/${MMV}*/doc/idbsupport
+ ;;
+ esac
+ if [ -f ${SUPPORTFILE} ]
+ then
+ einfo "Untagging: ${SUPPORTFILE}"
+ sed s@\<INSTALLTIMECOMBOPACKAGEID\>@${PACKAGEID}@g ${SUPPORTFILE} > ${SUPPORTFILE}.abs
+ mv ${SUPPORTFILE}.abs ${SUPPORTFILE}
+ chmod 644 ${SUPPORTFILE}
+ fi
+}
+
+src_install () {
+ instdir=/opt/intel/fortran${MMV//.}
+ # No lgpltext in ifc
+ # dodoc ${S}/lgpltext
+ dodoc ${S}/flicense
+ dodir ${instdir}
+ cp -pPR opt/intel/fc*/${MMV}*/* ${D}/${instdir}
+ cp -pPR opt/intel/idb*/${MMV}*/* ${D}/${instdir}
+ insinto /etc/env.d
+ doins ${FILESDIR}/${MMV}/05ifc || die
+}
+
+pkg_postinst () {
+ instdir=/opt/intel/fortran${MMV//.}
+
+ einfo "http://www.intel.com/software/products/compilers/flin/noncom.htm"
+ einfo "From the above url you can get a free, non-commercial"
+ einfo "license to use the Intel Fortran Compiler emailed to you."
+ einfo "You cannot run ifc without this license file."
+ einfo "Read the website for more information on this license."
+ einfo
+ einfo "Documentation can be found in ${instdir}/doc/"
+ einfo
+ einfo "You will need to place your license in ${instdir}/licenses/"
+ echo
+
+ ewarn "If 'ifc' breaks, use 'ifortbin' instead and report a bug."
+ echo
+
+ ewarn "Please perform"
+ ewarn " env-update"
+ ewarn " source /etc/profile"
+ ewarn "prior to using ifc."
+}