summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuis Francisco Araujo <araujo@gentoo.org>2008-01-20 03:45:28 +0000
committerLuis Francisco Araujo <araujo@gentoo.org>2008-01-20 03:45:28 +0000
commit582c6f0448fae7bc9645ca9f01debb40b430b5c1 (patch)
tree5e56a3b3615f8ed4ece590288d5f3447f89bcfba /dev-lang/io
parentVersion bump #205990 by Dennis Schridde. (diff)
downloadgentoo-2-582c6f0448fae7bc9645ca9f01debb40b430b5c1.tar.gz
gentoo-2-582c6f0448fae7bc9645ca9f01debb40b430b5c1.tar.bz2
gentoo-2-582c6f0448fae7bc9645ca9f01debb40b430b5c1.zip
Adding new version
(Portage version: 2.1.4)
Diffstat (limited to 'dev-lang/io')
-rw-r--r--dev-lang/io/ChangeLog9
-rw-r--r--dev-lang/io/files/digest-io-2008.01.173
-rw-r--r--dev-lang/io/io-2006.12.07.ebuild4
-rw-r--r--dev-lang/io/io-2008.01.17.ebuild35
4 files changed, 47 insertions, 4 deletions
diff --git a/dev-lang/io/ChangeLog b/dev-lang/io/ChangeLog
index d483bb1410bd..41934286ff31 100644
--- a/dev-lang/io/ChangeLog
+++ b/dev-lang/io/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-lang/io
-# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/io/ChangeLog,v 1.1 2006/12/09 02:39:42 araujo Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/io/ChangeLog,v 1.2 2008/01/20 03:45:28 araujo Exp $
+
+*io-2008.01.17 (20 Jan 2008)
+
+ 20 Jan 2008; Luis F. Araujo <araujo@gentoo.org> +io-2008.01.17.ebuild:
+ Adding new version
*io-2006.12.07 (09 Dec 2006)
diff --git a/dev-lang/io/files/digest-io-2008.01.17 b/dev-lang/io/files/digest-io-2008.01.17
new file mode 100644
index 000000000000..19c32f0cdc2f
--- /dev/null
+++ b/dev-lang/io/files/digest-io-2008.01.17
@@ -0,0 +1,3 @@
+MD5 7851b92af6380929ad1dcdd507a2d69c Io-2008-01-17.tar.gz 7556061
+RMD160 7f3f64d16b837af890861492d58688ae6ee7c0f0 Io-2008-01-17.tar.gz 7556061
+SHA256 316222cebbbd63a8a7badd92c0aa082ad3b16d4ccc967922c88b2b9cecdbd8b6 Io-2008-01-17.tar.gz 7556061
diff --git a/dev-lang/io/io-2006.12.07.ebuild b/dev-lang/io/io-2006.12.07.ebuild
index 1d81a1a5921e..e2e0ef86e089 100644
--- a/dev-lang/io/io-2006.12.07.ebuild
+++ b/dev-lang/io/io-2006.12.07.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/io/io-2006.12.07.ebuild,v 1.1 2006/12/09 02:39:42 araujo Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/io/io-2006.12.07.ebuild,v 1.2 2008/01/20 03:45:28 araujo Exp $
inherit versionator
@@ -30,6 +30,6 @@ src_install() {
INSTALL_PREFIX="${D}/usr" \
|| die "make install failed"
if use doc; then
- dodoc ${S}/docs/guide.{html,pdf}
+ dodoc "${S}/docs/guide.{html,pdf}"
fi
}
diff --git a/dev-lang/io/io-2008.01.17.ebuild b/dev-lang/io/io-2008.01.17.ebuild
new file mode 100644
index 000000000000..9e55394e33b7
--- /dev/null
+++ b/dev-lang/io/io-2008.01.17.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/io/io-2008.01.17.ebuild,v 1.1 2008/01/20 03:45:28 araujo Exp $
+
+inherit versionator
+
+MY_PV=$(replace_all_version_separators "-")
+MY_P="Io-${MY_PV}"
+
+DESCRIPTION="Io is a small, prototype-based programming language."
+HOMEPAGE="http://www.iolanguage.com"
+SRC_URI="http://io.urbanape.com/release/${MY_P}.tar.gz
+ http://www.sigusr1.org/~steve/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE="doc"
+DEPEND=""
+RDEPEND=""
+
+S="${WORKDIR}/${MY_P}"
+
+src_compile() {
+ make INSTALL_PREFIX="/usr" || die "make failed."
+}
+
+src_install() {
+ make install \
+ INSTALL_PREFIX="${D}/usr" \
+ || die "make install failed"
+ if use doc; then
+ dodoc "${S}/docs/guide.{html,pdf}"
+ fi
+}