summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHarald van Dijk <truedfx@gentoo.org>2007-03-10 08:44:37 +0000
committerHarald van Dijk <truedfx@gentoo.org>2007-03-10 08:44:37 +0000
commitbb5b67323ed7cd072a0e8070d18e33c84144f98c (patch)
tree4ee0ada41be4536f4f8f1bdf9ceff753dbbe1e59 /dev-lang/lazarus/lazarus-0.9.20-r1.ebuild
parentStable on amd64 wrt bug 169987 (diff)
downloadgentoo-2-bb5b67323ed7cd072a0e8070d18e33c84144f98c.tar.gz
gentoo-2-bb5b67323ed7cd072a0e8070d18e33c84144f98c.tar.bz2
gentoo-2-bb5b67323ed7cd072a0e8070d18e33c84144f98c.zip
Automatically find fpc source directory, preventing a crash on amd64 (#168168). Also, set default LCL interface to gtk2.
(Portage version: 2.1.2.2)
Diffstat (limited to 'dev-lang/lazarus/lazarus-0.9.20-r1.ebuild')
-rw-r--r--dev-lang/lazarus/lazarus-0.9.20-r1.ebuild66
1 files changed, 66 insertions, 0 deletions
diff --git a/dev-lang/lazarus/lazarus-0.9.20-r1.ebuild b/dev-lang/lazarus/lazarus-0.9.20-r1.ebuild
new file mode 100644
index 000000000000..458546d1aaf5
--- /dev/null
+++ b/dev-lang/lazarus/lazarus-0.9.20-r1.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/lazarus/lazarus-0.9.20-r1.ebuild,v 1.1 2007/03/10 08:44:37 truedfx Exp $
+
+inherit eutils
+
+FPCVER="2.0.4"
+
+SLOT="0" # Note: Slotting Lazarus needs slotting fpc, see DEPEND.
+LICENSE="GPL-2 LGPL-2.1 LGPL-2.1-linking-exception"
+KEYWORDS="~amd64 ~ppc ~x86"
+DESCRIPTION="Lazarus IDE is a feature rich visual programming environment emulating Delphi."
+HOMEPAGE="http://www.lazarus.freepascal.org/"
+IUSE=""
+SRC_URI="mirror://sourceforge/lazarus/${P}-0.tar.gz"
+
+DEPEND="~dev-lang/fpc-${FPCVER}
+ net-misc/rsync
+ >=x11-libs/gtk+-2.0"
+
+S=${WORKDIR}/${PN}
+
+pkg_setup() {
+ if ! built_with_use "dev-lang/fpc" source; then
+ eerror "You need to build dev-lang/fpc with the 'source' USE flag"
+ eerror "in order for lazarus to work properly."
+ die "lazarus needs fpc built with the 'source' USE to work."
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ sed -e "s/@FPCVER@/${FPCVER}/" "${FILESDIR}"/${P}-fpcsrc.patch \
+ > "${T}"/fpcsrc.patch || die "could not sed fpcsrc patch"
+
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-lclintf.patch
+ epatch "${T}"/fpcsrc.patch
+}
+
+src_compile() {
+ LCL_PLATFORM=gtk2 emake -j1 || die "make failed!"
+}
+
+src_install() {
+ diropts -m0755
+ dodir /usr/share
+ # Using rsync to avoid unnecessary copies and cleaning...
+ # Note: *.o and *.ppu are needed
+ rsync -a \
+ --exclude="CVS" --exclude=".cvsignore" \
+ --exclude="*.ppw" --exclude="*.ppl" \
+ --exclude="*.ow" --exclude="*.a"\
+ --exclude="*.rst" --exclude=".#*" \
+ --exclude="*.~*" --exclude="*.bak" \
+ --exclude="*.orig" --exclude="*.rej" \
+ --exclude=".xvpics" --exclude="*.compiled" \
+ --exclude="killme*" --exclude=".gdb_hist*" \
+ "${S}" "${D}"usr/share \
+ || die "Unable to copy files!"
+
+ dosym ../share/lazarus/startlazarus /usr/bin/startlazarus
+ dosym ../lazarus/images/mainicon.xpm /usr/share/pixmaps/lazarus.xpm
+
+ make_desktop_entry startlazarus "Lazarus IDE" "lazarus.xpm" || die "Failed making desktop entry!"
+}