summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Phillips <rphillips@gentoo.org>2003-02-07 21:59:51 +0000
committerRyan Phillips <rphillips@gentoo.org>2003-02-07 21:59:51 +0000
commit1ac77ae7653206ef03d2bec01f6a2986a61c6186 (patch)
tree31a3154a94f17bfeffb4c9f3ccb7ba88a5c2838f /dev-lang/lua/lua-4.0.1.ebuild
parentnumerous bug fixes. check ChangeLog (diff)
downloadgentoo-2-1ac77ae7653206ef03d2bec01f6a2986a61c6186.tar.gz
gentoo-2-1ac77ae7653206ef03d2bec01f6a2986a61c6186.tar.bz2
gentoo-2-1ac77ae7653206ef03d2bec01f6a2986a61c6186.zip
new version. ARCH masked
Diffstat (limited to 'dev-lang/lua/lua-4.0.1.ebuild')
-rw-r--r--dev-lang/lua/lua-4.0.1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-lang/lua/lua-4.0.1.ebuild b/dev-lang/lua/lua-4.0.1.ebuild
new file mode 100644
index 000000000000..46a79493f9ba
--- /dev/null
+++ b/dev-lang/lua/lua-4.0.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/lua/lua-4.0.1.ebuild,v 1.1 2003/02/07 21:59:51 rphillips Exp $
+
+S=${WORKDIR}/lua-${PV}
+DESCRIPTION="A powerful light-weight programming language designed for extending applications."
+SRC_URI="http://www.lua.org/ftp/lua-${PV}.tar.gz"
+HOMEPAGE="http://www.lua.org/"
+
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc "
+LICENSE="lua"
+
+
+src_compile() {
+ patch < ${FILESDIR}/lua-4.0-config.patch
+
+ emake || die
+ make so || die
+}
+
+src_install () {
+ make \
+ INSTALL_BIN=${D}/usr/bin \
+ INSTALL_MAN=${D}/usr/share/man/man1 \
+ INSTALL_INC=${D}/usr/include \
+ INSTALL_LIB=${D}/usr/lib \
+ install || die
+}