summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatti Bickel <mabi@gentoo.org>2008-10-17 19:20:34 +0000
committerMatti Bickel <mabi@gentoo.org>2008-10-17 19:20:34 +0000
commit6ea21da7b575b7b763b758e4a5739e721d8a236f (patch)
treedeb1b18a3560e6d8f9899ee19f1768024939914c /dev-lang/lua
parentFix desktop entry icon (#242468 by Renato Caldas) (diff)
downloadgentoo-2-6ea21da7b575b7b763b758e4a5739e721d8a236f.tar.gz
gentoo-2-6ea21da7b575b7b763b758e4a5739e721d8a236f.tar.bz2
gentoo-2-6ea21da7b575b7b763b758e4a5739e721d8a236f.zip
rolled back -r1, closes bug #242174 among others
(Portage version: 2.2_rc12/cvs/Linux 2.6.23-gentoo-r3-20080120 ppc)
Diffstat (limited to 'dev-lang/lua')
-rw-r--r--dev-lang/lua/ChangeLog7
-rw-r--r--dev-lang/lua/lua-5.1.4-r1.ebuild117
2 files changed, 6 insertions, 118 deletions
diff --git a/dev-lang/lua/ChangeLog b/dev-lang/lua/ChangeLog
index cd197886b0b7..c042321f3f68 100644
--- a/dev-lang/lua/ChangeLog
+++ b/dev-lang/lua/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-lang/lua
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/lua/ChangeLog,v 1.120 2008/10/10 08:26:34 mabi Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/lua/ChangeLog,v 1.121 2008/10/17 19:20:34 mabi Exp $
+
+ 17 Oct 2008; Matti Bickel <mabi@gentoo.org> -lua-5.1.4-r1.ebuild:
+ rolled back the -r1 ebuild b/c it breaks several packages (see bug #242174
+ for example). The cxx USE is gone as the risks and failures outweigh the
+ chances. Nothing else is changed.
*lua-5.1.4-r1 (09 Oct 2008)
diff --git a/dev-lang/lua/lua-5.1.4-r1.ebuild b/dev-lang/lua/lua-5.1.4-r1.ebuild
deleted file mode 100644
index ee544a3475fe..000000000000
--- a/dev-lang/lua/lua-5.1.4-r1.ebuild
+++ /dev/null
@@ -1,117 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/lua/lua-5.1.4-r1.ebuild,v 1.1 2008/10/10 08:26:34 mabi Exp $
-
-EAPI="1"
-
-inherit eutils portability versionator toolchain-funcs
-
-DESCRIPTION="A powerful light-weight programming language designed for extending applications"
-HOMEPAGE="http://www.lua.org/"
-SRC_URI="http://www.lua.org/ftp/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
-IUSE="cxx +deprecated readline static"
-
-DEPEND="readline? ( sys-libs/readline )"
-
-src_unpack() {
- local PATCH_PV=$(get_version_component_range 1-2)
- unpack ${A}
- cd "${S}"
-
- epatch "${FILESDIR}"/${PN}-${PATCH_PV}-make.patch
- epatch "${FILESDIR}"/${PN}-${PATCH_PV}-module_paths.patch
-
- # EPATCH_SOURCE="${FILESDIR}/${PV}" EPATCH_SUFFIX="upstream.patch" epatch
-
- # correct lua versioning
- sed -i -e 's/\(LIB_VERSION = \)6:1:1/\16:4:1/' src/Makefile
-
- sed -i -e 's:\(/README\)\("\):\1.gz\2:g' doc/readme.html
-
- if ! use deprecated ; then
- epatch "${FILESDIR}"/${P}-deprecated.patch
- epatch "${FILESDIR}"/${P}-test.patch
- fi
-
- if ! use readline ; then
- epatch "${FILESDIR}"/${PN}-${PATCH_PV}-readline.patch
- fi
-
- # Using dynamic linked lua is not recommended upstream for performance
- # reasons. http://article.gmane.org/gmane.comp.lang.lua.general/18519
- # Mainly, this is of concern if your arch is poor with GPRs, like x86
- # Not that this only affects the interpreter binary (named lua), not the lua
- # compiler (built statically) nor the lua libraries (both shared and static
- # are installed)
- if use static ; then
- epatch "${FILESDIR}"/${PN}-${PATCH_PV}-make_static.patch
- fi
-
- # We want packages to find our things...
- sed -i -e 's:/usr/local:/usr:' etc/lua.pc
-}
-
-src_compile() {
- tc-export CC
- if use cxx; then
- CC=$(tc-getCXX)
- fi
-
- myflags=
- # what to link to liblua
- liblibs="-lm"
- mycflags="${mycflags} -DLUA_USE_LINUX"
- liblibs="${liblibs} $(dlopen_lib)"
-
- # what to link to the executables
- mylibs=
- if use readline; then
- mylibs="-lreadline"
- fi
-
- cd src
- emake CC="${CC}" CFLAGS="${mycflags} ${CFLAGS}" \
- RPATH="${ROOT}/usr/$(get_libdir)/" \
- LUA_LIBS="${mylibs}" \
- LIB_LIBS="${liblibs}" \
- V=${PV} \
- gentoo_all || die "emake failed"
-
- mv lua_test ../test/lua.static
-}
-
-src_install() {
- emake INSTALL_TOP="${D}/usr/" INSTALL_LIB="${D}/usr/$(get_libdir)/" \
- V=${PV} gentoo_install \
- || die "emake install gentoo_install failed"
-
- dodoc HISTORY README
- dohtml doc/*.html doc/*.gif
-
- insinto /usr/share/pixmaps
- doins etc/lua.ico
- insinto /usr/$(get_libdir)/pkgconfig
- doins etc/lua.pc
-
- doman doc/lua.1 doc/luac.1
-}
-
-src_test() {
- local positive="bisect cf echo env factorial fib fibfor hello printf sieve
- sort trace-calls trace-globals"
- local negative="readonly"
- local test
-
- cd "${S}"
- for test in ${positive}; do
- test/lua.static test/${test}.lua || die "test $test failed"
- done
-
- for test in ${negative}; do
- test/lua.static test/${test}.lua && die "test $test failed"
- done
-}