summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKeri Harris <keri@gentoo.org>2006-06-09 09:05:40 +0000
committerKeri Harris <keri@gentoo.org>2006-06-09 09:05:40 +0000
commit0dd42fa11074a04727997f7330c56a58769c31d5 (patch)
tree0c5044dd58be2726b7c61f15c9d6e116dac389d8 /dev-lang/mercury-extras
parentAdd debug support to libgrades. Append ${P} to install_libdir so that mercury... (diff)
downloadgentoo-2-0dd42fa11074a04727997f7330c56a58769c31d5.tar.gz
gentoo-2-0dd42fa11074a04727997f7330c56a58769c31d5.tar.bz2
gentoo-2-0dd42fa11074a04727997f7330c56a58769c31d5.zip
Append ${PV} to install_libdir so we can install when mercury interfaces change.
(Portage version: 2.1_rc4-r3)
Diffstat (limited to 'dev-lang/mercury-extras')
-rw-r--r--dev-lang/mercury-extras/ChangeLog10
-rw-r--r--dev-lang/mercury-extras/files/digest-mercury-extras-0.12.2-r13
-rw-r--r--dev-lang/mercury-extras/files/mercury-extras-0.12.2-posix.patch11
-rw-r--r--dev-lang/mercury-extras/mercury-extras-0.12.2-r1.ebuild107
4 files changed, 130 insertions, 1 deletions
diff --git a/dev-lang/mercury-extras/ChangeLog b/dev-lang/mercury-extras/ChangeLog
index 5756a277cee0..11f763ec1719 100644
--- a/dev-lang/mercury-extras/ChangeLog
+++ b/dev-lang/mercury-extras/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for dev-lang/mercury-extras
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/mercury-extras/ChangeLog,v 1.28 2006/06/08 18:52:38 keri Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/mercury-extras/ChangeLog,v 1.29 2006/06/09 09:05:40 keri Exp $
+
+*mercury-extras-0.12.2-r1 (09 Jun 2006)
+
+ 09 Jun 2006; Keri Harris <keri@gentoo.org>
+ +files/mercury-extras-0.12.2-posix.patch,
+ +mercury-extras-0.12.2-r1.ebuild:
+ Append ${PV} to install_libdir so we can install when mercury interfaces
+ change.
08 Jun 2006; Keri Harris <keri@gentoo.org> mercury-extras-0.12.2.ebuild,
mercury-extras-0.13.0_beta20060601.ebuild:
diff --git a/dev-lang/mercury-extras/files/digest-mercury-extras-0.12.2-r1 b/dev-lang/mercury-extras/files/digest-mercury-extras-0.12.2-r1
new file mode 100644
index 000000000000..13cdfec9edd6
--- /dev/null
+++ b/dev-lang/mercury-extras/files/digest-mercury-extras-0.12.2-r1
@@ -0,0 +1,3 @@
+MD5 31101288778657de8bf063abe970bb70 mercury-extras-0.12.2.tar.gz 759070
+RMD160 3e7c4c67590408d2da056135c9560ff4d078eff6 mercury-extras-0.12.2.tar.gz 759070
+SHA256 3a5be0941fad7ed8f8d2e967138984127510ba388b65b0f3f35f46ae8b6b43a8 mercury-extras-0.12.2.tar.gz 759070
diff --git a/dev-lang/mercury-extras/files/mercury-extras-0.12.2-posix.patch b/dev-lang/mercury-extras/files/mercury-extras-0.12.2-posix.patch
new file mode 100644
index 000000000000..c9316d91fea4
--- /dev/null
+++ b/dev-lang/mercury-extras/files/mercury-extras-0.12.2-posix.patch
@@ -0,0 +1,11 @@
+--- mercury-extras-0.12.2.orig/posix/Mmakefile 2004-02-11 17:35:14.000000000 +1300
++++ mercury-extras-0.12.2/posix/Mmakefile 2006-06-07 18:41:15.000000000 +1200
+@@ -34,7 +34,7 @@
+
+ .PHONY: install
+ install: libposix.install
+- cp $(ADDITIONAL_HDRS) $(INSTALL_PREFIX)/lib/mercury/inc
++ cp $(ADDITIONAL_HDRS) $(INSTALL_PREFIX)/lib/mercury-0.12.2/inc
+
+ .PHONY: clean
+ clean:
diff --git a/dev-lang/mercury-extras/mercury-extras-0.12.2-r1.ebuild b/dev-lang/mercury-extras/mercury-extras-0.12.2-r1.ebuild
new file mode 100644
index 000000000000..136db130588b
--- /dev/null
+++ b/dev-lang/mercury-extras/mercury-extras-0.12.2-r1.ebuild
@@ -0,0 +1,107 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/mercury-extras/mercury-extras-0.12.2-r1.ebuild,v 1.1 2006/06/09 09:05:40 keri Exp $
+
+inherit eutils
+
+DESCRIPTION="Additional libraries and tools that are not part of the Mercury standard library"
+HOMEPAGE="http://www.cs.mu.oz.au/research/mercury/index.html"
+SRC_URI="ftp://ftp.mercury.cs.mu.oz.au/pub/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~ppc ~x86"
+
+IUSE="doc glut iodbc opengl tcltk"
+
+DEPEND="~dev-lang/mercury-0.12.2
+ sys-libs/ncurses
+ glut? ( virtual/glut )
+ iodbc? ( dev-db/libiodbc )
+ opengl? ( virtual/opengl )
+ tcktk? ( =dev-lang/tk-8.4*
+ || ( (
+ x11-libs/libX11
+ x11-libs/libXmu )
+ virtual/x11 ) )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-gcc4.patch
+ epatch "${FILESDIR}"/${P}-concurrency.patch
+ epatch "${FILESDIR}"/${P}-dynamic_linking.patch
+ epatch "${FILESDIR}"/${P}-lex.patch
+ epatch "${FILESDIR}"/${P}-mercury_glut.patch
+ epatch "${FILESDIR}"/${P}-mercury_tcltk.patch
+ epatch "${FILESDIR}"/${P}-mercury_opengl.patch
+ epatch "${FILESDIR}"/${P}-odbc.patch
+ epatch "${FILESDIR}"/${P}-posix.patch
+ epatch "${FILESDIR}"/${P}-references.patch
+ epatch "${FILESDIR}"/${P}-trailed_update.patch
+
+ sed -i -e "s:curs:concurrency curs:" \
+ -e "s:posix:posix quickcheck:" Mmakefile
+
+ if built_with_use dev-lang/mercury minimal; then
+ sed -i -e "s:references::" Mmakefile
+ else
+ sed -i -e "s:xml:trailed_update xml:" Mmakefile
+ fi
+
+ use iodbc && sed -i -e "s:moose:moose odbc:" Mmakefile
+ use glut && sed -i -e "s: lex : graphics/mercury_glut lex :" Mmakefile
+ use tcltk && sed -i -e "s: lex : graphics/mercury_tcltk lex :" Mmakefile
+ use opengl && sed -i -e "s: lex : graphics/mercury_opengl lex :" Mmakefile
+}
+
+src_compile() {
+ mmake depend || die "mmake depend failed"
+ mmake || die "mmake failed"
+
+ if use opengl && use tcltk ; then
+ cd "${S}"/graphics/mercury_opengl
+ cp ../mercury_tcltk/mtcltk.m ./
+ mmake -f Mmakefile.mtogl depend || die "mmake depend mtogl failed"
+ mmake -f Mmakefile.mtogl || die "mmake mtogl failed"
+ fi
+}
+
+src_install() {
+ cd "${S}"
+ mmake INSTALL_PREFIX="${D}"/usr install || die "mmake install failed"
+
+ if use opengl && use tcltk ; then
+ cd "${S}"/graphics/mercury_opengl
+ mv Mmakefile Mmakefile.opengl
+ mv Mmakefile.mtogl Mmakefile
+ mmake INSTALL_PREFIX="${D}"/usr \
+ install || die "mmake install mtogl failed"
+ fi
+
+ cd "${S}"
+ if use doc ; then
+ docinto samples/complex_numbers
+ dodoc complex_numbers/samples/*.m
+
+ docinto samples/curs
+ dodoc curs/samples/*.m
+
+ docinto samples/curses
+ dodoc curses/sample/*.m
+
+ docinto samples/dynamic_linking
+ dodoc dynamic_linking/hello.m
+
+ docinto samples/lex
+ dodoc lex/samples/*.m
+
+ docinto samples/moose
+ dodoc moose/samples/*.m moose/samples/*.moo
+
+ docinto samples/references
+ dodoc references/samples/*.m
+ fi
+
+ dodoc README
+}