summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKeri Harris <keri@gentoo.org>2010-10-30 04:14:00 +0000
committerKeri Harris <keri@gentoo.org>2010-10-30 04:14:00 +0000
commit3496a1e6b0ddcc696d7e3498fe02a4b32d38fea8 (patch)
tree81ca2398ba560e70ff8570224897b1e2e85ca076 /dev-lang/mercury
parentAdd YAPLIBDIR to LD_LIBRARY_PATH when bootstrapping chr (diff)
downloadgentoo-2-3496a1e6b0ddcc696d7e3498fe02a4b32d38fea8.tar.gz
gentoo-2-3496a1e6b0ddcc696d7e3498fe02a4b32d38fea8.tar.bz2
gentoo-2-3496a1e6b0ddcc696d7e3498fe02a4b32d38fea8.zip
QA - add die to do... function calls, add die to sed calls, remove die from econf call
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'dev-lang/mercury')
-rw-r--r--dev-lang/mercury/ChangeLog6
-rw-r--r--dev-lang/mercury/mercury-10.04.2-r1.ebuild24
2 files changed, 17 insertions, 13 deletions
diff --git a/dev-lang/mercury/ChangeLog b/dev-lang/mercury/ChangeLog
index 7c6cf1897032..2e7c80da4eb1 100644
--- a/dev-lang/mercury/ChangeLog
+++ b/dev-lang/mercury/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-lang/mercury
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/mercury/ChangeLog,v 1.121 2010/10/22 22:23:30 keri Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/mercury/ChangeLog,v 1.122 2010/10/30 04:14:00 keri Exp $
+
+ 30 Oct 2010; <keri@gentoo.org> mercury-10.04.2-r1.ebuild:
+ QA - add die to do... function calls, add die to sed calls, remove die
+ from econf call
*mercury-10.04.2-r1 (22 Oct 2010)
diff --git a/dev-lang/mercury/mercury-10.04.2-r1.ebuild b/dev-lang/mercury/mercury-10.04.2-r1.ebuild
index 88b17335ef59..0c8daef2efed 100644
--- a/dev-lang/mercury/mercury-10.04.2-r1.ebuild
+++ b/dev-lang/mercury/mercury-10.04.2-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/mercury/mercury-10.04.2-r1.ebuild,v 1.1 2010/10/22 22:23:30 keri Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/mercury/mercury-10.04.2-r1.ebuild,v 1.2 2010/10/30 04:14:00 keri Exp $
inherit autotools elisp-common eutils flag-o-matic java-pkg-opt-2 multilib
@@ -49,7 +49,8 @@ src_unpack() {
"${S}"/compiler/libs.file_util.c \
"${S}"/compiler/make.program_target.m \
"${S}"/compiler/make.program_target.c \
- "${S}"/scripts/Mmake.vars.in
+ "${S}"/scripts/Mmake.vars.in \
+ || die "sed libdir failed"
touch "${S}"/compiler/*.date
touch "${S}"/compiler/*.date0
@@ -86,9 +87,7 @@ src_compile() {
$(use_enable !minimal most-grades) \
$(use_with readline)"
- econf \
- ${myconf} \
- || die "econf failed"
+ econf ${myconf}
emake \
PARALLEL=${MAKEOPTS} \
@@ -123,7 +122,8 @@ src_test() {
fi
cd "${TESTDIR}"
- sed -i -e "s:@WORKSPACE@:${TWS}:" WS_FLAGS.ws
+ sed -i -e "s:@WORKSPACE@:${TWS}:" WS_FLAGS.ws \
+ || die "sed WORKSPACE failed"
PATH="${TWS}"/scripts:"${TWS}"/util:"${TWS}"/slice:"${PATH}" \
TERM="" \
@@ -164,28 +164,28 @@ src_install() {
dodoc \
BUGS HISTORY LIMITATIONS NEWS README README.Linux \
README.Linux-Alpha README.Linux-m68k README.Linux-PPC \
- RELEASE_NOTES TODO VERSION WORK_IN_PROGRESS
+ RELEASE_NOTES TODO VERSION WORK_IN_PROGRESS || die
if use erlang; then
- dodoc README.Erlang
+ dodoc README.Erlang || die
fi
if use java; then
- dodoc README.Java
+ dodoc README.Java || die
fi
if use examples; then
insinto /usr/share/doc/${PF}/samples
- doins samples/{*.m,README,Mmakefile}
+ doins samples/{*.m,README,Mmakefile} || die
doins -r samples/c_interface \
samples/diff \
samples/muz \
samples/rot13 \
samples/solutions \
- samples/solver_types
+ samples/solver_types || die
if use java; then
- doins -r samples/java_interface
+ doins -r samples/java_interface || die
fi
rm -rf $(find "${D}"/usr/share/doc/${PF}/samples \