summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Johanson <latexer@gentoo.org>2006-02-20 01:33:46 +0000
committerPeter Johanson <latexer@gentoo.org>2006-02-20 01:33:46 +0000
commitab2d18523fb8dd2dae59b092d97686c41d32cc79 (patch)
tree5f09ab38c522383102ed127a444a80017c62627b /dev-lang/mono/mono-1.1.13.1.ebuild
parentAlpha stable for bug #119924 (diff)
downloadgentoo-2-ab2d18523fb8dd2dae59b092d97686c41d32cc79.tar.gz
gentoo-2-ab2d18523fb8dd2dae59b092d97686c41d32cc79.tar.bz2
gentoo-2-ab2d18523fb8dd2dae59b092d97686c41d32cc79.zip
Remove some unneeded versions, and add a small fix to make sure we build using bundled mcs/classlibs. Fixes bug #118062.
(Portage version: 2.0.53)
Diffstat (limited to 'dev-lang/mono/mono-1.1.13.1.ebuild')
-rw-r--r--dev-lang/mono/mono-1.1.13.1.ebuild5
1 files changed, 4 insertions, 1 deletions
diff --git a/dev-lang/mono/mono-1.1.13.1.ebuild b/dev-lang/mono/mono-1.1.13.1.ebuild
index 790a1126308b..c1ca39c63555 100644
--- a/dev-lang/mono/mono-1.1.13.1.ebuild
+++ b/dev-lang/mono/mono-1.1.13.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/mono/mono-1.1.13.1.ebuild,v 1.3 2006/01/30 18:32:34 herbs Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/mono/mono-1.1.13.1.ebuild,v 1.4 2006/02/20 01:33:46 latexer Exp $
inherit eutils mono flag-o-matic multilib
@@ -72,6 +72,9 @@ src_compile() {
fi
fi
+ # Force the use of the monolite mcs, to prevent us from trying to build
+ # with old buggy classlibs/mcs versions. See bug #118062
+ touch ${S}/mcs/build/deps/use-monolite
econf ${myconf} || die
emake -j1 || die "MONO compilation failure"
}