summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Johanson <latexer@gentoo.org>2006-10-15 23:57:38 +0000
committerPeter Johanson <latexer@gentoo.org>2006-10-15 23:57:38 +0000
commit37d54468bc937c01601a67875faecf7f0587f217 (patch)
treefbdcf57f4c5425f2a084a62352f632b4b624b0c3 /dev-lang/mono
parentVersion bump. (diff)
downloadgentoo-2-37d54468bc937c01601a67875faecf7f0587f217.tar.gz
gentoo-2-37d54468bc937c01601a67875faecf7f0587f217.tar.bz2
gentoo-2-37d54468bc937c01601a67875faecf7f0587f217.zip
Bump for bug #150264.
(Portage version: 2.1.2_pre1-r4)
Diffstat (limited to 'dev-lang/mono')
-rw-r--r--dev-lang/mono/ChangeLog9
-rw-r--r--dev-lang/mono/files/digest-mono-1.1.13.8.13
-rw-r--r--dev-lang/mono/files/digest-mono-1.1.183
-rw-r--r--dev-lang/mono/mono-1.1.13.8.1.ebuild99
-rw-r--r--dev-lang/mono/mono-1.1.18.ebuild101
5 files changed, 214 insertions, 1 deletions
diff --git a/dev-lang/mono/ChangeLog b/dev-lang/mono/ChangeLog
index bfca6766391a..54a4f55b5014 100644
--- a/dev-lang/mono/ChangeLog
+++ b/dev-lang/mono/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-lang/mono
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/mono/ChangeLog,v 1.90 2006/09/04 06:57:47 compnerd Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/mono/ChangeLog,v 1.91 2006/10/15 23:57:38 latexer Exp $
+
+*mono-1.1.18 (15 Oct 2006)
+*mono-1.1.13.8.1 (15 Oct 2006)
+
+ 15 Oct 2006; Peter Johanson <latexer@gentoo.org> +mono-1.1.13.8.1.ebuild,
+ +mono-1.1.18.ebuild:
+ Bump for bug #150264.
*mono-1.1.17.1 (04 Sep 2006)
diff --git a/dev-lang/mono/files/digest-mono-1.1.13.8.1 b/dev-lang/mono/files/digest-mono-1.1.13.8.1
new file mode 100644
index 000000000000..f1224e63cdfc
--- /dev/null
+++ b/dev-lang/mono/files/digest-mono-1.1.13.8.1
@@ -0,0 +1,3 @@
+MD5 473c24c4be17b8e71393bc96bbda4bca mono-1.1.13.8.1.tar.gz 17758715
+RMD160 a100a96b19300b253c12a2ad70caf65721418209 mono-1.1.13.8.1.tar.gz 17758715
+SHA256 841cd62de1f61fefd17190dcc744e03f49c495039cc2088627ede9d9d825e21a mono-1.1.13.8.1.tar.gz 17758715
diff --git a/dev-lang/mono/files/digest-mono-1.1.18 b/dev-lang/mono/files/digest-mono-1.1.18
new file mode 100644
index 000000000000..62a321da8e10
--- /dev/null
+++ b/dev-lang/mono/files/digest-mono-1.1.18
@@ -0,0 +1,3 @@
+MD5 ce7c16c15b938edb2f1ea781921ef3eb mono-1.1.18.tar.gz 19457001
+RMD160 60134edff923ca2a39cb82f75f5dcc7468edb601 mono-1.1.18.tar.gz 19457001
+SHA256 8b5a62cb91b92a9b77c62595f7f081971efac66fdfebaf1de7cd5c15b425c36b mono-1.1.18.tar.gz 19457001
diff --git a/dev-lang/mono/mono-1.1.13.8.1.ebuild b/dev-lang/mono/mono-1.1.13.8.1.ebuild
new file mode 100644
index 000000000000..7e5c39fbf4f7
--- /dev/null
+++ b/dev-lang/mono/mono-1.1.13.8.1.ebuild
@@ -0,0 +1,99 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/mono/mono-1.1.13.8.1.ebuild,v 1.1 2006/10/15 23:57:38 latexer Exp $
+
+inherit eutils mono flag-o-matic multilib autotools
+
+RESTRICT="confcache"
+
+DESCRIPTION="Mono runtime and class libraries, a C# compiler/interpreter"
+HOMEPAGE="http://www.go-mono.com/"
+SRC_URI="http://www.go-mono.com/sources/mono-${PV:0:3}/${P}.tar.gz"
+
+LICENSE="|| ( GPL-2 LGPL-2 X11 )"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~amd64"
+IUSE="nptl X"
+
+DEPEND=">=dev-libs/glib-2.0
+ sys-devel/bc
+ !<dev-dotnet/pnet-0.6.12
+ nptl? ( >=sys-devel/gcc-3.3.5-r1 )
+ ppc? (
+ >=sys-devel/gcc-3.2.3-r4
+ >=sys-libs/glibc-2.3.3_pre20040420
+ )"
+
+RDEPEND="${DEPEND}
+ X? ( >=dev-dotnet/libgdiplus-1.1.13 )
+ dev-util/pkgconfig
+ dev-libs/libxml2"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ # Fix munging of Unix paths
+ epatch ${FILESDIR}/${PN}-1.1.13-pathfix.diff
+ epatch ${FILESDIR}/${PN}-1.1.13-resource-manager.diff
+ epatch ${FILESDIR}/${PN}-1.1.13.8-dynamic-assembly-get-types.diff
+
+ # Install all our .dlls under $(libdir), not $(prefix)/lib
+ if [ $(get_libdir) != "lib" ] ; then
+ sed -i -e 's:$(prefix)/lib:$(libdir):' \
+ -e 's:$(exec_prefix)/lib:$(libdir):' \
+ -e "s:'mono_libdir=\${exec_prefix}/lib':\"mono_libdir=\$libdir\":" \
+ ${S}/{scripts,mono/metadata,mono/os/unix}/Makefile.am \
+ ${S}/configure.in || die "sed failed"
+ sed -i -e 's:^libdir.*:libdir=@libdir@:' \
+ -e 's:${prefix}/lib/:${libdir}/:g' \
+ ${S}/{scripts,}/*.pc.in || die "sed failed"
+ fi
+
+ # Remove the dummy ltconfig and leave to libtoolize handling it
+ rm -f ${S}/libgc/ltconfig
+
+ eautoreconf
+}
+
+src_compile() {
+ strip-flags
+
+ local myconf="--with-preview=yes"
+
+ # Force __thread on amd64. See bug #83770
+ if use amd64
+ then
+ myconf="${myconf} --with-tls=__thread"
+ else
+ if use nptl
+ then
+ myconf="${myconf} --with-tls=__thread"
+ else
+ myconf="${myconf} --with-tls=pthread"
+ fi
+ fi
+
+ # Force the use of the monolite mcs, to prevent us from trying to build
+ # with old buggy classlibs/mcs versions. See bug #118062
+ touch ${S}/mcs/build/deps/use-monolite
+ econf ${myconf} || die
+ emake -j1 || die "MONO compilation failure"
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+
+ dodoc AUTHORS ChangeLog NEWS README
+ docinto docs
+ dodoc docs/*
+ docinto libgc
+ dodoc libgc/ChangeLog
+}
+
+pkg_postinst() {
+ ewarn "This version of mono has changed the assembly version for"
+ ewarn "ICSharpCode.SharpZipLib, which may break some installed"
+ ewarn "applications such as monodoc. Please re-emerge monodoc and any"
+ ewarn "other packages you have which may make use of this library."
+}
diff --git a/dev-lang/mono/mono-1.1.18.ebuild b/dev-lang/mono/mono-1.1.18.ebuild
new file mode 100644
index 000000000000..d36f419fdd15
--- /dev/null
+++ b/dev-lang/mono/mono-1.1.18.ebuild
@@ -0,0 +1,101 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/mono/mono-1.1.18.ebuild,v 1.1 2006/10/15 23:57:38 latexer Exp $
+
+inherit eutils flag-o-matic multilib autotools
+
+DESCRIPTION="Mono runtime and class libraries, a C# compiler/interpreter"
+HOMEPAGE="http://www.go-mono.com"
+SRC_URI="http://www.go-mono.com/sources/mono-${PV:0:3}/${P}.tar.gz"
+
+LICENSE="|| ( GPL-2 LGPL-2 X11 )"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="X nptl"
+
+RDEPEND="!<dev-dotnet/pnet-0.6.12
+ >=dev-libs/glib-2.6
+ nptl? ( >=sys-devel/gcc-3.3.5-r1 )
+ ppc? (
+ >=sys-devel/gcc-3.2.3-r4
+ >=sys-libs/glibc-2.3.3_pre20040420
+ )
+ X? ( >=dev-dotnet/libgdiplus-1.1.17 )"
+DEPEND="${RDEPEND}
+ sys-devel/bc
+ >=dev-util/pkgconfig-0.19"
+
+# Parallel build unfriendly
+MAKEOPTS="${MAKEOPTS} -j1"
+
+# confcache causes build errors
+RESTRICT="confcache"
+
+function get-memory-total() {
+ cat /proc/meminfo | grep MemTotal | sed -r "s/[^0-9]*([[0-9]+).*/\1/"
+}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ # Fix the install path, install into $(libdir)
+ sed -i -e 's:$(prefix)/lib:$(libdir):' \
+ -i -e 's:$(exec_prefix)/lib:$(libdir):' \
+ -i -e "s:'mono_libdir=\${exec_prefix}/lib':\"mono_libdir=\$libdir\":" \
+ ${S}/{scripts,mono/metadata}/Makefile.am ${S}/configure.in \
+ || die "sed failed"
+
+ sed -i -e 's:^libdir.*:libdir=@libdir@:' \
+ -i -e 's:${prefix}/lib/:${libdir}/:g' \
+ ${S}/{scripts,}/*.pc.in \
+ || die "sed failed"
+
+ # Remove dummy ltconfig and let libtool handle it
+ rm -f ${S}/libgc/ltconfig
+
+ eautoreconf
+}
+
+src_compile() {
+ # mono's build system is finiky, strip the flags
+ strip-flags
+
+ # Enable the 2.0 FX, use the system glib and the gc
+ local myconf="--with-preview=yes --with-glib=system --with-gc=included"
+
+ # Threading support
+ if use amd64 ; then
+ # force __thread on amd64 (bug #83770)
+ myconf="${myconf} --with-tls=__thread"
+ else
+ if use nptl ; then
+ myconf="${myconf} --with-tls=__thread"
+ else
+ myconf="${myconf} --with-tls=pthread"
+ fi
+ fi
+
+ # Enable large heaps if memory is more than >=3GB
+ if [[ $(get-memory-total) -ge 3145728 ]] ; then
+ myconf="${myconf} --with-large-heap=yes"
+ fi
+
+ # Force the use of monolite mcs to prevent issues with classlibs (bug #118062)
+ touch ${S}/mcs/build/deps/use-monolite
+
+ econf ${myconf} || die "configure failed"
+ emake || die "compile failed"
+}
+
+src_install() {
+ emake DESTDIR=${D} install || die "install failed"
+
+ dodoc AUTHORS ChangeLog NEWS README
+
+ docinto docs
+ dodoc docs/*
+
+ docinto libgc
+ dodoc libgc/ChangeLog
+}