summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2012-09-15 13:37:04 +0000
committerPacho Ramos <pacho@gentoo.org>2012-09-15 13:37:04 +0000
commit55c4349113e8f6af55cf190fb00d1f7485bbb306 (patch)
tree7e88c0d80bd28b803666718122167588da96f5bd /dev-lang/mono
parentStable for amd64, wrt bug #431190 (diff)
downloadgentoo-2-55c4349113e8f6af55cf190fb00d1f7485bbb306.tar.gz
gentoo-2-55c4349113e8f6af55cf190fb00d1f7485bbb306.tar.bz2
gentoo-2-55c4349113e8f6af55cf190fb00d1f7485bbb306.zip
Fix CVE-2012-3543, drop old.
(Portage version: 2.1.11.17/cvs/Linux x86_64)
Diffstat (limited to 'dev-lang/mono')
-rw-r--r--dev-lang/mono/ChangeLog10
-rw-r--r--dev-lang/mono/files/mono-2.10.9-CVE-2012-3543.patch196
-rw-r--r--dev-lang/mono/files/mono-2.10.9-CVE-2012-3543_2.patch34
-rw-r--r--dev-lang/mono/mono-2.10.5.ebuild274
-rw-r--r--dev-lang/mono/mono-2.10.9-r2.ebuild (renamed from dev-lang/mono/mono-2.10.8.ebuild)81
5 files changed, 281 insertions, 314 deletions
diff --git a/dev-lang/mono/ChangeLog b/dev-lang/mono/ChangeLog
index 07421963f6a0..3dd2906971ae 100644
--- a/dev-lang/mono/ChangeLog
+++ b/dev-lang/mono/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for dev-lang/mono
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/mono/ChangeLog,v 1.246 2012/08/24 12:07:53 xmw Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/mono/ChangeLog,v 1.247 2012/09/15 13:37:04 pacho Exp $
+
+*mono-2.10.9-r2 (15 Sep 2012)
+
+ 15 Sep 2012; Pacho Ramos <pacho@gentoo.org>
+ +files/mono-2.10.9-CVE-2012-3543.patch,
+ +files/mono-2.10.9-CVE-2012-3543_2.patch, +mono-2.10.9-r2.ebuild,
+ -mono-2.10.5.ebuild, -mono-2.10.8.ebuild:
+ Fix CVE-2012-3543, drop old.
24 Aug 2012; Michael Weber <xmw@gentoo.org> mono-2.10.9-r1.ebuild:
ppc stable (bug 426688).
diff --git a/dev-lang/mono/files/mono-2.10.9-CVE-2012-3543.patch b/dev-lang/mono/files/mono-2.10.9-CVE-2012-3543.patch
new file mode 100644
index 000000000000..307e10fb3ee6
--- /dev/null
+++ b/dev-lang/mono/files/mono-2.10.9-CVE-2012-3543.patch
@@ -0,0 +1,196 @@
+From 04245de5c480db5dff5983467f7a8606f1321ed6 Mon Sep 17 00:00:00 2001
+From: Marek Habersack <grendel@twistedcode.net>
+Date: Tue, 24 Jul 2012 18:49:34 -0400
+Subject: [PATCH] Fix for Novell bug #739119
+
+---
+ .../System.Web.Util/SecureHashCodeProvider.cs | 131 ++++++++++++++++++++
+ mcs/class/System.Web/System.Web.dll.sources | 1 +
+ mcs/class/System.Web/System.Web/WebROCollection.cs | 5 +-
+ 3 files changed, 136 insertions(+), 1 deletion(-)
+ create mode 100644 mcs/class/System.Web/System.Web.Util/SecureHashCodeProvider.cs
+
+diff --git a/mcs/class/System.Web/System.Web.Util/SecureHashCodeProvider.cs b/mcs/class/System.Web/System.Web.Util/SecureHashCodeProvider.cs
+new file mode 100644
+index 0000000..165022c
+--- /dev/null
++++ b/mcs/class/System.Web/System.Web.Util/SecureHashCodeProvider.cs
+@@ -0,0 +1,131 @@
++//
++// System.Collections.SecureHashCodeProvider.cs
++//
++// Authors:
++// Sergey Chaban (serge@wildwestsoftware.com)
++// Andreas Nahr (ClassDevelopment@A-SoftTech.com)
++// Sebastien Pouliot <sebastien@ximian.com>
++//
++// Copyright (C) 2004-2005 Novell, Inc (http://www.novell.com)
++// Copyright 2012 Xamarin, Inc (http://xamarin.com)
++//
++// Permission is hereby granted, free of charge, to any person obtaining
++// a copy of this software and associated documentation files (the
++// "Software"), to deal in the Software without restriction, including
++// without limitation the rights to use, copy, modify, merge, publish,
++// distribute, sublicense, and/or sell copies of the Software, and to
++// permit persons to whom the Software is furnished to do so, subject to
++// the following conditions:
++//
++// The above copyright notice and this permission notice shall be
++// included in all copies or substantial portions of the Software.
++//
++// THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND,
++// EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF
++// MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND
++// NONINFRINGEMENT. IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT HOLDERS BE
++// LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION
++// OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION
++// WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.
++//
++using System;
++using System.Collections;
++using System.Globalization;
++
++namespace System.Web.Util
++{
++ class SecureHashCodeProvider : IHashCodeProvider
++ {
++ static readonly SecureHashCodeProvider singletonInvariant = new SecureHashCodeProvider (CultureInfo.InvariantCulture);
++ static SecureHashCodeProvider singleton;
++ static readonly object sync = new object ();
++ static readonly int seed;
++
++ TextInfo m_text; // must match MS name for serialization
++
++ public static SecureHashCodeProvider Default {
++ get {
++ lock (sync) {
++ if (singleton == null) {
++ singleton = new SecureHashCodeProvider ();
++ } else if (singleton.m_text == null) {
++ if (!AreEqual (CultureInfo.CurrentCulture, CultureInfo.InvariantCulture))
++ singleton = new SecureHashCodeProvider ();
++ } else if (!AreEqual (singleton.m_text, CultureInfo.CurrentCulture)) {
++ singleton = new SecureHashCodeProvider ();
++ }
++ return singleton;
++ }
++ }
++ }
++
++ public static SecureHashCodeProvider DefaultInvariant {
++ get { return singletonInvariant; }
++ }
++
++ static SecureHashCodeProvider ()
++ {
++ // It should be enough to fend off the attack described in
++ // https://bugzilla.novell.com/show_bug.cgi?id=739119
++ // In order to predict value of the seed, the attacker would have to know the exact time when
++ // the server process started and since it's a remote attack, this is next to impossible.
++ // Using milliseconds instead of ticks here would make it easier for the attackers since there
++ // would only be as many as 1000 possible values
++ seed = (int)DateTime.UtcNow.Ticks;
++ }
++
++ // Public instance constructor
++ public SecureHashCodeProvider ()
++ {
++ CultureInfo culture = CultureInfo.CurrentCulture;
++ if (!AreEqual (culture, CultureInfo.InvariantCulture))
++ m_text = CultureInfo.CurrentCulture.TextInfo;
++ }
++
++ public SecureHashCodeProvider (CultureInfo culture)
++ {
++ if (culture == null)
++ throw new ArgumentNullException ("culture");
++ if (!AreEqual (culture, CultureInfo.InvariantCulture))
++ m_text = culture.TextInfo;
++ }
++
++ static bool AreEqual (CultureInfo a, CultureInfo b)
++ {
++ return a.LCID == b.LCID;
++ }
++
++ static bool AreEqual (TextInfo info, CultureInfo culture)
++ {
++ return info.LCID == culture.LCID;
++ }
++
++ public int GetHashCode (object obj)
++ {
++ if (obj == null)
++ throw new ArgumentNullException ("obj");
++
++ string str = obj as string;
++
++ if (str == null)
++ return obj.GetHashCode ();
++
++ int h = seed;
++ char c;
++
++ if ((m_text != null) && !AreEqual (m_text, CultureInfo.InvariantCulture)) {
++ str = m_text.ToLower (str);
++ for (int i = 0; i < str.Length; i++) {
++ c = str [i];
++ h = h * 31 + c;
++ }
++ } else {
++ for (int i = 0; i < str.Length; i++) {
++ c = Char.ToLower (str [i], CultureInfo.InvariantCulture);
++ h = h * 31 + c;
++ }
++ }
++ return h;
++ }
++ }
++}
+diff --git a/mcs/class/System.Web/System.Web.dll.sources b/mcs/class/System.Web/System.Web.dll.sources
+index ca7745a..aa41fca 100644
+--- a/mcs/class/System.Web/System.Web.dll.sources
++++ b/mcs/class/System.Web/System.Web.dll.sources
+@@ -1174,6 +1174,7 @@ System.Web.Util/IWebPropertyAccessor.cs
+ System.Web.Util/MachineKeySectionUtils.cs
+ System.Web.Util/RuntimeHelpers.cs
+ System.Web.Util/SearchPattern.cs
++System.Web.Util/SecureHashCodeProvider.cs
+ System.Web.Util/SerializationHelper.cs
+ System.Web.Util/StrUtils.cs
+ System.Web.Util/TimeUtil.cs
+diff --git a/mcs/class/System.Web/System.Web/WebROCollection.cs b/mcs/class/System.Web/System.Web/WebROCollection.cs
+index ddb2e30..e1b98df 100644
+--- a/mcs/class/System.Web/System.Web/WebROCollection.cs
++++ b/mcs/class/System.Web/System.Web/WebROCollection.cs
+@@ -5,6 +5,7 @@
+ // Gonzalo Paniagua Javier (gonzalo@novell.com)
+ //
+ // (c) 2005-2009 Novell, Inc. (http://www.novell.com)
++// Copyright 2012 Xamarin, Inc (http://xamarin.com)
+ //
+ //
+ // Permission is hereby granted, free of charge, to any person obtaining
+@@ -26,8 +27,10 @@
+ // OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION
+ // WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.
+ //
++using System.Collections;
+ using System.Collections.Specialized;
+ using System.Text;
++using System.Web.Util;
+
+ namespace System.Web
+ {
+@@ -36,7 +39,7 @@ class WebROCollection : NameValueCollection
+ bool got_id;
+ int id;
+
+- public WebROCollection () : base (StringComparer.OrdinalIgnoreCase) { }
++ public WebROCollection () : base (SecureHashCodeProvider.DefaultInvariant, CaseInsensitiveComparer.DefaultInvariant) { }
+ public bool GotID {
+ get { return got_id; }
+ }
+--
+1.7.10
+
diff --git a/dev-lang/mono/files/mono-2.10.9-CVE-2012-3543_2.patch b/dev-lang/mono/files/mono-2.10.9-CVE-2012-3543_2.patch
new file mode 100644
index 000000000000..6ab3e077b689
--- /dev/null
+++ b/dev-lang/mono/files/mono-2.10.9-CVE-2012-3543_2.patch
@@ -0,0 +1,34 @@
+From 049bb49f1c5b650166de2a266bc1879c5def0190 Mon Sep 17 00:00:00 2001
+From: Marek Habersack <grendel@twistedcode.net>
+Date: Wed, 25 Jul 2012 08:42:09 -0400
+Subject: [PATCH] Update to fix for Novell bug #739119
+
+---
+ mcs/class/System.Web/System.Web.UI/Page.cs | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/mcs/class/System.Web/System.Web.UI/Page.cs b/mcs/class/System.Web/System.Web.UI/Page.cs
+index 989af7e..b2316a4 100644
+--- a/mcs/class/System.Web/System.Web.UI/Page.cs
++++ b/mcs/class/System.Web/System.Web.UI/Page.cs
+@@ -1175,7 +1175,7 @@ internal void OnFormPostRender (HtmlTextWriter writer, string formUniqueID)
+
+ void ProcessPostData (NameValueCollection data, bool second)
+ {
+- NameValueCollection requestValues = _requestValueCollection == null ? new NameValueCollection () : _requestValueCollection;
++ NameValueCollection requestValues = _requestValueCollection == null ? new NameValueCollection (SecureHashCodeProvider.DefaultInvariant, CaseInsensitiveComparer.DefaultInvariant) : _requestValueCollection;
+
+ if (data != null && data.Count > 0) {
+ var used = new Dictionary <string, string> (StringComparer.Ordinal);
+@@ -1210,7 +1210,7 @@ void ProcessPostData (NameValueCollection data, bool second)
+
+ } else if (!second) {
+ if (secondPostData == null)
+- secondPostData = new NameValueCollection ();
++ secondPostData = new NameValueCollection (SecureHashCodeProvider.DefaultInvariant, CaseInsensitiveComparer.DefaultInvariant);
+ secondPostData.Add (id, data [id]);
+ }
+ }
+--
+1.7.10
+
diff --git a/dev-lang/mono/mono-2.10.5.ebuild b/dev-lang/mono/mono-2.10.5.ebuild
deleted file mode 100644
index 6f052be5ab18..000000000000
--- a/dev-lang/mono/mono-2.10.5.ebuild
+++ /dev/null
@@ -1,274 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/mono/mono-2.10.5.ebuild,v 1.6 2011/11/10 19:14:21 xarthisius Exp $
-
-EAPI="4"
-
-inherit linux-info mono eutils flag-o-matic multilib go-mono pax-utils
-
-DESCRIPTION="Mono runtime and class libraries, a C# compiler/interpreter"
-HOMEPAGE="http://www.mono-project.com/Main_Page"
-
-LICENSE="MIT LGPL-2.1 GPL-2 BSD-4 NPL-1.1 Ms-PL GPL-2-with-linking-exception IDPL"
-SLOT="0"
-KEYWORDS="amd64 ppc x86"
-
-IUSE="minimal pax_kernel xen"
-
-#Bash requirement is for += operator
-COMMONDEPEND="!dev-util/monodoc
- !minimal? ( =dev-dotnet/libgdiplus-${GO_MONO_REL_PV}* )
- ia64? ( sys-libs/libunwind )"
-RDEPEND="${COMMONDEPEND}
- || ( www-client/links www-client/lynx )"
-
-DEPEND="${COMMONDEPEND}
- sys-devel/bc
- virtual/yacc
- >=app-shells/bash-3.2
- pax_kernel? ( sys-apps/paxctl )"
-
-MAKEOPTS="${MAKEOPTS} -j1"
-
-RESTRICT="test"
-
-pkg_setup() {
- if use kernel_linux
- then
- get_version
- if linux_config_exists
- then
- if linux_chkconfig_present SYSVIPC
- then
- einfo "CONFIG_SYSVIPC is set, looking good."
- else
- eerror "If CONFIG_SYSVIPC is not set in your kernel .config, mono will hang while compiling."
- eerror "See http://bugs.gentoo.org/261869 for more info."
- die "Please set CONFIG_SYSVIPC in your kernel .config"
- fi
- else
- ewarn "Was unable to determine your kernel .config"
- ewarn "Please note that if CONFIG_SYSVIPC is not set in your kernel .config, mono will hang while compiling."
- ewarn "See http://bugs.gentoo.org/261869 for more info."
- fi
- fi
- PATCHES=( "${FILESDIR}/${PN}-2.10.2-threads-access.patch" )
-}
-
-src_prepare() {
- go-mono_src_prepare
-
- # we need to sed in the paxctl -mr in the runtime/mono-wrapper.in so it don't
- # get killed in the build proces when MPROTEC is enable. #286280
- # RANDMMAP kill the build proces to #347365
- if use pax_kernel ; then
- ewarn "We are disabling MPROTECT on the mono binary."
- sed '/exec/ i\paxctl -mr "$r/@mono_runtime@"' -i "${S}"/runtime/mono-wrapper.in
- fi
-}
-
-src_configure() {
- # mono's build system is finiky, strip the flags
- strip-flags
-
- #Remove this at your own peril. Mono will barf in unexpected ways.
- append-flags -fno-strict-aliasing
-
- # NOTE: We need the static libs for now so mono-debugger works.
- # See http://bugs.gentoo.org/show_bug.cgi?id=256264 for details
- #
- # --without-moonlight since www-plugins/moonlight is not the only one
- # using mono: https://bugzilla.novell.com/show_bug.cgi?id=641005#c3
- #
- # --with-profile4 needs to be always enabled since it's used by default
- # and, otherwise, problems like bug #340641 appear.
- #
- # sgen fails on ppc, bug #359515
-
- local myconf=""
- use ppc && myconf="${myconf} --with-sgen=no"
- go-mono_src_configure \
- --enable-static \
- --disable-quiet-build \
- --without-moonlight \
- --with-libgdiplus=$(use minimal && printf "no" || printf "installed" ) \
- $(use_with xen xen_opt) \
- --without-ikvm-native \
- --with-jit \
- --disable-dtrace \
- --with-profile4 \
- ${myconf}
-}
-
-src_test() {
- echo ">>> Test phase [check]: ${CATEGORY}/${PF}"
-
- export MONO_REGISTRY_PATH="${T}/registry"
- export XDG_DATA_HOME="${T}/data"
- export MONO_SHARED_DIR="${T}/shared"
- export XDG_CONFIG_HOME="${T}/config"
- export HOME="${T}/home"
-
- emake -j1 check
-}
-
-src_install() {
- go-mono_src_install
-
- # Remove files not respecting LDFLAGS and that we are not supposed to provide, see Fedora
- # mono.spec and http://www.mail-archive.com/mono-devel-list@lists.ximian.com/msg24870.html
- # for reference.
- rm -f "${D}"/usr/$(get_libdir)/mono/2.0/mscorlib.dll.so
- rm -f "${D}"/usr/$(get_libdir)/mono/2.0/mcs.exe.so
-}
-
-#THINK!!!! Before touching postrm and postinst
-#Reference phase order:
-#pkg_preinst
-#pkg_prerm
-#pkg_postrm
-#pkg_postinst
-
-pkg_preinst() {
- local symlink
- local NUNIT_DIR="/usr/$(get_libdir)/mono/nunit"
- local pv_atom
- if [[ "$(readlink "${ROOT}"/${NUNIT_DIR})" == *"mono-nunit"* ]]
- then
- for pv_atom in 2.2{,-r1,-r2,-r3,-r4} '2.4_pre*' '2.4_rc*' 2.4
- do
- if has_version "=dev-lang/mono-${pv_atom}"
- then
- einfo "If you just received a file collision warning message,"
- einfo "be advised that this is a known problem, which will now be fixed:"
- ebegin "Found broken symlinks created by $(best_version dev-lang/mono), fixing"
- for symlink in \
- "${ROOT}/${NUNIT_DIR}" \
- "${ROOT}/usr/$(get_libdir)/pkgconfig/nunit.pc" \
- "${ROOT}/usr/bin/nunit-console" \
- "${ROOT}/usr/bin/nunit-console2"
- do
- if [[ -L "${symlink}" ]]
- then
- rm -f "${symlink}" &> /dev/null
- fi
- done
- eend 0
- break
- fi
- done
- fi
-}
-
-pkg_postinst() {
- elog "PLEASE TAKE NOTE!"
- elog ""
- elog "Some of the namespaces supported by Mono require extra packages to be installed."
- elog "Below is a list of namespaces and the corresponding package you must install:"
- elog ""
- elog ">=x11-libs/cairo-1.6.4"
- elog " Mono.Cairo"
- elog "Also read:"
- elog "http://www.mono-project.com/Mono.Cairo"
- elog ""
- elog ">=dev-db/firebird-2.0.4.13130.1"
- elog " FirebirdSql.Data.Firebird"
- elog "Also read:"
- elog "http://www.mono-project.com/Firebird_Interbase"
- elog ""
- elog "=dev-dotnet/gluezilla-${GO_MONO_REL_PV}*"
- elog " Mono.Mozilla"
- elog " Mono.Mozilla.WebBrowser"
- elog " Mono.Mozilla.Widget"
- elog " Interop.SHDocVw"
- elog " AxInterop.SHDocVw"
- elog " Interop.mshtml.dll"
- elog " System.Windows.Forms.WebBrowser"
- elog " Microsoft.IE"
- elog "Also read:"
- elog "http://www.mono-project.com/WebBrowser"
- elog ""
- elog "dev-db/sqlite:3"
- elog " Mono.Data.Sqlite"
- elog "Also read:"
- elog "http://www.mono-project.com/SQLite"
- elog ""
- elog ">=dev-db/oracle-instantclient-basic-10.2"
- elog " System.Data.OracleClient"
- elog "Also read:"
- elog "http://www.mono-project.com/Oracle"
- elog ""
- elog "Mono also has support for packages that are not included in portage:"
- elog ""
- elog "No ebuild available:"
- elog " IBM.Data.DB2"
- elog "Also read: http://www.mono-project.com/IBM_DB2"
- elog ""
- elog "No ebuild needed:"
- elog " Mono.Data.SybaseClient"
- elog "Also read: http://www.mono-project.com/Sybase"
-}
-
-# NOTICE: THE COPYRIGHT FILES IN THE TARBALL ARE UNCLEAR!
-# WHENEVER YOU THINK SOMETHING IS GPL-2+, IT'S ONLY GPL-2
-# UNLESS MIGUEL DE ICAZA HIMSELF SAYS OTHERWISE.
-
-# mono
-# The code we use is LGPL, but contributions must be made under the MIT/X11
-# license, so Novell can serve its paying customers. Exception is mono/man.
-# LICENSE="LGPL-2.1"
-
- # mono/man
- # LICENSE="MIT"
-
-# mcs/mcs
-# mcs/gmcs
-# LICENSE="GPL-2 MIT"
-
-# tests
-# LICENSE="MIT"
-
-# mcs/class
-# Except the listed exceptions:
-# LICENSE="MIT"
-
- # mcs/class/ByteFX.Data
- # mcs/class/Npgsql
- # LICENSE="LGPL-2.1"
-
- # mcs/class/FirebirdSql.Data.Firebird
- # LICENSE="IDPL"
-
- # mcs/class/ICSharpCode.SharpZipLib
- # LICENSE="GPL-2-with-linking-exception"
-
- # mcs/class/MicrosoftAjaxLibrary
- # LICENSE="Ms-Pl"
-
- # mcs/class/Microsoft.JScript/Microsoft.JScript/TokenStream.cs
- # mcs/class/Microsoft.JScript/Microsoft.JScript/Token.cs
- # mcs/class/Microsoft.JScript/Microsoft.JScript/Parser.cs
- # mcs/class/Microsoft.JScript/Microsoft.JScript/Decompiler.cs
- # LICENSE="|| ( NPL-1.1 GPL-2 )"
-
-# mcs/jay
-# LICENSE="BSD-4"
-
-# mcs/tools
-# Except the listed exceptions:
-# LICENSE="MIT"
-
- # mcs/tools/mdoc/Mono.Documentation/monodocs2html.cs
- # LICENSE="GPL-2"
-
- # mcs/tools/sqlsharp/SqlSharpCli.cs
- # LICENSE="GPL-2"
-
- # mcs/tools/csharp/repl.cs
- # LICENSE="|| ( MIT GPL-2 )"
-
- # mcs/tools/mono-win32-setup.nsi
- # LICENSE="GPL-2"
-
-# samples
-# LICENSE="MIT"
diff --git a/dev-lang/mono/mono-2.10.8.ebuild b/dev-lang/mono/mono-2.10.9-r2.ebuild
index f5090613c63a..7ef0e6743a9e 100644
--- a/dev-lang/mono/mono-2.10.8.ebuild
+++ b/dev-lang/mono/mono-2.10.9-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/mono/mono-2.10.8.ebuild,v 1.5 2012/08/18 12:28:43 xmw Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/mono/mono-2.10.9-r2.ebuild,v 1.1 2012/09/15 13:37:04 pacho Exp $
EAPI="4"
@@ -11,7 +11,7 @@ HOMEPAGE="http://www.mono-project.com/Main_Page"
LICENSE="MIT LGPL-2.1 GPL-2 BSD-4 NPL-1.1 Ms-PL GPL-2-with-linking-exception IDPL"
SLOT="0"
-KEYWORDS="amd64 ppc x86"
+KEYWORDS="~amd64 ~ppc ~x86"
IUSE="minimal pax_kernel xen"
@@ -52,7 +52,10 @@ pkg_setup() {
ewarn "See http://bugs.gentoo.org/261869 for more info."
fi
fi
- PATCHES=( "${FILESDIR}/${PN}-2.10.2-threads-access.patch" )
+ PATCHES=( "${FILESDIR}/${PN}-2.10.2-threads-access.patch"
+ "${FILESDIR}/${PN}-2.10.9-CVE-2012-3382.patch"
+ "${FILESDIR}/${PN}-2.10.9-CVE-2012-3543.patch"
+ "${FILESDIR}/${PN}-2.10.9-CVE-2012-3543_2.patch" )
}
src_prepare() {
@@ -160,42 +163,42 @@ pkg_preinst() {
fi
}
-pkg_postinst() {
- elog "PLEASE TAKE NOTE!"
- elog ""
- elog "Some of the namespaces supported by Mono require extra packages to be installed."
- elog "Below is a list of namespaces and the corresponding package you must install:"
- elog ""
- elog ">=x11-libs/cairo-1.6.4"
- elog " Mono.Cairo"
- elog "Also read:"
- elog "http://www.mono-project.com/Mono.Cairo"
- elog ""
- elog ">=dev-db/firebird-2.0.4.13130.1"
- elog " FirebirdSql.Data.Firebird"
- elog "Also read:"
- elog "http://www.mono-project.com/Firebird_Interbase"
- elog ""
- elog "dev-db/sqlite:3"
- elog " Mono.Data.Sqlite"
- elog "Also read:"
- elog "http://www.mono-project.com/SQLite"
- elog ""
- elog ">=dev-db/oracle-instantclient-basic-10.2"
- elog " System.Data.OracleClient"
- elog "Also read:"
- elog "http://www.mono-project.com/Oracle"
- elog ""
- elog "Mono also has support for packages that are not included in portage:"
- elog ""
- elog "No ebuild available:"
- elog " IBM.Data.DB2"
- elog "Also read: http://www.mono-project.com/IBM_DB2"
- elog ""
- elog "No ebuild needed:"
- elog " Mono.Data.SybaseClient"
- elog "Also read: http://www.mono-project.com/Sybase"
-}
+#pkg_postinst() {
+# elog "PLEASE TAKE NOTE!"
+# elog ""
+# elog "Some of the namespaces supported by Mono require extra packages to be installed."
+# elog "Below is a list of namespaces and the corresponding package you must install:"
+# elog ""
+# elog ">=x11-libs/cairo-1.6.4"
+# elog " Mono.Cairo"
+# elog "Also read:"
+# elog "http://www.mono-project.com/Mono.Cairo"
+# elog ""
+# elog ">=dev-db/firebird-2.0.4.13130.1"
+# elog " FirebirdSql.Data.Firebird"
+# elog "Also read:"
+# elog "http://www.mono-project.com/Firebird_Interbase"
+# elog ""
+# elog "dev-db/sqlite:3"
+# elog " Mono.Data.Sqlite"
+# elog "Also read:"
+# elog "http://www.mono-project.com/SQLite"
+# elog ""
+# elog ">=dev-db/oracle-instantclient-basic-10.2"
+# elog " System.Data.OracleClient"
+# elog "Also read:"
+# elog "http://www.mono-project.com/Oracle"
+# elog ""
+# elog "Mono also has support for packages that are not included in portage:"
+# elog ""
+# elog "No ebuild available:"
+# elog " IBM.Data.DB2"
+# elog "Also read: http://www.mono-project.com/IBM_DB2"
+# elog ""
+# elog "No ebuild needed:"
+# elog " Mono.Data.SybaseClient"
+# elog "Also read: http://www.mono-project.com/Sybase"
+#}
# NOTICE: THE COPYRIGHT FILES IN THE TARBALL ARE UNCLEAR!
# WHENEVER YOU THINK SOMETHING IS GPL-2+, IT'S ONLY GPL-2