summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSaleem Abdulrasool <compnerd@gentoo.org>2006-09-04 06:57:47 +0000
committerSaleem Abdulrasool <compnerd@gentoo.org>2006-09-04 06:57:47 +0000
commit7b7902c1c9ea9de404f4a80fd31f3394ccf74963 (patch)
treecf36d894622ce97cd2e8444b02eb6299eb2877eb /dev-lang/mono
parentAdded ~mips to KEYWORDS. (diff)
downloadgentoo-2-7b7902c1c9ea9de404f4a80fd31f3394ccf74963.tar.gz
gentoo-2-7b7902c1c9ea9de404f4a80fd31f3394ccf74963.tar.bz2
gentoo-2-7b7902c1c9ea9de404f4a80fd31f3394ccf74963.zip
version bump from upstream
(Portage version: 2.1.1_rc1-r2)
Diffstat (limited to 'dev-lang/mono')
-rw-r--r--dev-lang/mono/ChangeLog8
-rw-r--r--dev-lang/mono/files/digest-mono-1.1.17.13
-rw-r--r--dev-lang/mono/mono-1.1.17.1.ebuild101
3 files changed, 111 insertions, 1 deletions
diff --git a/dev-lang/mono/ChangeLog b/dev-lang/mono/ChangeLog
index 85a2300b1089..bfca6766391a 100644
--- a/dev-lang/mono/ChangeLog
+++ b/dev-lang/mono/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-lang/mono
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/mono/ChangeLog,v 1.89 2006/07/17 15:42:01 dang Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/mono/ChangeLog,v 1.90 2006/09/04 06:57:47 compnerd Exp $
+
+*mono-1.1.17.1 (04 Sep 2006)
+
+ 04 Sep 2006; Saleem Abdulrasool <compnerd@gentoo.org>
+ +mono-1.1.17.1.ebuild:
+ version bump from upstream
17 Jul 2006; Daniel Gryniewicz <dang@gentoo.org> mono-1.1.13.6.ebuild:
Marked stable on amd64 for bug #139612
diff --git a/dev-lang/mono/files/digest-mono-1.1.17.1 b/dev-lang/mono/files/digest-mono-1.1.17.1
new file mode 100644
index 000000000000..b1bf82265320
--- /dev/null
+++ b/dev-lang/mono/files/digest-mono-1.1.17.1
@@ -0,0 +1,3 @@
+MD5 072cb3de1f19cbebd6034f7a5cff1292 mono-1.1.17.1.tar.gz 19352812
+RMD160 664c46d1b81015c427177ab6a704d2bda5a3ad82 mono-1.1.17.1.tar.gz 19352812
+SHA256 abc547c45952152a4aebd3923790f651ce32c5535ea1de3aae031fba2a06b489 mono-1.1.17.1.tar.gz 19352812
diff --git a/dev-lang/mono/mono-1.1.17.1.ebuild b/dev-lang/mono/mono-1.1.17.1.ebuild
new file mode 100644
index 000000000000..ff6989d7908c
--- /dev/null
+++ b/dev-lang/mono/mono-1.1.17.1.ebuild
@@ -0,0 +1,101 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/mono/mono-1.1.17.1.ebuild,v 1.1 2006/09/04 06:57:47 compnerd Exp $
+
+inherit eutils flag-o-matic multilib autotools
+
+DESCRIPTION="Mono runtime and class libraries, a C# compiler/interpreter"
+HOMEPAGE="http://www.go-mono.com"
+SRC_URI="http://www.go-mono.com/sources/mono-${PV:0:3}/${P}.tar.gz"
+
+LICENSE="|| ( GPL-2 LGPL-2 X11 )"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="X nptl"
+
+RDEPEND="!<dev-dotnet/pnet-0.6.12
+ >=dev-libs/glib-2.6
+ nptl? ( >=sys-devel/gcc-3.3.5-r1 )
+ ppc? (
+ >=sys-devel/gcc-3.2.3-r4
+ >=sys-libs/glibc-2.3.3_pre20040420
+ )
+ X? ( >=dev-dotnet/libgdiplus-1.1.17 )"
+DEPEND="${RDEPEND}
+ sys-devel/bc
+ >=dev-util/pkgconfig-0.19"
+
+# Parallel build unfriendly
+MAKEOPTS="${MAKEOPTS} -j1"
+
+# confcache causes build errors
+RESTRICT="confcache"
+
+function get-memory-total() {
+ cat /proc/meminfo | grep MemTotal | sed -r "s/[^0-9]*([[0-9]+).*/\1/"
+}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ # Fix the install path, install into $(libdir)
+ sed -i -e 's:$(prefix)/lib:$(libdir):' \
+ -i -e 's:$(exec_prefix)/lib:$(libdir):' \
+ -i -e "s:'mono_libdir=\${exec_prefix}/lib':\"mono_libdir=\$libdir\":" \
+ ${S}/{scripts,mono/metadata}/Makefile.am ${S}/configure.in \
+ || die "sed failed"
+
+ sed -i -e 's:^libdir.*:libdir=@libdir@:' \
+ -i -e 's:${prefix}/lib/:${libdir}/:g' \
+ ${S}/{scripts,}/*.pc.in \
+ || die "sed failed"
+
+ # Remove dummy ltconfig and let libtool handle it
+ rm -f ${S}/libgc/ltconfig
+
+ eautoreconf
+}
+
+src_compile() {
+ # mono's build system is finiky, strip the flags
+ strip-flags
+
+ # Enable the 2.0 FX, use the system glib and the gc
+ local myconf="--with-preview=yes --with-glib=system --with-gc=included"
+
+ # Threading support
+ if use amd64 ; then
+ # force __thread on amd64 (bug #83770)
+ myconf="${myconf} --with-tls=__thread"
+ else
+ if use nptl ; then
+ myconf="${myconf} --with-tls=__thread"
+ else
+ myconf="${myconf} --with-tls=pthread"
+ fi
+ fi
+
+ # Enable large heaps if memory is more than >=3GB
+ if [[ $(get-memory-total) -ge 3145728 ]] ; then
+ myconf="${myconf} --with-large-heap=yes"
+ fi
+
+ # Force the use of monolite mcs to prevent issues with classlibs (bug #118062)
+ touch ${S}/mcs/build/deps/use-monolite
+
+ econf ${myconf} || die "configure failed"
+ emake || die "compile failed"
+}
+
+src_install() {
+ emake DESTDIR=${D} install || die "install failed"
+
+ dodoc AUTHORS ChangeLog NEWS README
+
+ docinto docs
+ dodoc docs/*
+
+ docinto libgc
+ dodoc libgc/ChangeLog
+}