summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Johanson <latexer@gentoo.org>2006-07-12 17:58:45 +0000
committerPeter Johanson <latexer@gentoo.org>2006-07-12 17:58:45 +0000
commit7c89ac4930e5dee36c1843006d951481eac5222f (patch)
treed2f09ae086122d31f340e360f67baee7c7ae10ca /dev-lang/mono
parentMinor bump, and remove one obsoleted version. (diff)
downloadgentoo-2-7c89ac4930e5dee36c1843006d951481eac5222f.tar.gz
gentoo-2-7c89ac4930e5dee36c1843006d951481eac5222f.tar.bz2
gentoo-2-7c89ac4930e5dee36c1843006d951481eac5222f.zip
Minor bump, and remove one obsoleted version.
(Portage version: 2.1.1_pre2-r6)
Diffstat (limited to 'dev-lang/mono')
-rw-r--r--dev-lang/mono/ChangeLog8
-rw-r--r--dev-lang/mono/files/digest-mono-1.1.16.13
-rw-r--r--dev-lang/mono/mono-1.1.16.1.ebuild97
3 files changed, 107 insertions, 1 deletions
diff --git a/dev-lang/mono/ChangeLog b/dev-lang/mono/ChangeLog
index 5eaf9cab0a8d..99b3c4c50bf4 100644
--- a/dev-lang/mono/ChangeLog
+++ b/dev-lang/mono/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-lang/mono
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/mono/ChangeLog,v 1.84 2006/07/12 15:26:35 latexer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/mono/ChangeLog,v 1.85 2006/07/12 17:58:45 latexer Exp $
+
+*mono-1.1.16.1 (12 Jul 2006)
+
+ 12 Jul 2006; Peter Johanson <latexer@gentoo.org> -mono-1.1.16.ebuild,
+ +mono-1.1.16.1.ebuild:
+ Minor bump, and remove one obsoleted version.
*mono-1.1.16 (12 Jul 2006)
diff --git a/dev-lang/mono/files/digest-mono-1.1.16.1 b/dev-lang/mono/files/digest-mono-1.1.16.1
new file mode 100644
index 000000000000..50bfa4334828
--- /dev/null
+++ b/dev-lang/mono/files/digest-mono-1.1.16.1
@@ -0,0 +1,3 @@
+MD5 11556607ba74cae225d9c73aef09e5e3 mono-1.1.16.1.tar.gz 19115095
+RMD160 3ccf59d5e8f3e7ce74bccd495d7a8413a0fdce9c mono-1.1.16.1.tar.gz 19115095
+SHA256 6404bd0b34c642bb159328486949424d7d51f444cfbed5c83ee5f4ee3ad34b0f mono-1.1.16.1.tar.gz 19115095
diff --git a/dev-lang/mono/mono-1.1.16.1.ebuild b/dev-lang/mono/mono-1.1.16.1.ebuild
new file mode 100644
index 000000000000..3dd25a5836b7
--- /dev/null
+++ b/dev-lang/mono/mono-1.1.16.1.ebuild
@@ -0,0 +1,97 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/mono/mono-1.1.16.1.ebuild,v 1.1 2006/07/12 17:58:45 latexer Exp $
+
+inherit eutils mono flag-o-matic multilib autotools
+
+RESTRICT="confcache"
+
+DESCRIPTION="Mono runtime and class libraries, a C# compiler/interpreter"
+HOMEPAGE="http://www.go-mono.com/"
+SRC_URI="http://www.go-mono.com/sources/mono-${PV:0:3}/${P}.tar.gz"
+
+LICENSE="|| ( GPL-2 LGPL-2 X11 )"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~amd64"
+IUSE="nptl X"
+
+DEPEND=">=dev-libs/glib-2.0
+ sys-devel/bc
+ !<dev-dotnet/pnet-0.6.12
+ nptl? ( >=sys-devel/gcc-3.3.5-r1 )
+ ppc? (
+ >=sys-devel/gcc-3.2.3-r4
+ >=sys-libs/glibc-2.3.3_pre20040420
+ )"
+
+RDEPEND="${DEPEND}
+ X? ( >=dev-dotnet/libgdiplus-1.1.16 )
+ dev-util/pkgconfig
+ dev-libs/libxml2"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ # Fix munging of Unix paths
+ epatch ${FILESDIR}/${PN}-1.1.13-pathfix.diff
+
+ # Install all our .dlls under $(libdir), not $(prefix)/lib
+ if [ $(get_libdir) != "lib" ] ; then
+ sed -i -e 's:$(prefix)/lib:$(libdir):' \
+ -e 's:$(exec_prefix)/lib:$(libdir):' \
+ -e "s:'mono_libdir=\${exec_prefix}/lib':\"mono_libdir=\$libdir\":" \
+ ${S}/{scripts,mono/metadata,mono/os/unix}/Makefile.am \
+ ${S}/configure.in || die "sed failed"
+ sed -i -e 's:^libdir.*:libdir=@libdir@:' \
+ -e 's:${prefix}/lib/:${libdir}/:g' \
+ ${S}/{scripts,}/*.pc.in || die "sed failed"
+ fi
+
+ # Remove the dummy ltconfig and leave to libtoolize handling it
+ rm -f ${S}/libgc/ltconfig
+
+ eautoreconf
+}
+
+src_compile() {
+ strip-flags
+
+ local myconf="--with-preview=yes"
+
+ # Force __thread on amd64. See bug #83770
+ if use amd64
+ then
+ myconf="${myconf} --with-tls=__thread"
+ else
+ if use nptl
+ then
+ myconf="${myconf} --with-tls=__thread"
+ else
+ myconf="${myconf} --with-tls=pthread"
+ fi
+ fi
+
+ # Force the use of the monolite mcs, to prevent us from trying to build
+ # with old buggy classlibs/mcs versions. See bug #118062
+ touch ${S}/mcs/build/deps/use-monolite
+ econf ${myconf} || die
+ emake -j1 || die "MONO compilation failure"
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+
+ dodoc AUTHORS ChangeLog NEWS README
+ docinto docs
+ dodoc docs/*
+ docinto libgc
+ dodoc libgc/ChangeLog
+}
+
+pkg_postinst() {
+ ewarn "This version of mono has changed the assembly version for"
+ ewarn "ICSharpCode.SharpZipLib, which may break some installed"
+ ewarn "applications such as monodoc. Please re-emerge monodoc and any"
+ ewarn "other packages you have which may make use of this library."
+}