summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJonathan Callen <abcd@gentoo.org>2010-04-06 09:13:55 +0000
committerJonathan Callen <abcd@gentoo.org>2010-04-06 09:13:55 +0000
commitfed13ef75012f801bf7f9c09a09d82d0630ee5d6 (patch)
tree64b55389b867f907d71d7441899e6ba25afd3933 /dev-lang/mosml/mosml-2.01-r1.ebuild
parentForce python 2 version. Bug #312287 (diff)
downloadgentoo-2-fed13ef75012f801bf7f9c09a09d82d0630ee5d6.tar.gz
gentoo-2-fed13ef75012f801bf7f9c09a09d82d0630ee5d6.tar.bz2
gentoo-2-fed13ef75012f801bf7f9c09a09d82d0630ee5d6.zip
Bump to EAPI=3, add prefix keywords
(Portage version: -svn/cvs/Linux i686)
Diffstat (limited to 'dev-lang/mosml/mosml-2.01-r1.ebuild')
-rw-r--r--dev-lang/mosml/mosml-2.01-r1.ebuild36
1 files changed, 20 insertions, 16 deletions
diff --git a/dev-lang/mosml/mosml-2.01-r1.ebuild b/dev-lang/mosml/mosml-2.01-r1.ebuild
index 9f44f1538f0b..b152d41f2041 100644
--- a/dev-lang/mosml/mosml-2.01-r1.ebuild
+++ b/dev-lang/mosml/mosml-2.01-r1.ebuild
@@ -1,49 +1,53 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/mosml/mosml-2.01-r1.ebuild,v 1.4 2009/08/17 01:41:25 vostorga Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/mosml/mosml-2.01-r1.ebuild,v 1.5 2010/04/06 09:13:55 abcd Exp $
+
+EAPI="3"
inherit eutils
-S="${WORKDIR}/${PN}/src"
DESCRIPTION="Moscow ML - a lightweight implementation of Standard ML (SML)"
SRC_URI="http://www.itu.dk/people/sestoft/mosml/mos201src.tar.gz"
HOMEPAGE="http://www.itu.dk/people/sestoft/mosml.html"
+
LICENSE="GPL-2"
-KEYWORDS="~amd64 ~ppc ~x86"
-IUSE=""
SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE=""
DEPEND=""
RDEPEND=""
-src_unpack() {
- unpack ${A}
- cd "${S}"
+S="${WORKDIR}/${PN}/src"
+
+
+src_prepare() {
epatch "${FILESDIR}/${P}-malloc.patch" #154859
#Fixing pre-stripped files
sed -i -e "/STRIP/d" mosmlyac/Makefile || die "sed Makefile failed"
sed -i -e "/STRIP/d" runtime/Makefile || die "sed Makefile failed"
+
+ sed -i -e "s|^CPP=/lib/cpp|CPP=${EPREFIX}/usr/bin/cpp|" Makefile.inc
}
+src_configure() { :; }
+
src_compile() {
emake CC=$(tc-getCC) CPP="$(tc-getCPP) -P -traditional -Dunix -Umsdos" \
- MOSMLHOME=/opt/mosml world || die
+ MOSMLHOME="${EPREFIX}"/opt/mosml world || die
}
-src_install () {
-
- make MOSMLHOME="${D}"/opt/mosml install || die
- rm "${D}"/opt/mosml/lib/camlrunm # This is a bad symlink
- echo "#!/opt/mosml/bin/camlrunm" > "${D}"/opt/mosml/lib/header
+src_install() {
+ emake -j1 MOSMLHOME="${ED}"/opt/mosml install || die
+ rm "${ED}"opt/mosml/lib/camlrunm # This is a bad symlink
+ echo "#!${EPREFIX}/opt/mosml/bin/camlrunm" > "${ED}"opt/mosml/lib/header
dodoc ../README
- into /usr/bin
dosym /opt/mosml/bin/mosml /usr/bin/mosml
dosym /opt/mosml/bin/mosmlc /usr/bin/mosmlc
dosym /opt/mosml/bin/mosmllex /usr/bin/mosmllex
dosym /opt/mosml/bin/mosmlyac /usr/bin/mosmlyac
dosym /opt/mosml/bin/camlrunm /usr/bin/camlrunm
dosym /opt/mosml/bin/camlrunm /opt/mosml/lib/camlrunm
-
}