summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2004-12-16 19:20:47 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2004-12-16 19:20:47 +0000
commit0bab4be8d0d98587fb3abdb1eca743a7f4044765 (patch)
treecc5a01fd2d053a0755d975e8ed2a837bc2dc649d /dev-lang/nasm/nasm-0.98.38-r1.ebuild
parentstable; 74303 (Manifest recommit) (diff)
downloadgentoo-2-0bab4be8d0d98587fb3abdb1eca743a7f4044765.tar.gz
gentoo-2-0bab4be8d0d98587fb3abdb1eca743a7f4044765.tar.bz2
gentoo-2-0bab4be8d0d98587fb3abdb1eca743a7f4044765.zip
add patch from bug #74477 to address overflow; clean older version; tidy
Diffstat (limited to 'dev-lang/nasm/nasm-0.98.38-r1.ebuild')
-rw-r--r--dev-lang/nasm/nasm-0.98.38-r1.ebuild57
1 files changed, 57 insertions, 0 deletions
diff --git a/dev-lang/nasm/nasm-0.98.38-r1.ebuild b/dev-lang/nasm/nasm-0.98.38-r1.ebuild
new file mode 100644
index 000000000000..b88ec2298e16
--- /dev/null
+++ b/dev-lang/nasm/nasm-0.98.38-r1.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/nasm/nasm-0.98.38-r1.ebuild,v 1.1 2004/12/16 19:20:47 mr_bones_ Exp $
+
+inherit eutils
+
+DESCRIPTION="groovy little assembler"
+HOMEPAGE="http://nasm.sourceforge.net/"
+SRC_URI="mirror://sourceforge/nasm/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="-* x86 amd64"
+IUSE="doc build"
+
+DEPEND="!build? ( dev-lang/perl )
+ doc? ( virtual/ghostscript
+ sys-apps/texinfo )
+ sys-devel/gcc"
+RDEPEND="virtual/libc"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${PV}-overflow.patch"
+}
+
+src_compile() {
+ ./configure --prefix=/usr || die
+
+ if use build; then
+ emake nasm || die "emake failed"
+ else
+ emake all rdf || die "emake failed"
+ if use doc; then
+ emake doc || die "emake failed"
+ fi
+ fi
+
+}
+
+src_install() {
+ if use build; then
+ dobin nasm || die "dobin failed"
+ else
+ dobin nasm ndisasm rdoff/{ldrdf,rdf2bin,rdf2ihx,rdfdump,rdflib,rdx} \
+ || die "dobin failed"
+ dosym /usr/bin/rdf2bin /usr/bin/rdf2com
+ doman nasm.1 ndisasm.1
+ dodoc AUTHORS CHANGES ChangeLog INSTALL README TODO
+ if use doc; then
+ doinfo doc/info/*
+ dohtml doc/html/*
+ dodoc doc/nasmdoc.*
+ fi
+ fi
+}