summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndres Loeh <kosmikus@gentoo.org>2003-04-16 08:39:51 +0000
committerAndres Loeh <kosmikus@gentoo.org>2003-04-16 08:39:51 +0000
commitdd0a7d98414b5d05dc21bc23a849a2c6e32b733b (patch)
tree76b8edcfb0c085b86b322457e7cd2524501cc5f1 /dev-lang/nhc98/nhc98-1.16.ebuild
parentchanged emake -> make (problem with parallel builds) (diff)
downloadgentoo-2-dd0a7d98414b5d05dc21bc23a849a2c6e32b733b.tar.gz
gentoo-2-dd0a7d98414b5d05dc21bc23a849a2c6e32b733b.tar.bz2
gentoo-2-dd0a7d98414b5d05dc21bc23a849a2c6e32b733b.zip
cleaned up nhc98-1.16 ebuild
Diffstat (limited to 'dev-lang/nhc98/nhc98-1.16.ebuild')
-rw-r--r--dev-lang/nhc98/nhc98-1.16.ebuild49
1 files changed, 22 insertions, 27 deletions
diff --git a/dev-lang/nhc98/nhc98-1.16.ebuild b/dev-lang/nhc98/nhc98-1.16.ebuild
index c37b5b35f4b1..fd4acb433f86 100644
--- a/dev-lang/nhc98/nhc98-1.16.ebuild
+++ b/dev-lang/nhc98/nhc98-1.16.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/nhc98/nhc98-1.16.ebuild,v 1.2 2003/04/10 23:20:56 george Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/nhc98/nhc98-1.16.ebuild,v 1.3 2003/04/16 08:39:51 kosmikus Exp $
IUSE="readline"
@@ -13,7 +13,7 @@ HOMEPAGE="http://www.cs.york.ac.uk/fp/nhc98/"
SLOT="0"
LICENSE="nhc98"
-KEYWORDS="x86 ~sparc "
+KEYWORDS="~x86 ~sparc "
DEPEND="virtual/glibc
readline? ( >=readline-4.1 )"
@@ -44,31 +44,6 @@ src_install () {
# configure script.
make DESTDIR=${D} install || die
- #nhc's build system does not update hmakerc when using DESTDIR;
- #therefore, we do it manually here
-
- einfo "Adjusting... hmakerc"
- cd ${S}
- MACHINE=`script/harch`
- ${D}/usr/bin/hmake-config \
- ${D}/usr/lib/hmake/${MACHINE}/hmakerc add /usr/bin/nhc98
- ${D}/usr/bin/hmake-config \
- ${D}/usr/lib/hmake/${MACHINE}/hmakerc add nhc98 ||\
- einfo "(This error message is harmless)"
- ${D}/usr/bin/hmake-config \
- ${D}/usr/lib/hmake/${MACHINE}/hmakerc \
- default /usr/bin/nhc98
- # remove temporary build version of nhc98 from config
- ${D}/usr/bin/hmake-config \
- ${D}/usr/lib/hmake/${MACHINE}/hmakerc \
- delete ${S}/script/nhc98
-
- #need to adjust paths in hmakerc
- cd ${D}/usr/lib/hmake/${MACHINE}
- mv hmakerc hmakerc.orig
- sed -e "s:${S}/script/::" -e "s:${S}/include:/usr/include:" hmakerc.orig > hmakerc
-
- cd ${S}
#install docs and man pages manually
dodoc README INSTALL COPYRIGHT
doman man/*
@@ -78,3 +53,23 @@ src_install () {
docinto html/bugs
dodoc bugs/README
}
+
+pkg_postinst () {
+ #nhc's build system does not update hmakerc when using DESTDIR;
+ #therefore, we do it manually here
+
+ einfo "Adjusting... hmakerc"
+ MACHINE=`/usr/bin/harch`
+ /usr/bin/hmake-config \
+ /usr/lib/hmake/${MACHINE}/hmakerc add /usr/bin/nhc98
+ /usr/bin/hmake-config \
+ /usr/lib/hmake/${MACHINE}/hmakerc add nhc98 ||\
+ einfo "(This error message is harmless)"
+ /usr/bin/hmake-config \
+ /usr/lib/hmake/${MACHINE}/hmakerc \
+ default /usr/bin/nhc98
+ # remove temporary build version of nhc98 from config
+ /usr/bin/hmake-config \
+ /usr/lib/hmake/${MACHINE}/hmakerc \
+ delete ${S}/script/nhc98
+}