summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorge Shapovalov <george@gentoo.org>2003-04-10 08:59:59 +0000
committerGeorge Shapovalov <george@gentoo.org>2003-04-10 08:59:59 +0000
commita54e9415d44c4920fa96de07fb0be8270c87f060 (patch)
tree09d860dc4e7f139e4420f2012e7a8dccbc92c771 /dev-lang/nhc98
parentcleanup and portage-2.0.48_pre2 (diff)
downloadgentoo-2-a54e9415d44c4920fa96de07fb0be8270c87f060.tar.gz
gentoo-2-a54e9415d44c4920fa96de07fb0be8270c87f060.tar.bz2
gentoo-2-a54e9415d44c4920fa96de07fb0be8270c87f060.zip
update and fix, ~arch'ed for now
Diffstat (limited to 'dev-lang/nhc98')
-rw-r--r--dev-lang/nhc98/ChangeLog8
-rw-r--r--dev-lang/nhc98/files/digest-nhc98-1.162
-rw-r--r--dev-lang/nhc98/nhc98-1.16.ebuild74
3 files changed, 83 insertions, 1 deletions
diff --git a/dev-lang/nhc98/ChangeLog b/dev-lang/nhc98/ChangeLog
index 76db5ad18b76..465bd0bca67d 100644
--- a/dev-lang/nhc98/ChangeLog
+++ b/dev-lang/nhc98/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-lang/nhc98
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/nhc98/ChangeLog,v 1.5 2003/02/12 05:57:20 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/nhc98/ChangeLog,v 1.6 2003/04/10 08:59:59 george Exp $
+
+*nhc98-1.16 (09 Apr 2003)
+
+ 09 Apr 2003; George Shapovalov <george@gentoo.org> all :
+ update and fix, see #18857,
+ thanks to Andres Loeh <andres@cs.uu.nl> for ebuild
06 Dec 2002; Rodney Rees <manson@gentoo.org> : changed sparc ~sparc keywords
diff --git a/dev-lang/nhc98/files/digest-nhc98-1.16 b/dev-lang/nhc98/files/digest-nhc98-1.16
new file mode 100644
index 000000000000..e3dbcc015c5d
--- /dev/null
+++ b/dev-lang/nhc98/files/digest-nhc98-1.16
@@ -0,0 +1,2 @@
+MD5 a62866b8d966108cba325d0322a3010d nhc98src-1.16.tar.gz 5689485
+MD5 38b1505acbcbc5a91e077304e978ab82 patch-1.16-typesyn 5700
diff --git a/dev-lang/nhc98/nhc98-1.16.ebuild b/dev-lang/nhc98/nhc98-1.16.ebuild
new file mode 100644
index 000000000000..ce39ef3c59cd
--- /dev/null
+++ b/dev-lang/nhc98/nhc98-1.16.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/nhc98/nhc98-1.16.ebuild,v 1.1 2003/04/10 08:59:59 george Exp $
+
+IUSE="readline"
+
+TARBALL="nhc98src-${PV}.tar.gz"
+
+DESCRIPTION="Haskell 98 compiler"
+SRC_URI="ftp://ftp.cs.york.ac.uk/pub/haskell/nhc98/${TARBALL}
+ ftp://ftp.cs.york.ac.uk/pub/haskell/nhc98/patch-1.16-typesyn"
+HOMEPAGE="http://www.cs.york.ac.uk/fp/nhc98/"
+
+SLOT="0"
+LICENSE="nhc98"
+KEYWORDS="~x86 ~sparc "
+
+DEPEND="virtual/glibc
+ readline? ( >=readline-4.1 )"
+
+src_unpack() {
+ # unpack the source
+ unpack "${TARBALL}"
+ # type synoym patch
+ cd ${S}
+ epatch ${DISTDIR}/patch-1.16-typesyn
+# cd ${P}
+# patch -p0 < ${FILESDIR}/patch-1.16-typesyn
+}
+
+src_compile() {
+
+ ./configure --buildwith=gcc \
+ --prefix=/usr --installdir=/usr \
+ -man -docs \
+ --buildopts="${CFLAGS} --host=${CHOST}" || die "./configure failed"
+ # the build does not seem to work all that
+ # well with parallel make
+ make || die
+}
+
+src_install () {
+ # The install location is taken care of by the
+ # configure script.
+ make DESTDIR=${D} install || die
+
+ #nhc's build system does not update hmakerc when using DESTDIR;
+ #therefore, we do it manually here
+
+ einfo "Adjusting... hmakerc"
+ cd ${S}
+ MACHINE=`script/harch`
+ ${D}/usr/bin/hmake-config \
+ ${D}/usr/lib/hmake/${MACHINE}/hmakerc add /usr/bin/nhc98
+ ${D}/usr/bin/hmake-config \
+ ${D}/usr/lib/hmake/${MACHINE}/hmakerc add nhc98 ||\
+ einfo "(This error message is harmless)"
+ ${D}/usr/bin/hmake-config \
+ ${D}/usr/lib/hmake/${MACHINE}/hmakerc \
+ default /usr/bin/nhc98
+ # remove temporary build version of nhc98 from config
+ ${D}/usr/bin/hmake-config \
+ ${D}/usr/lib/hmake/${MACHINE}/hmakerc \
+ delete ${S}/script/nhc98
+
+ #install docs and man pages manually
+ dodoc README INSTALL COPYRIGHT
+ doman man/*
+
+ cd docs
+ dohtml -A hs -r *
+ docinto html/bugs
+ dodoc bugs/README
+}