summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2012-08-22 03:28:07 +0000
committerPatrick Lauer <patrick@gentoo.org>2012-08-22 03:28:07 +0000
commit87469e9b1194a7cbe46e5d38b8726e2eb272ec13 (patch)
treeaba71e60ef90215a04c67d315cfc5e4ff5790606 /dev-lang/niecza-bin/niecza-bin-20.ebuild
parentadded prefix keywords (diff)
downloadgentoo-2-87469e9b1194a7cbe46e5d38b8726e2eb272ec13.tar.gz
gentoo-2-87469e9b1194a7cbe46e5d38b8726e2eb272ec13.tar.bz2
gentoo-2-87469e9b1194a7cbe46e5d38b8726e2eb272ec13.zip
Initial import, ebuilds by me
(Portage version: 2.2.0_alpha121/cvs/Linux x86_64)
Diffstat (limited to 'dev-lang/niecza-bin/niecza-bin-20.ebuild')
-rw-r--r--dev-lang/niecza-bin/niecza-bin-20.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-lang/niecza-bin/niecza-bin-20.ebuild b/dev-lang/niecza-bin/niecza-bin-20.ebuild
new file mode 100644
index 000000000000..88d89e35f6f9
--- /dev/null
+++ b/dev-lang/niecza-bin/niecza-bin-20.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/niecza-bin/niecza-bin-20.ebuild,v 1.1 2012/08/22 03:28:07 patrick Exp $
+
+EAPI=4
+
+inherit eutils multilib
+
+DESCRIPTION="A Perl 6 compiler targetting the CLR with an experimental focus on optimizations."
+HOMEPAGE="https://github.com/sorear/niecza"
+
+MY_PN="niecza"
+MY_P="${MY_PN}-${PV}"
+SRC_URI="https://github.com/downloads/sorear/${MY_PN}/${MY_P}.zip"
+
+LICENSE="Artistic-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-lang/mono"
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}
+
+src_configure() { :; }
+
+src_compile() { :; }
+
+src_install() {
+ mkdir ${D}/opt/niecza-bin -p
+ cp -r ${WORKDIR}/* ${D}/opt/niecza-bin || die "Failed to copy"
+ einfo "The binary is installed to /opt/niecza-bin/run/Niecza.exe"
+}