summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2012-08-28 07:50:36 +0000
committerPatrick Lauer <patrick@gentoo.org>2012-08-28 07:50:36 +0000
commitc73f9795ca11f963a1c9469a5afe43e705a787e9 (patch)
treee88001e1951393f3db6c4a28d3655ad4a7b57a2c /dev-lang/niecza/niecza-21.ebuild
parentRespect CFLAGS #432204; Convert to EAPI=4 (diff)
downloadgentoo-2-c73f9795ca11f963a1c9469a5afe43e705a787e9.tar.gz
gentoo-2-c73f9795ca11f963a1c9469a5afe43e705a787e9.tar.bz2
gentoo-2-c73f9795ca11f963a1c9469a5afe43e705a787e9.zip
Bump
(Portage version: 2.2.0_alpha123/cvs/Linux x86_64)
Diffstat (limited to 'dev-lang/niecza/niecza-21.ebuild')
-rw-r--r--dev-lang/niecza/niecza-21.ebuild58
1 files changed, 58 insertions, 0 deletions
diff --git a/dev-lang/niecza/niecza-21.ebuild b/dev-lang/niecza/niecza-21.ebuild
new file mode 100644
index 000000000000..abd827e0e3de
--- /dev/null
+++ b/dev-lang/niecza/niecza-21.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/niecza/niecza-21.ebuild,v 1.1 2012/08/28 07:50:36 patrick Exp $
+
+EAPI=4
+
+inherit eutils multilib
+
+GITHUB_CRAP="sorear-niecza-50939fa"
+
+DESCRIPTION="A Perl 6 compiler targetting the CLR with an experimental focus on optimizations."
+HOMEPAGE="https://github.com/sorear/niecza"
+SRC_URI="https://github.com/sorear/niecza/zipball/v${PV} -> niecza-${PV}.zip"
+
+LICENSE="Artistic-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-lang/mono"
+DEPEND="${RDEPEND}
+ || ( dev-lang/niecza-bin dev-lang/niecza )"
+
+S=${WORKDIR}/${GITHUB_CRAP}
+
+src_prepare() {
+ epatch "${FILESDIR}"/fix-bootstrap-${PV}.patch || die "Failed to fix"
+ cd "${S}"
+ # bootstrap only works from git dirs? sigh :)
+ sed -i -e 's:@git describe --tags:echo "v${PV}":' Makefile
+ # silly workaround for stuff trying to write everywhere: copy the installed niecza here (sigh)
+ # since we have different installation paths for the bin version we need to check here
+ mkdir boot -p
+ if has_version dev-lang/niecza; then
+ cp -r /opt/niecza/* boot/
+ else
+ cp -r /opt/niecza-bin/* boot/
+ fi
+ mkdir -p boot/obj
+}
+
+src_configure() { :; }
+
+src_compile() {
+ export XDG_DATA_HOME="${S}"
+ emake -j1 || die
+}
+
+src_test() {
+ emake -j1 test || die
+}
+
+src_install() {
+ mkdir -p "${D}"/opt/niecza
+ for i in docs lib obj run README.pod; do
+ cp -r "${S}"/$i "${D}"/opt/niecza/ || die "Failed to install"
+ done
+}