summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2011-01-24 09:22:53 +0000
committerAlexis Ballier <aballier@gentoo.org>2011-01-24 09:22:53 +0000
commit108686b2de43d58b8b8eb736aed19c76e72f79dd (patch)
treeea5816f8486b25df39050d029f283edabdd79b71 /dev-lang/ocaml/files
parentremove old (diff)
downloadgentoo-2-108686b2de43d58b8b8eb736aed19c76e72f79dd.tar.gz
gentoo-2-108686b2de43d58b8b8eb736aed19c76e72f79dd.tar.bz2
gentoo-2-108686b2de43d58b8b8eb736aed19c76e72f79dd.zip
remove old
(Portage version: 2.2.0_alpha19/cvs/Linux x86_64)
Diffstat (limited to 'dev-lang/ocaml/files')
-rw-r--r--dev-lang/ocaml/files/ocaml-3.10.0-automagic.patch51
-rw-r--r--dev-lang/ocaml/files/ocaml-3.10.0-call-ld-with-proper-ldflags.patch30
-rw-r--r--dev-lang/ocaml/files/ocaml-3.10.0-configure.patch133
-rw-r--r--dev-lang/ocaml/files/ocaml-3.10.0-exec-stack-fixes.patch312
-rw-r--r--dev-lang/ocaml/files/ocaml-3.10.2-tk85.patch53
5 files changed, 0 insertions, 579 deletions
diff --git a/dev-lang/ocaml/files/ocaml-3.10.0-automagic.patch b/dev-lang/ocaml/files/ocaml-3.10.0-automagic.patch
deleted file mode 100644
index 0aa90973793a..000000000000
--- a/dev-lang/ocaml/files/ocaml-3.10.0-automagic.patch
+++ /dev/null
@@ -1,51 +0,0 @@
-Index: ocaml-3.10.0/configure
-===================================================================
---- ocaml-3.10.0.orig/configure
-+++ ocaml-3.10.0/configure
-@@ -31,6 +31,8 @@ x11_include_dir=''
- x11_lib_dir=''
- tk_wanted=yes
- pthread_wanted=yes
-+graph_wanted=yes
-+dbm_wanted=yes
- tk_defs=''
- tk_libs=''
- tk_x11=yes
-@@ -87,6 +89,10 @@ while : ; do
- ;; # Ignored for backward compatibility
- -no-pthread*|--no-pthread*)
- pthread_wanted=no;;
-+ -no-dbm|--no-dbm)
-+ dbm_wanted=no;;
-+ -no-graph|--no-graph)
-+ graph_wanted=no;;
- -no-tk|--no-tk)
- tk_wanted=no;;
- -tkdefs*|--tkdefs*)
-@@ -1233,7 +1239,7 @@ do
- done
-
-
--if test "$x11_include" = "not found" || test "$x11_link" = "not found"
-+if test "$x11_include" = "not found" || test "$x11_link" = "not found" || test "$graph_wanted" = "no"
- then
- echo "X11 not found, the \"graph\" library will not be supported."
- x11_include=""
-@@ -1281,7 +1287,7 @@ for dir in /usr/include /usr/include/db1
- break
- fi
- done
--if test "$dbm_include" = "not found" || test "$dbm_link" = "not found"; then
-+if test "$dbm_include" = "not found" || test "$dbm_link" = "not found" || test "$dbm_wanted" = "no"; then
- echo "NDBM not found, the \"dbm\" library will not be supported."
- else
- echo "NDBM found (in $dbm_include)"
-@@ -1546,7 +1552,7 @@ echo " $otherlibraries"
- echo "Configuration for the \"num\" library:"
- echo " target architecture ...... $bng_arch (asm level $bng_asm_level)"
-
--if test "$x11_include" != "not found" && test "$x11_lib" != "not found"; then
-+if test "$x11_include" != "not found" && test "$x11_lib" != "not found" && test "$graph_wanted" != "no"; then
- echo "Configuration for the \"graph\" library:"
- echo " options for compiling .... $x11_include"
- echo " options for linking ...... $x11_link"
diff --git a/dev-lang/ocaml/files/ocaml-3.10.0-call-ld-with-proper-ldflags.patch b/dev-lang/ocaml/files/ocaml-3.10.0-call-ld-with-proper-ldflags.patch
deleted file mode 100644
index 29d94aafb118..000000000000
--- a/dev-lang/ocaml/files/ocaml-3.10.0-call-ld-with-proper-ldflags.patch
+++ /dev/null
@@ -1,30 +0,0 @@
-As we now support LDFLAGS in NATIVECCLINKOPTS
-it can happen that -Wl,--foo,--bar option is in that variable
-As ocaml happens to call ld with NATIVECCLINKOPTS
-we have to "translate" it so that ld doesn't bail out with unrecognized option
-Initial patch from Julien Cristau : http://caml.inria.fr/mantis/view.php?id=4142
-Modified a bit to catch comma separated options
-Index: ocaml-3.10.0/Makefile
-===================================================================
---- ocaml-3.10.0.orig/Makefile
-+++ ocaml-3.10.0/Makefile
-@@ -316,6 +316,8 @@ partialclean::
- rm -f ocaml toplevel/toplevellib.cma
-
- # The configuration file
-+comma = ,
-+Wl = -Wl,
-
- utils/config.ml: utils/config.mlp config/Makefile
- @rm -f utils/config.ml
-@@ -326,8 +328,8 @@ utils/config.ml: utils/config.mlp config
- -e 's|%%BYTELINK%%|$(BYTECC) $(BYTECCLINKOPTS)|' \
- -e 's|%%NATIVECC%%|$(NATIVECC) $(NATIVECCCOMPOPTS)|' \
- -e 's|%%NATIVELINK%%|$(NATIVECC) $(NATIVECCLINKOPTS)|' \
-- -e 's|%%PARTIALLD%%|$(PARTIALLD) $(NATIVECCLINKOPTS)|' \
-- -e 's|%%PACKLD%%|$(PARTIALLD) $(NATIVECCLINKOPTS) -o |' \
-+ -e 's|%%PARTIALLD%%|$(PARTIALLD) $(subst $(comma), ,$(subst $(Wl),,$(NATIVECCLINKOPTS)))|' \
-+ -e 's|%%PACKLD%%|$(PARTIALLD) $(subst $(comma), ,$(subst $(Wl),,$(NATIVECCLINKOPTS))) -o |' \
- -e 's|%%BYTECCLIBS%%|$(BYTECCLIBS)|' \
- -e 's|%%NATIVECCLIBS%%|$(NATIVECCLIBS)|' \
- -e 's|%%RANLIBCMD%%|$(RANLIBCMD)|' \
diff --git a/dev-lang/ocaml/files/ocaml-3.10.0-configure.patch b/dev-lang/ocaml/files/ocaml-3.10.0-configure.patch
deleted file mode 100644
index d96d3f5beed1..000000000000
--- a/dev-lang/ocaml/files/ocaml-3.10.0-configure.patch
+++ /dev/null
@@ -1,133 +0,0 @@
-Index: ocaml-3.10.0/configure
-===================================================================
---- ocaml-3.10.0.orig/configure
-+++ ocaml-3.10.0/configure
-@@ -233,75 +233,75 @@ esac
- # Configure the bytecode compiler
-
- bytecc="$cc"
--bytecccompopts=""
--bytecclinkopts=""
-+bytecccompopts="${CFLAGS}"
-+bytecclinkopts="${LDFLAGS}"
- ostype="Unix"
- exe=""
-
- case "$bytecc,$host" in
- cc,*-*-nextstep*)
- # GNU C extensions disabled, but __GNUC__ still defined!
-- bytecccompopts="-fno-defer-pop $gcc_warnings -U__GNUC__ -posix"
-- bytecclinkopts="-posix";;
-+ bytecccompopts="$bytecccompopts -fno-defer-pop $gcc_warnings -U__GNUC__ -posix"
-+ bytecclinkopts="$bytecclinkopts -posix";;
- *,*-*-rhapsody*)
- # Almost the same as NeXTStep
-- bytecccompopts="-fno-defer-pop $gcc_warnings -DSHRINKED_GNUC"
-+ bytecccompopts="$bytecccompopts -fno-defer-pop $gcc_warnings -DSHRINKED_GNUC"
- mathlib="";;
- *,*-*-darwin*)
-- bytecccompopts="-fno-defer-pop -no-cpp-precomp $gcc_warnings"
-+ bytecccompopts="$bytecccompopts -fno-defer-pop -no-cpp-precomp $gcc_warnings"
- mathlib=""
- # Tell gcc that we can use 32-bit code addresses for threaded code
- # even if we compile in 64-bit mode
- echo "#define ARCH_CODE32" >> m.h;;
- *,*-*-beos*)
-- bytecccompopts="-fno-defer-pop $gcc_warnings"
-+ bytecccompopts="$bytecccompopts -fno-defer-pop $gcc_warnings"
- # No -lm library
- mathlib="";;
- gcc,alpha*-*-osf*)
-- bytecccompopts="-fno-defer-pop $gcc_warnings"
-+ bytecccompopts="$bytecccompopts -fno-defer-pop $gcc_warnings"
- if cc="$bytecc" sh ./hasgot -mieee; then
- bytecccompopts="-mieee $bytecccompopts";
- fi
- # Put code and static data in lower 4GB
-- bytecclinkopts="-Wl,-T,12000000 -Wl,-D,14000000"
-+ bytecclinkopts="$bytecclinkopts -Wl,-T,12000000 -Wl,-D,14000000"
- # Tell gcc that we can use 32-bit code addresses for threaded code
- echo "#define ARCH_CODE32" >> m.h;;
- cc,alpha*-*-osf*)
-- bytecccompopts="-std1 -ieee";;
-+ bytecccompopts="$bytecccompopts -std1 -ieee";;
- gcc,alpha*-*-linux*)
- if cc="$bytecc" sh ./hasgot -mieee; then
- bytecccompopts="-mieee $bytecccompopts";
- fi;;
- cc,mips-*-irix6*)
- # Add -n32 flag to ensure compatibility with native-code compiler
-- bytecccompopts="-n32"
-+ bytecccompopts="$bytecccompopts -n32"
- # Turn off warning "unused library"
-- bytecclinkopts="-n32 -Wl,-woff,84";;
-+ bytecclinkopts="$bytecclinkopts -n32 -Wl,-woff,84";;
- cc*,mips-*-irix6*)
- # (For those who want to force "cc -64")
- # Turn off warning "unused library"
-- bytecclinkopts="-Wl,-woff,84";;
-+ bytecclinkopts="$bytecclinkopts -Wl,-woff,84";;
- *,alpha*-*-unicos*)
- # For the Cray T3E
-- bytecccompopts="-DUMK";;
-+ bytecccompopts="$bytecccompopts -DUMK";;
- gcc*,powerpc-*-aix*)
- # Avoid name-space pollution by requiring Unix98-conformant includes
-- bytecccompopts="-fno-defer-pop $gcc_warnings -D_XOPEN_SOURCE=500";;
-+ bytecccompopts="$bytecccompopts -fno-defer-pop $gcc_warnings -D_XOPEN_SOURCE=500";;
- *,powerpc-*-aix*)
-- bytecccompopts="-D_XOPEN_SOURCE=500";;
-+ bytecccompopts="$bytecccompopts -D_XOPEN_SOURCE=500";;
- gcc*,*-*-cygwin*)
-- bytecccompopts="-fno-defer-pop $gcc_warnings -U_WIN32"
-+ bytecccompopts="$bytecccompopts -fno-defer-pop $gcc_warnings -U_WIN32"
- exe=".exe"
- ostype="Cygwin";;
- gcc*,x86_64-*-linux*)
-- bytecccompopts="-fno-defer-pop $gcc_warnings"
-+ bytecccompopts="$bytecccompopts -fno-defer-pop $gcc_warnings"
- # Tell gcc that we can use 32-bit code addresses for threaded code
- # unless we are compiled for a shared library (-fPIC option)
- echo "#ifndef __PIC__" >> m.h
- echo "# define ARCH_CODE32" >> m.h
- echo "#endif" >> m.h;;
- gcc*)
-- bytecccompopts="-fno-defer-pop $gcc_warnings";;
-+ bytecccompopts="$bytecccompopts -fno-defer-pop $gcc_warnings";;
- esac
-
- # Configure compiler to use in further tests
-@@ -616,22 +616,22 @@ else
- nativecc="$ccoption"
- fi
-
--nativecccompopts=''
--nativecclinkopts=''
-+nativecccompopts="${CFLAGS}"
-+nativecclinkopts="${LDFLAGS}"
- nativeccrpath="$byteccrpath"
-
- case "$arch,$nativecc,$system,$host_type" in
-- alpha,cc*,digital,*) nativecccompopts=-std1;;
-- mips,cc*,irix,*) nativecccompopts=-n32
-- nativecclinkopts="-n32 -Wl,-woff,84";;
-- *,*,nextstep,*) nativecccompopts="$gcc_warnings -U__GNUC__ -posix"
-- nativecclinkopts="-posix";;
-+ alpha,cc*,digital,*) nativecccompopts="$nativecccompopts -std1";;
-+ mips,cc*,irix,*) nativecccompopts="$nativecccompopts -n32"
-+ nativecclinkopts="$nativecclinkopts -n32 -Wl,-woff,84";;
-+ *,*,nextstep,*) nativecccompopts="$nativecccompopts $gcc_warnings -U__GNUC__ -posix"
-+ nativecclinkopts="$nativecclinkopts -posix";;
- *,*,rhapsody,*darwin[1-5].*)
-- nativecccompopts="$gcc_warnings -DSHRINKED_GNUC";;
-- *,*,rhapsody,*) nativecccompopts="$gcc_warnings -DDARWIN_VERSION_6 $dl_defs"
-+ nativecccompopts="$nativecccompopts $gcc_warnings -DSHRINKED_GNUC";;
-+ *,*,rhapsody,*) nativecccompopts="$nativecccompopts $gcc_warnings -DDARWIN_VERSION_6 $dl_defs"
- if $arch64; then partialld="ld -r -arch ppc64"; fi;;
-- *,gcc*,cygwin,*) nativecccompopts="$gcc_warnings -U_WIN32";;
-- *,gcc*,*,*) nativecccompopts="$gcc_warnings";;
-+ *,gcc*,cygwin,*) nativecccompopts="$nativecccompopts $gcc_warnings -U_WIN32";;
-+ *,gcc*,*,*) nativecccompopts="$nativecccompopts $gcc_warnings";;
- esac
-
- asflags=''
diff --git a/dev-lang/ocaml/files/ocaml-3.10.0-exec-stack-fixes.patch b/dev-lang/ocaml/files/ocaml-3.10.0-exec-stack-fixes.patch
deleted file mode 100644
index 123636098d3b..000000000000
--- a/dev-lang/ocaml/files/ocaml-3.10.0-exec-stack-fixes.patch
+++ /dev/null
@@ -1,312 +0,0 @@
-Index: ocaml-3.10.0/asmcomp/alpha/emit.mlp
-===================================================================
---- ocaml-3.10.0.orig/asmcomp/alpha/emit.mlp
-+++ ocaml-3.10.0/asmcomp/alpha/emit.mlp
-@@ -811,6 +811,11 @@ let data l =
- ` .data\n`;
- List.iter emit_item l
-
-+(* Mark stack as non executable *)
-+let nx_stack() =
-+ if Config.system = "linux" then
-+ ` .section .note.GNU-stack,\"\",%progbits\n`
-+
- (* Beginning / end of an assembly file *)
-
- let begin_assembly() =
-@@ -843,6 +848,7 @@ let begin_assembly() =
- `{emit_symbol lbl_begin}:\n`
-
- let end_assembly () =
-+ nx_stack();
- let lbl_end = Compilenv.make_symbol (Some "code_end") in
- ` .text\n`;
- ` .globl {emit_symbol lbl_end}\n`;
-Index: ocaml-3.10.0/asmrun/alpha.S
-===================================================================
---- ocaml-3.10.0.orig/asmrun/alpha.S
-+++ ocaml-3.10.0/asmrun/alpha.S
-@@ -438,3 +438,7 @@ caml_system__frametable:
- .word -1 /* negative frame size => use callback link */
- .word 0 /* no roots here */
- .align 3
-+
-+#ifdef __ELF__
-+.section .note.GNU-stack,"",%progbits
-+#endif
-Index: ocaml-3.10.0/asmrun/amd64.S
-===================================================================
---- ocaml-3.10.0.orig/asmrun/amd64.S
-+++ ocaml-3.10.0/asmrun/amd64.S
-@@ -366,3 +366,7 @@ caml_negf_mask:
- .align 16
- caml_absf_mask:
- .quad 0x7FFFFFFFFFFFFFFF, 0xFFFFFFFFFFFFFFFF
-+
-+#ifdef __ELF__
-+.section .note.GNU-stack,"",%progbits
-+#endif
-Index: ocaml-3.10.0/asmrun/arm.S
-===================================================================
---- ocaml-3.10.0.orig/asmrun/arm.S
-+++ ocaml-3.10.0/asmrun/arm.S
-@@ -337,3 +337,7 @@ caml_system__frametable:
- .short -1 /* negative frame size => use callback link */
- .short 0 /* no roots */
- .align 2
-+
-+#ifdef __ELF__
-+.section .note.GNU-stack,"",%progbits
-+#endif
-Index: ocaml-3.10.0/asmrun/hppa.S
-===================================================================
---- ocaml-3.10.0.orig/asmrun/hppa.S
-+++ ocaml-3.10.0/asmrun/hppa.S
-@@ -532,3 +532,8 @@ G(caml_system__frametable):
- .long L104 + 3 /* return address into callback */
- .short -1 /* negative frame size => use callback link */
- .short 0 /* no roots */
-+
-+#ifdef __ELF__
-+.section .note.GNU-stack,"",%progbits
-+#endif
-+
-Index: ocaml-3.10.0/asmrun/i386.S
-===================================================================
---- ocaml-3.10.0.orig/asmrun/i386.S
-+++ ocaml-3.10.0/asmrun/i386.S
-@@ -416,3 +416,8 @@ Lmcount$stub:
- hlt ; hlt ; hlt ; hlt ; hlt
- .subsections_via_symbols
- #endif
-+
-+#ifdef __ELF__
-+.section .note.GNU-stack,"",%progbits
-+#endif
-+
-Index: ocaml-3.10.0/asmrun/ia64.S
-===================================================================
---- ocaml-3.10.0.orig/asmrun/ia64.S
-+++ ocaml-3.10.0/asmrun/ia64.S
-@@ -528,3 +528,8 @@ caml_system__frametable:
-
- .common caml_saved_bsp#, 8, 8
- .common caml_saved_rnat#, 8, 8
-+
-+#ifdef __ELF__
-+.section .note.GNU-stack,"",%progbits
-+#endif
-+
-Index: ocaml-3.10.0/asmrun/m68k.S
-===================================================================
---- ocaml-3.10.0.orig/asmrun/m68k.S
-+++ ocaml-3.10.0/asmrun/m68k.S
-@@ -242,3 +242,8 @@ _caml_system__frametable:
- .long L107 | return address into callback
- .word -1 | negative frame size => use callback link
- .word 0 | no roots here
-+
-+#ifdef __ELF__
-+.section .note.GNU-stack,"",%progbits
-+#endif
-+
-Index: ocaml-3.10.0/asmrun/power-elf.S
-===================================================================
---- ocaml-3.10.0.orig/asmrun/power-elf.S
-+++ ocaml-3.10.0/asmrun/power-elf.S
-@@ -419,3 +419,7 @@ caml_system__frametable:
- .short -1 /* negative size count => use callback link */
- .short 0 /* no roots here */
-
-+#ifdef __ELF__
-+.section .note.GNU-stack,"",%progbits
-+#endif
-+
-Index: ocaml-3.10.0/asmrun/sparc.S
-===================================================================
---- ocaml-3.10.0.orig/asmrun/sparc.S
-+++ ocaml-3.10.0/asmrun/sparc.S
-@@ -405,3 +405,8 @@ Caml_system__frametable:
- .type Caml_raise_exception, #function
- .type Caml_system__frametable, #object
- #endif
-+
-+#ifdef __ELF__
-+.section .note.GNU-stack,"",%progbits
-+#endif
-+
-Index: ocaml-3.10.0/asmcomp/amd64/emit.mlp
-===================================================================
---- ocaml-3.10.0.orig/asmcomp/amd64/emit.mlp
-+++ ocaml-3.10.0/asmcomp/amd64/emit.mlp
-@@ -676,6 +676,13 @@ let data l =
- ` .data\n`;
- List.iter emit_item l
-
-+(* Mark stack as non executable *)
-+let nx_stack() =
-+ if Config.system = "linux" then
-+ ` .section .note.GNU-stack,\"\",%progbits\n`
-+
-+
-+
- (* Beginning / end of an assembly file *)
-
- let begin_assembly() =
-@@ -689,6 +696,7 @@ let begin_assembly() =
- `{emit_symbol lbl_begin}:\n`
-
- let end_assembly() =
-+ nx_stack();
- let lbl_end = Compilenv.make_symbol (Some "code_end") in
- ` .text\n`;
- ` .globl {emit_symbol lbl_end}\n`;
-Index: ocaml-3.10.0/asmcomp/arm/emit.mlp
-===================================================================
---- ocaml-3.10.0.orig/asmcomp/arm/emit.mlp
-+++ ocaml-3.10.0/asmcomp/arm/emit.mlp
-@@ -642,6 +642,13 @@ let data l =
- ` .data\n`;
- List.iter emit_item l
-
-+(* Mark stack as non executable *)
-+let nx_stack() =
-+ if Config.system = "linux" then
-+ ` .section .note.GNU-stack,\"\",%progbits\n`
-+
-+
-+
- (* Beginning / end of an assembly file *)
-
- let begin_assembly() =
-@@ -661,6 +668,7 @@ let begin_assembly() =
- `{emit_symbol lbl_begin}:\n`
-
- let end_assembly () =
-+ nx_stack();
- let lbl_end = Compilenv.make_symbol (Some "code_end") in
- ` .text\n`;
- ` .global {emit_symbol lbl_end}\n`;
-Index: ocaml-3.10.0/asmcomp/hppa/emit.mlp
-===================================================================
---- ocaml-3.10.0.orig/asmcomp/hppa/emit.mlp
-+++ ocaml-3.10.0/asmcomp/hppa/emit.mlp
-@@ -994,6 +994,12 @@ let data l =
- ` .data\n`;
- List.iter emit_item l
-
-+(* Mark stack as non executable *)
-+let nx_stack() =
-+ if Config.system = "linux" then
-+ ` .section .note.GNU-stack,\"\",%progbits\n`
-+
-+
- (* Beginning / end of an assembly file *)
-
- let begin_assembly() =
-@@ -1022,6 +1028,7 @@ let begin_assembly() =
-
-
- let end_assembly() =
-+ nx_stack();
- ` .code\n`;
- let lbl_end = Compilenv.make_symbol (Some "code_end") in
- declare_global lbl_end;
-Index: ocaml-3.10.0/asmcomp/i386/emit.mlp
-===================================================================
---- ocaml-3.10.0.orig/asmcomp/i386/emit.mlp
-+++ ocaml-3.10.0/asmcomp/i386/emit.mlp
-@@ -947,6 +947,11 @@ let data l =
- ` .data\n`;
- List.iter emit_item l
-
-+(* Mark stack as non executable *)
-+let nx_stack() =
-+ if Config.system = "linux_elf" then
-+ ` .section .note.GNU-stack,\"\",%progbits\n`
-+
- (* Beginning / end of an assembly file *)
-
- let begin_assembly() =
-@@ -960,6 +965,7 @@ let begin_assembly() =
- `{emit_symbol lbl_begin}:\n`
-
- let end_assembly() =
-+ nx_stack();
- let lbl_end = Compilenv.make_symbol (Some "code_end") in
- ` .text\n`;
- ` .globl {emit_symbol lbl_end}\n`;
-Index: ocaml-3.10.0/asmcomp/ia64/emit.mlp
-===================================================================
---- ocaml-3.10.0.orig/asmcomp/ia64/emit.mlp
-+++ ocaml-3.10.0/asmcomp/ia64/emit.mlp
-@@ -1306,6 +1306,11 @@ let data l =
- ` .align 8\n`;
- List.iter emit_item l
-
-+(* Mark stack as non executable *)
-+let nx_stack() =
-+ if Config.system = "linux" then
-+ ` .section .note.GNU-stack,\"\",%progbits\n`
-+
- (* Beginning / end of an assembly file *)
-
- let begin_assembly() =
-@@ -1315,6 +1320,7 @@ let begin_assembly() =
- emit_define_symbol (Compilenv.make_symbol (Some "code_begin"))
-
- let end_assembly () =
-+ nx_stack();
- ` .data\n`;
- emit_define_symbol (Compilenv.make_symbol (Some "data_end"));
- ` .text\n`;
-Index: ocaml-3.10.0/asmcomp/power/emit.mlp
-===================================================================
---- ocaml-3.10.0.orig/asmcomp/power/emit.mlp
-+++ ocaml-3.10.0/asmcomp/power/emit.mlp
-@@ -916,6 +916,12 @@ let data l =
- emit_string data_space;
- List.iter emit_item l
-
-+(* Mark stack as non executable *)
-+let nx_stack() =
-+ if Config.system = "elf" then
-+ ` .section .note.GNU-stack,\"\",%progbits\n`
-+
-+
- (* Beginning / end of an assembly file *)
-
- let begin_assembly() =
-@@ -932,6 +938,7 @@ let begin_assembly() =
- `{emit_symbol lbl_begin}:\n`
-
- let end_assembly() =
-+ nx_stack();
- if pic_externals then
- (* Emit the pointers to external functions *)
- StringSet.iter emit_external !external_functions;
-Index: ocaml-3.10.0/asmcomp/sparc/emit.mlp
-===================================================================
---- ocaml-3.10.0.orig/asmcomp/sparc/emit.mlp
-+++ ocaml-3.10.0/asmcomp/sparc/emit.mlp
-@@ -741,6 +741,12 @@ let data l =
- ` .data\n`;
- List.iter emit_item l
-
-+(* Mark stack as non executable *)
-+let nx_stack() =
-+ if Config.system = "linux" then
-+ ` .section .note.GNU-stack,\"\",%progbits\n`
-+
-+
- (* Beginning / end of an assembly file *)
-
- let begin_assembly() =
-@@ -754,6 +760,7 @@ let begin_assembly() =
- `{emit_symbol lbl_begin}:\n`
-
- let end_assembly() =
-+ nx_stack();
- ` .text\n`;
- let lbl_end = Compilenv.make_symbol (Some "code_end") in
- ` .global {emit_symbol lbl_end}\n`;
diff --git a/dev-lang/ocaml/files/ocaml-3.10.2-tk85.patch b/dev-lang/ocaml/files/ocaml-3.10.2-tk85.patch
deleted file mode 100644
index b612ef8eab36..000000000000
--- a/dev-lang/ocaml/files/ocaml-3.10.2-tk85.patch
+++ /dev/null
@@ -1,53 +0,0 @@
-Index: ocaml-3.10.2/configure
-===================================================================
---- ocaml-3.10.2.orig/configure
-+++ ocaml-3.10.2/configure
-@@ -1339,6 +1339,8 @@ if test $has_tk = true; then
- tcl_version=`sh ./runtest $tk_defs $tk_x11_include tclversion.c`
- for tk_incs in \
- "-I/usr/local/include" \
-+ "-I/usr/local/include/tcl8.5 -I/usr/local/include/tk8.5" \
-+ "-I/usr/include/tcl8.5 -I/usr/include/tk8.5" \
- "-I/usr/local/include/tcl8.4 -I/usr/local/include/tk8.4" \
- "-I/usr/include/tcl8.4 -I/usr/include/tk8.4" \
- "-I/usr/local/include/tcl8.3 -I/usr/local/include/tk8.3" \
-@@ -1361,6 +1363,7 @@ if test $has_tk = true; then
- 8.2) tclmaj=8 tclmin=2 tkmaj=8 tkmin=2 ;;
- 8.3) tclmaj=8 tclmin=3 tkmaj=8 tkmin=3 ;;
- 8.4) tclmaj=8 tclmin=4 tkmaj=8 tkmin=4 ;;
-+ 8.5) tclmaj=8 tclmin=5 tkmaj=8 tkmin=5 ;;
- *) echo "This version is not known."; has_tk=false ;;
- esac
- else
-Index: ocaml-3.10.2/otherlibs/labltk/support/cltkImg.c
-===================================================================
---- ocaml-3.10.2.orig/otherlibs/labltk/support/cltkImg.c
-+++ ocaml-3.10.2/otherlibs/labltk/support/cltkImg.c
-@@ -98,7 +98,11 @@ camltk_setimgdata_native (value imgname,
- pib.offset[0] = 0;
- pib.offset[1] = 1;
- pib.offset[2] = 2;
-+#if (TK_MAJOR_VERSION == 8 && TK_MINOR_VERSION >= 5 || TK_MAJOR_VERSION > 8)
-+ Tk_PhotoPutBlock(cltclinterp,ph,&pib,Int_val(x),Int_val(y),Int_val(w),Int_val(h)
-+#else
- Tk_PhotoPutBlock(ph,&pib,Int_val(x),Int_val(y),Int_val(w),Int_val(h)
-+#endif
- #if (TK_MAJOR_VERSION == 8 && TK_MINOR_VERSION >= 4 || TK_MAJOR_VERSION > 8)
- , TK_PHOTO_COMPOSITE_SET
- #endif
-Index: ocaml-3.10.2/otherlibs/labltk/tkanim/tkAnimGIF.c
-===================================================================
---- ocaml-3.10.2.orig/otherlibs/labltk/tkanim/tkAnimGIF.c
-+++ ocaml-3.10.2/otherlibs/labltk/tkanim/tkAnimGIF.c
-@@ -334,7 +334,11 @@ FileReadGIF(interp, f, fileName, formatS
- goto error;
- }
- }
-+#if (TK_MAJOR_VERSION == 8 && TK_MINOR_VERSION >= 5 || TK_MAJOR_VERSION > 8)
-+ Tk_PhotoPutBlock(interp, photoHandle, &block, 0, 0, imageWidth, imageHeight
-+#else
- Tk_PhotoPutBlock(photoHandle, &block, 0, 0, imageWidth, imageHeight
-+#endif
- #if (TK_MAJOR_VERSION == 8 && TK_MINOR_VERSION >= 4 || TK_MAJOR_VERSION > 8)
- , TK_PHOTO_COMPOSITE_SET
- #endif