summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2009-01-20 08:23:31 +0000
committerAlexis Ballier <aballier@gentoo.org>2009-01-20 08:23:31 +0000
commitdc0303d05ab8b27ade702245a1da17afd2e3005c (patch)
tree5e664e370c216b8eb5fc1abfb07b94f1fedcde35 /dev-lang/ocaml/ocaml-3.10.2.ebuild
parentFix (diff)
downloadgentoo-2-dc0303d05ab8b27ade702245a1da17afd2e3005c.tar.gz
gentoo-2-dc0303d05ab8b27ade702245a1da17afd2e3005c.tar.bz2
gentoo-2-dc0303d05ab8b27ade702245a1da17afd2e3005c.zip
Set LC_ALL to C because there are many a-z A-Z regexps that may cause build failures, bug #255379
(Portage version: 2.2_rc23/cvs/Linux x86_64)
Diffstat (limited to 'dev-lang/ocaml/ocaml-3.10.2.ebuild')
-rw-r--r--dev-lang/ocaml/ocaml-3.10.2.ebuild5
1 files changed, 3 insertions, 2 deletions
diff --git a/dev-lang/ocaml/ocaml-3.10.2.ebuild b/dev-lang/ocaml/ocaml-3.10.2.ebuild
index caa72dd09a84..e28ae5faedf0 100644
--- a/dev-lang/ocaml/ocaml-3.10.2.ebuild
+++ b/dev-lang/ocaml/ocaml-3.10.2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ocaml/ocaml-3.10.2.ebuild,v 1.10 2008/09/22 18:56:34 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ocaml/ocaml-3.10.2.ebuild,v 1.11 2009/01/20 08:23:31 aballier Exp $
inherit flag-o-matic eutils multilib versionator toolchain-funcs
@@ -62,6 +62,7 @@ src_unpack() {
}
src_compile() {
+ export LC_ALL=C
local myconf="--host ${CHOST}"
# dev-lang/ocaml tends to break/give unexpected results with "unsafe" CFLAGS.