summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2008-02-24 15:51:57 +0000
committerAlexis Ballier <aballier@gentoo.org>2008-02-24 15:51:57 +0000
commit67de5de2b3d5daca20d68ec864ae4a971c683f17 (patch)
tree39e88a5d4bc189ec241d3f6be9d53ff40be3d3bb /dev-lang/ocaml
parentold (diff)
downloadgentoo-2-67de5de2b3d5daca20d68ec864ae4a971c683f17.tar.gz
gentoo-2-67de5de2b3d5daca20d68ec864ae4a971c683f17.tar.bz2
gentoo-2-67de5de2b3d5daca20d68ec864ae4a971c683f17.zip
remove unused versions
(Portage version: 2.1.4.4)
Diffstat (limited to 'dev-lang/ocaml')
-rw-r--r--dev-lang/ocaml/ChangeLog6
-rw-r--r--dev-lang/ocaml/ocaml-3.09.2.ebuild89
-rw-r--r--dev-lang/ocaml/ocaml-3.09.3.ebuild93
-rw-r--r--dev-lang/ocaml/ocaml-3.10.0.ebuild130
4 files changed, 5 insertions, 313 deletions
diff --git a/dev-lang/ocaml/ChangeLog b/dev-lang/ocaml/ChangeLog
index 16669405512f..a6fcea9d2f43 100644
--- a/dev-lang/ocaml/ChangeLog
+++ b/dev-lang/ocaml/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-lang/ocaml
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ocaml/ChangeLog,v 1.134 2008/01/11 12:03:51 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ocaml/ChangeLog,v 1.135 2008/02/24 15:51:57 aballier Exp $
+
+ 24 Feb 2008; Alexis Ballier <aballier@gentoo.org> -ocaml-3.09.2.ebuild,
+ -ocaml-3.09.3.ebuild, -ocaml-3.10.0.ebuild:
+ remove unused versions
*ocaml-3.10.1 (11 Jan 2008)
diff --git a/dev-lang/ocaml/ocaml-3.09.2.ebuild b/dev-lang/ocaml/ocaml-3.09.2.ebuild
deleted file mode 100644
index d1ae8994084f..000000000000
--- a/dev-lang/ocaml/ocaml-3.09.2.ebuild
+++ /dev/null
@@ -1,89 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ocaml/ocaml-3.09.2.ebuild,v 1.15 2008/01/02 18:35:23 aballier Exp $
-
-inherit flag-o-matic eutils multilib
-
-DESCRIPTION="fast modern type-inferring functional programming language descended from the ML (Meta Language) family"
-HOMEPAGE="http://www.ocaml.org/"
-
-SRC_URI="http://caml.inria.fr/distrib/ocaml-3.09/${P}.tar.bz2"
-
-LICENSE="QPL-1.0 LGPL-2"
-SLOT="0"
-KEYWORDS="amd64 ppc ppc64 sparc x86"
-IUSE="tk latex"
-
-DEPEND="tk? ( >=dev-lang/tk-3.3.3 )"
-
-pkg_setup() {
- ewarn
- ewarn "Building ocaml with unsafe CFLAGS can have unexpected results"
- ewarn "Please retry building with safer CFLAGS before reporting bugs"
- ewarn "Likewise, building with a hardened gcc is not possible."
- ewarn
-}
-
-src_compile() {
- filter-flags "-fstack-protector"
- replace-flags "-O?" -O2
-
- local myconf
- use tk || myconf="-no-tk"
-
- # Fix for bug #46703
- export LC_ALL=C
-
- ./configure -prefix /usr \
- -bindir /usr/bin \
- -libdir /usr/$(get_libdir)/ocaml \
- -mandir /usr/share/man \
- --with-pthread ${myconf} || die
-
- sed -i -e "s/\(BYTECCCOMPOPTS=.*\)/\1 ${CFLAGS}/" config/Makefile
- sed -i -e "s/\(NATIVECCCOMPOPTS=.*\)/\1 ${CFLAGS}/" config/Makefile
-
- make world || die
- # Native code generation unsupported on some archs
- if ! use ppc64 ; then
- make opt || die
- make opt.opt || die
- fi
-}
-
-src_install() {
- make BINDIR="${D}/usr/bin" \
- LIBDIR="${D}/usr/$(get_libdir)/ocaml" \
- MANDIR="${D}/usr/share/man" \
- install || die
-
- # compiler libs
- dodir /usr/lib/ocaml/compiler-libs
- insinto /usr/lib/ocaml/compiler-libs
- doins {utils,typing,parsing}/*.{mli,cmi,cmo,cmx,o}
-
- # headers
- dodir /usr/include
- dosym /usr/lib/ocaml/caml /usr/include/
-
- # silly, silly makefiles
- dosed "s:${D}::g" /usr/$(get_libdir)/ocaml/ld.conf
-
- # documentation
- dodoc Changes INSTALL README Upgrading
-}
-
-pkg_postinst() {
- if use latex; then
- echo "TEXINPUTS=/usr/$(get_libdir)/ocaml/ocamldoc:" > /etc/env.d/99ocamldoc
- fi
-
- echo
- elog "OCaml is not binary compatible from version to version,"
- elog "so you (may) need to rebuild all packages depending on it that"
- elog "are actually installed on your system."
- elog "To do so, you can run: "
- elog "sh '${FILESDIR}/ocaml-rebuild.sh' [-h | emerge options]"
- elog "Which will call emerge on all old packages with the given options"
- echo
-}
diff --git a/dev-lang/ocaml/ocaml-3.09.3.ebuild b/dev-lang/ocaml/ocaml-3.09.3.ebuild
deleted file mode 100644
index d0356c2dacd1..000000000000
--- a/dev-lang/ocaml/ocaml-3.09.3.ebuild
+++ /dev/null
@@ -1,93 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ocaml/ocaml-3.09.3.ebuild,v 1.14 2008/01/02 18:35:23 aballier Exp $
-
-inherit flag-o-matic eutils multilib
-
-DESCRIPTION="fast modern type-inferring functional programming language descended from the ML (Meta Language) family"
-HOMEPAGE="http://www.ocaml.org/"
-
-SRC_URI="http://caml.inria.fr/distrib/ocaml-3.09/${P}.tar.bz2"
-
-LICENSE="QPL-1.0 LGPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ppc64 sparc x86 ~x86-fbsd"
-IUSE="tk latex"
-
-DEPEND="tk? ( >=dev-lang/tk-3.3.3 )"
-
-pkg_setup() {
- ewarn
- ewarn "Building ocaml with unsafe CFLAGS can have unexpected results"
- ewarn "Please retry building with safer CFLAGS before reporting bugs"
- ewarn "Likewise, building with a hardened gcc is not possible."
- ewarn
-}
-
-src_compile() {
- filter-flags "-fstack-protector"
- replace-flags "-O?" -O2
-
- local myconf
- use tk || myconf="-no-tk"
-
- # Fix for kernel_arch != system_ach (bug #135641)
- myconf="${myconf} -host ${CHOST}"
-
- # Fix for bug #46703
- export LC_ALL=C
-
- ./configure -prefix /usr \
- -bindir /usr/bin \
- -libdir /usr/$(get_libdir)/ocaml \
- -mandir /usr/share/man \
- --with-pthread ${myconf} || die
-
- sed -i -e "s/\(BYTECCCOMPOPTS=.*\)/\1 ${CFLAGS}/" config/Makefile
- sed -i -e "s/\(NATIVECCCOMPOPTS=.*\)/\1 ${CFLAGS}/" config/Makefile
-
- make world || die
-
- # Native code generation unsupported on some archs
- if ! use ppc64 ; then
- make opt || die
- make opt.opt || die
- fi
-}
-
-src_install() {
- make BINDIR="${D}/usr/bin" \
- LIBDIR="${D}/usr/$(get_libdir)/ocaml" \
- MANDIR="${D}/usr/share/man" \
- install || die
-
- # compiler libs
- dodir /usr/lib/ocaml/compiler-libs
- insinto /usr/lib/ocaml/compiler-libs
- doins {utils,typing,parsing}/*.{mli,cmi,cmo,cmx,o}
-
- # headers
- dodir /usr/include
- dosym /usr/lib/ocaml/caml /usr/include/
-
- # silly, silly makefiles
- dosed "s:${D}::g" /usr/$(get_libdir)/ocaml/ld.conf
-
- # documentation
- dodoc Changes INSTALL README Upgrading
-}
-
-pkg_postinst() {
- if use latex; then
- echo "TEXINPUTS=/usr/$(get_libdir)/ocaml/ocamldoc:" > /etc/env.d/99ocamldoc
- fi
-
- echo
- elog "OCaml is not binary compatible from version to version,"
- elog "so you (may) need to rebuild all packages depending on it that"
- elog "are actually installed on your system."
- elog "To do so, you can run: "
- elog "sh '${FILESDIR}/ocaml-rebuild.sh' [-h | emerge options]"
- elog "Which will call emerge on all old packages with the given options"
- echo
-}
diff --git a/dev-lang/ocaml/ocaml-3.10.0.ebuild b/dev-lang/ocaml/ocaml-3.10.0.ebuild
deleted file mode 100644
index df6259a967d3..000000000000
--- a/dev-lang/ocaml/ocaml-3.10.0.ebuild
+++ /dev/null
@@ -1,130 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ocaml/ocaml-3.10.0.ebuild,v 1.11 2008/01/03 18:04:24 aballier Exp $
-
-inherit flag-o-matic eutils multilib versionator toolchain-funcs
-
-EAPI="1"
-
-DESCRIPTION="fast modern type-inferring functional programming language descended from the ML (Meta Language) family"
-HOMEPAGE="http://www.ocaml.org/"
-SRC_URI="http://caml.inria.fr/distrib/ocaml-$( get_version_component_range 1-2)/${P}.tar.gz"
-
-LICENSE="QPL-1.0 LGPL-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
-IUSE="emacs gdbm latex ncurses +ocamlopt tk X xemacs"
-
-DEPEND="tk? ( >=dev-lang/tk-3.3.3 )
- ncurses? ( sys-libs/ncurses )
- X? ( x11-libs/libX11 x11-proto/xproto )
- gdbm? ( sys-libs/gdbm )"
-
-PDEPEND="emacs? ( app-emacs/ocaml-mode )
- xemacs? ( app-xemacs/ocaml )"
-
-pkg_setup() {
- # dev-lang/ocaml creates its own objects but calls gcc for linking, which will
- # results in relocations if gcc wants to create a PIE executable
- if gcc-specs-pie ; then
- append-ldflags -nopie
- ewarn "Ocaml generates its own native asm, you're using a PIE compiler"
- ewarn "We have appended -nopie to ocaml build options"
- ewarn "because linking an executable with pie while the objects are not pic will not work"
- fi
-}
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- # Fix the EXEC_STACK in ocaml compiled binaries (#153382)
- epatch "${FILESDIR}"/${P}-exec-stack-fixes.patch
-
- # The configure script doesn't inherit previous defined variables,
- # overwriting previous declarations of bytecccompopts, bytecclinkopts,
- # nativecccompopts and nativecclinkopts. Reported upstream as issue 0004267.
- epatch "${FILESDIR}"/${P}-configure.patch
-
- # ocaml has automagics on libX11 and gdbm
- # http://caml.inria.fr/mantis/view.php?id=4278
- epatch "${FILESDIR}/${P}-automagic.patch"
-
- # Call ld with proper flags, different from gcc ones
- # This happens when calling ocamlc -pack
- # See comment in the patch
- epatch "${FILESDIR}/${P}-call-ld-with-proper-ldflags.patch"
-
-}
-
-src_compile() {
- local myconf="--host ${CHOST}"
-
- # dev-lang/ocaml tends to break/give unexpected results with "unsafe" CFLAGS.
- strip-flags
- replace-flags "-O?" -O2
-
- # It doesn't compile on alpha without this LDFLAGS
- use alpha && append-ldflags "-Wl,--no-relax"
-
- use tk || myconf="${myconf} -no-tk"
- use ncurses || myconf="${myconf} -no-curses"
- use X || myconf="${myconf} -no-graph"
- use gdbm || myconf="${myconf} -no-dbm"
-
- # ocaml uses a home-brewn configure script, preventing it to use econf.
- ./configure -prefix /usr \
- --bindir /usr/bin \
- --libdir /usr/$(get_libdir)/ocaml \
- --mandir /usr/share/man \
- --with-pthread ${myconf} || die "configure failed!"
-
- make world || die "make world failed!"
-
- # Native code generation can be disabled now
- if use ocamlopt ; then
- make opt || die "make opt failed!"
- make opt.opt || die "make opt.opt failed!"
- fi
-}
-
-src_install() {
- make BINDIR="${D}"/usr/bin \
- LIBDIR="${D}"/usr/$(get_libdir)/ocaml \
- MANDIR="${D}"/usr/share/man \
- install || die "make install failed!"
-
- # Install the compiler libs
- dodir /usr/$(get_libdir)/ocaml/compiler-libs
- insinto /usr/$(get_libdir)/ocaml/compiler-libs
- doins {utils,typing,parsing}/*.{mli,cmi,cmo,cmx,o}
-
- # Symlink the headers to the right place
- dodir /usr/include
- dosym /usr/$(get_libdir)/ocaml/caml /usr/include/
-
- # Remove ${D} from ld.conf, as the buildsystem isn't $(DESTDIR) aware
- dosed "s:${D}::g" /usr/$(get_libdir)/ocaml/ld.conf
-
- dodoc Changes INSTALL README Upgrading
-
- # Create and envd entry for latex input files (this definitely belongs into
- # CONTENT and not in pkg_postinst.
- if use latex ; then
- echo "TEXINPUTS=/usr/$(get_libdir)/ocaml/ocamldoc:" > "${T}"/99ocamldoc
- doenvd "${T}"/99ocamldoc
- fi
-
- # Install ocaml-rebuild.sh script rather than keeping it in $PORTDIR
- dosbin "${FILESDIR}/ocaml-rebuild.sh"
-}
-
-pkg_postinst() {
- echo
- ewarn "OCaml is not binary compatible from version to version, so you"
- ewarn "need to rebuild all packages depending on it, that are actually"
- ewarn "installed on your system. To do so, you can run:"
- ewarn "/usr/sbin/ocaml-rebuild.sh [-h | emerge options]"
- ewarn "Which will call emerge on all old packages with the given options"
- echo
-}