summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2008-11-27 07:35:33 +0000
committerAlexis Ballier <aballier@gentoo.org>2008-11-27 07:35:33 +0000
commit8650ae611d14d592b57033b079b4449c47e873c0 (patch)
treee5f37c153770b2b90d0ea6f1a991a7f6b74c50da /dev-lang/ocaml
parentVersion bump for Rails 2.2.2 (diff)
downloadgentoo-2-8650ae611d14d592b57033b079b4449c47e873c0.tar.gz
gentoo-2-8650ae611d14d592b57033b079b4449c47e873c0.tar.bz2
gentoo-2-8650ae611d14d592b57033b079b4449c47e873c0.zip
Dont try to install native code compiler libs when not building native code, reported by Jeroen Roovers <jer@gentoo.org> in bug #248929
(Portage version: 2.2_rc16/cvs/Linux 2.6.27.5 x86_64)
Diffstat (limited to 'dev-lang/ocaml')
-rw-r--r--dev-lang/ocaml/ChangeLog6
-rw-r--r--dev-lang/ocaml/ocaml-3.11.0_rc1.ebuild5
2 files changed, 8 insertions, 3 deletions
diff --git a/dev-lang/ocaml/ChangeLog b/dev-lang/ocaml/ChangeLog
index 7a2107c1ffbf..efc7f653a383 100644
--- a/dev-lang/ocaml/ChangeLog
+++ b/dev-lang/ocaml/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-lang/ocaml
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ocaml/ChangeLog,v 1.154 2008/11/25 19:12:36 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ocaml/ChangeLog,v 1.155 2008/11/27 07:35:33 aballier Exp $
+
+ 27 Nov 2008; Alexis Ballier <aballier@gentoo.org> ocaml-3.11.0_rc1.ebuild:
+ Dont try to install native code compiler libs when not building native
+ code, reported by Jeroen Roovers <jer@gentoo.org> in bug #248929
*ocaml-3.11.0_rc1 (25 Nov 2008)
diff --git a/dev-lang/ocaml/ocaml-3.11.0_rc1.ebuild b/dev-lang/ocaml/ocaml-3.11.0_rc1.ebuild
index 7c79e8393e5c..96ed313ba9b5 100644
--- a/dev-lang/ocaml/ocaml-3.11.0_rc1.ebuild
+++ b/dev-lang/ocaml/ocaml-3.11.0_rc1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ocaml/ocaml-3.11.0_rc1.ebuild,v 1.1 2008/11/25 19:12:36 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ocaml/ocaml-3.11.0_rc1.ebuild,v 1.2 2008/11/27 07:35:33 aballier Exp $
inherit flag-o-matic eutils multilib versionator toolchain-funcs
@@ -92,7 +92,8 @@ src_install() {
# Install the compiler libs
dodir /usr/$(get_libdir)/ocaml/compiler-libs
insinto /usr/$(get_libdir)/ocaml/compiler-libs
- doins {utils,typing,parsing}/*.{mli,cmi,cmo,cmx,o}
+ doins {utils,typing,parsing}/*.{mli,cmi,cmo}
+ use ocamlopt && doins {utils,typing,parsing}/*.{cmx,o}
# Symlink the headers to the right place
dodir /usr/include