summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorge Shapovalov <george@gentoo.org>2002-08-07 07:13:43 +0000
committerGeorge Shapovalov <george@gentoo.org>2002-08-07 07:13:43 +0000
commita2f2a292879440ffbea196416e52939b2b42ae91 (patch)
treea0e16b27c55d3d4991696919e32e8c6c20018133 /dev-lang/ocaml
parentmasked new version of ocaml for testing (diff)
downloadgentoo-2-a2f2a292879440ffbea196416e52939b2b42ae91.tar.gz
gentoo-2-a2f2a292879440ffbea196416e52939b2b42ae91.tar.bz2
gentoo-2-a2f2a292879440ffbea196416e52939b2b42ae91.zip
new version of ocaml, should fix some ppc problems
Diffstat (limited to 'dev-lang/ocaml')
-rw-r--r--dev-lang/ocaml/files/digest-ocaml-3.051
-rw-r--r--dev-lang/ocaml/ocaml-3.05.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/dev-lang/ocaml/files/digest-ocaml-3.05 b/dev-lang/ocaml/files/digest-ocaml-3.05
new file mode 100644
index 000000000000..b6b06953ea52
--- /dev/null
+++ b/dev-lang/ocaml/files/digest-ocaml-3.05
@@ -0,0 +1 @@
+MD5 20afd1cd0e958968b463e69c2f120493 ocaml-3.05.tar.gz 2433950
diff --git a/dev-lang/ocaml/ocaml-3.05.ebuild b/dev-lang/ocaml/ocaml-3.05.ebuild
new file mode 100644
index 000000000000..b1c076ea2fcd
--- /dev/null
+++ b/dev-lang/ocaml/ocaml-3.05.ebuild
@@ -0,0 +1,53 @@
+# Copyright 20022 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ocaml/ocaml-3.05.ebuild,v 1.1 2002/08/07 07:13:42 george Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Objective Caml is a fast modern type-inferring functional programming language descended from the ML (Meta Language) family."
+SRC_URI="ftp://ftp.inria.fr/lang/caml-light/${P}.tar.gz"
+HOMEPAGE="http://www.ocaml.org/"
+
+DEPEND="virtual/glibc
+ tcltk? ( >=dev-lang/tk-3.3.3 )"
+RDEPEND="${DEPEND}"
+
+SLOT="0"
+LICENSE="QPL-1.0 LGPL-2"
+KEYWORDS="x86"
+
+src_compile()
+{
+ local myconf
+ use tcltk || myconf="-no-tk"
+
+ ./configure -prefix /usr \
+ -bindir /usr/bin \
+ -libdir /usr/lib/ocaml \
+ -mandir /usr/share/man \
+ --with-pthread ${myconf} || die
+
+ make world || die
+ make opt || die
+ make opt.opt || die
+}
+
+src_install ()
+{
+ make BINDIR=${D}/usr/bin \
+ LIBDIR=${D}/usr/lib/ocaml \
+ MANDIR=${D}/usr/share/man \
+ install || die
+
+ # silly, silly makefiles
+ dosed "s:${D}::g" /usr/lib/ocaml/ld.conf
+
+ dodir /etc/env.d
+ echo LDPATH=/usr/lib/ocaml:/usr/lib/ocaml/labltk \
+ > ${D}/etc/env.d/30ocaml
+ dodoc Changes INSTALL LICENSE README Upgrading
+
+}
+
+
+
+