summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAron Griffis <agriffis@gentoo.org>2004-06-07 20:34:54 +0000
committerAron Griffis <agriffis@gentoo.org>2004-06-07 20:34:54 +0000
commit2d56a810ed953be1371f73fab7960ee45abfaaea (patch)
treed47f0672a60a1ec7b66b64946c7e7a64e7d163f9 /dev-lang/palmos-sdk/palmos-sdk-4.0.ebuild
parentUpdated to fix font burriness. (Manifest recommit) (diff)
downloadgentoo-2-2d56a810ed953be1371f73fab7960ee45abfaaea.tar.gz
gentoo-2-2d56a810ed953be1371f73fab7960ee45abfaaea.tar.bz2
gentoo-2-2d56a810ed953be1371f73fab7960ee45abfaaea.zip
Overhauled these ebuilds to use RESTRICT=fetch so that digests can be generated properly
Diffstat (limited to 'dev-lang/palmos-sdk/palmos-sdk-4.0.ebuild')
-rw-r--r--dev-lang/palmos-sdk/palmos-sdk-4.0.ebuild78
1 files changed, 32 insertions, 46 deletions
diff --git a/dev-lang/palmos-sdk/palmos-sdk-4.0.ebuild b/dev-lang/palmos-sdk/palmos-sdk-4.0.ebuild
index 82a189e7dcbe..6cebc73c63b5 100644
--- a/dev-lang/palmos-sdk/palmos-sdk-4.0.ebuild
+++ b/dev-lang/palmos-sdk/palmos-sdk-4.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/palmos-sdk/palmos-sdk-4.0.ebuild,v 1.3 2004/06/01 11:17:06 plasmaroo Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/palmos-sdk/palmos-sdk-4.0.ebuild,v 1.4 2004/06/07 20:34:54 agriffis Exp $
inherit rpm
@@ -11,64 +11,50 @@ LICENSE="Palm-SDK"
SLOT="4.0"
KEYWORDS="~x86"
DEPEND="dev-lang/prc-tools"
-
-A1="sdk40.tar.gz"
-A2="sdk40upd1.tar.gz"
-AD1="sdk40-docs.zip"
-AD2="sdk40-examples.tar.gz"
-AX="${A1} ${A2}"
-
+# Note: There is an sdk40-docs.tar.gz but it's actually a zip file, so
+# might as well just get the zip file.
+SRC_URI="sdk40.tar.gz sdk40upd1.tar.gz
+ doc? ( sdk40-docs.zip sdk40-examples.tar.gz )"
IUSE="doc"
-BASE="/opt/palmdev/sdk-${SLOT}"
-RESTRICT="nostrip"
+RESTRICT="nostrip fetch"
S=${WORKDIR}
-pkg_setup() {
-
- if ! ( [ -f ${DISTDIR}/${A1} ] && [ -f ${DISTDIR}/${A2} ] ); then
- echo
- eerror "Please go to http://www.palmos.com/cgi-bin/sdk40.cgi"; \
- eerror "and download ${A1} and ${A2} and place them"; \
- eerror "in ${DISTDIR} and emerge this package again."
- die
- fi
-
- if ( ( [ ! -f ${DISTDIR}/${AD1} ] || [ ! -f ${DISTDIR}/${AD2} ] ) && [ `use doc` ] ); then
- echo
- eerror "Please go to http://www.palmos.com/cgi-bin/sdk40.cgi"
- eerror "and download ${AD1} and ${AD2} and place them in"
- eerror "${DISTDIR} and emerge this package again or disable the \`doc'"
- eerror "USE flag."
- die
- fi
+pkg_nofetch() {
+ typeset a
+ einfo "Please download the following files from"
+ einfo "http://www.palmos.com/cgi-bin/sdk40.cgi"
+ einfo "and put them in ${DISTDIR}, then emerge this package again."
+ for a in ${A}; do
+ einfo " ${a}"
+ done
}
src_unpack() {
-
- unpack ${AX}
+ unpack ${A}
rpm_unpack *.rpm
- rm *.rpm
-
- if use doc; then
- unpack ${AD1}
- unpack ${AD2}
- fi
-
}
src_install() {
+ typeset base=/opt/palmdev/sdk-${SLOT}
- dodir ${BASE}
- cp -Rf PalmOS-4.0-SDK-Update-1/PalmOS-Unix/PalmOS-Support/* opt/palmdev/sdk-4
- cp -Rf PalmOS-4.0-SDK-Update-1/PalmOS-Unix/Documentation/* opt/palmdev/sdk-4
- cp -PRf opt/palmdev/sdk-4/* ${D}/opt/palmdev/sdk-${SLOT}
- mv Documentation ${D}/opt/palmdev/sdk-${SLOT}
- mv Examples ${D}/opt/palmdev/sdk-${SLOT}/Documentation
+ # Copy the updates over top of the existing files
+ cp -Rf PalmOS-4.0-SDK-Update-1/PalmOS-Unix/PalmOS-Support/* \
+ opt/palmdev/sdk-4 || die
+ if use doc; then
+ cp -Rf PalmOS-4.0-SDK-Update-1/PalmOS-Unix/Documentation/* \
+ Documentation || die
+ fi
+ # Now install
+ dodir ${base%/*} || die
+ mv opt/palmdev/sdk-4 ${D}${base} || die
+ if use doc; then
+ mv Documentation ${D}${base} || die
+ mv Examples ${D}${base}/Documentation || die
+ fi
}
-pkg_postinst()
-{
- palmdev-prep || eerror "Could not run \`palmdev-prep'!"
+pkg_postinst() {
+ palmdev-prep || eerror "Error running palmdev-prep :-("
}