summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2012-03-08 04:18:42 +0000
committerPatrick Lauer <patrick@gentoo.org>2012-03-08 04:18:42 +0000
commitb4d0b0434ff2e833903a63f762cc8f617e66a386 (patch)
treee61ccc5e35a5e60396b76797e6c167a1316e7ae4 /dev-lang/parrot
parentRevbump to add dependency on paramiko for scp/sftp (bug #407265). (diff)
downloadgentoo-2-b4d0b0434ff2e833903a63f762cc8f617e66a386.tar.gz
gentoo-2-b4d0b0434ff2e833903a63f762cc8f617e66a386.tar.bz2
gentoo-2-b4d0b0434ff2e833903a63f762cc8f617e66a386.zip
Bump, remove old, partial fix for #404195
(Portage version: 2.2.0_alpha90/cvs/Linux x86_64)
Diffstat (limited to 'dev-lang/parrot')
-rw-r--r--dev-lang/parrot/ChangeLog9
-rw-r--r--dev-lang/parrot/parrot-2.11.0.ebuild79
-rw-r--r--dev-lang/parrot/parrot-3.3.0.ebuild80
-rw-r--r--dev-lang/parrot/parrot-3.6.0.ebuild84
-rw-r--r--dev-lang/parrot/parrot-3.9.0.ebuild79
-rw-r--r--dev-lang/parrot/parrot-4.1.0.ebuild (renamed from dev-lang/parrot/parrot-3.11.0-r1.ebuild)14
6 files changed, 18 insertions, 327 deletions
diff --git a/dev-lang/parrot/ChangeLog b/dev-lang/parrot/ChangeLog
index 4669f34f0fba..312d57fbf2ff 100644
--- a/dev-lang/parrot/ChangeLog
+++ b/dev-lang/parrot/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-lang/parrot
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/parrot/ChangeLog,v 1.50 2012/02/16 06:44:06 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/parrot/ChangeLog,v 1.51 2012/03/08 04:18:42 patrick Exp $
+
+*parrot-4.1.0 (08 Mar 2012)
+
+ 08 Mar 2012; Patrick Lauer <patrick@gentoo.org> +parrot-4.1.0.ebuild,
+ -parrot-2.11.0.ebuild, -parrot-3.11.0-r1.ebuild, -parrot-3.3.0.ebuild,
+ -parrot-3.6.0.ebuild, -parrot-3.9.0.ebuild:
+ Bump, remove old, partial fix for #404195
*parrot-4.0.0 (16 Feb 2012)
diff --git a/dev-lang/parrot/parrot-2.11.0.ebuild b/dev-lang/parrot/parrot-2.11.0.ebuild
deleted file mode 100644
index ed853edc4a38..000000000000
--- a/dev-lang/parrot/parrot-2.11.0.ebuild
+++ /dev/null
@@ -1,79 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/parrot/parrot-2.11.0.ebuild,v 1.3 2011/03/26 09:39:08 grobian Exp $
-
-EAPI=3
-
-inherit eutils multilib
-
-DESCRIPTION="Virtual machine designed to efficiently compile and execute bytecode for dynamic languages"
-HOMEPAGE="http://www.parrot.org/"
-SRC_URI="ftp://ftp.parrot.org/pub/parrot/releases/devel/${PV}/${P}.tar.bz2"
-
-LICENSE="Artistic-2"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
-IUSE="opengl nls doc examples gdbm gmp ssl +unicode pcre"
-
-RDEPEND="sys-libs/readline
- opengl? ( media-libs/freeglut )
- nls? ( sys-devel/gettext )
- unicode? ( >=dev-libs/icu-2.6 )
- gdbm? ( >=sys-libs/gdbm-1.8.3-r1 )
- gmp? ( >=dev-libs/gmp-4.1.4 )
- ssl? ( dev-libs/openssl )
- pcre? ( dev-libs/libpcre )"
-
-DEPEND="dev-lang/perl[doc?]
- ${RDEPEND}"
-
-src_configure() {
- myconf="--disable-rpath"
- use unicode || myconf+=" --without-icu"
- use ssl || myconf+=" --without-crypto"
- use gdbm || myconf+=" --without-gdbm"
- use nls || myconf+=" --without-gettext"
- use gmp || myconf+=" --without-gmp"
- use opengl || myconf+=" --without-opengl"
- use pcre || myconf+=" --without-pcre"
-
- perl Configure.pl \
- --ccflags="${CFLAGS}" \
- --linkflags="${LDFLAGS}" \
- --prefix="${EPREFIX}"/usr \
- --libdir="${EPREFIX}"/usr/$(get_libdir) \
- --mandir="${EPREFIX}"/usr/share/man \
- --sysconfdir="${EPREFIX}"/etc \
- --sharedstatedir="${EPREFIX}"/var/lib/parrot \
- --pkgconfigdir=pkgconfig \
- $myconf || die
-}
-
-src_compile() {
- export LD_LIBRARY_PATH=${LD_LIBRARY_PATH:+$LD_LIBRARY_PATH:}"${S}"/blib/lib
- # occasionally dies in parallel make
- emake -j1 || die
- if use doc ; then
- emake -j1 html || die
- fi
-}
-
-src_test() {
- emake -j1 test || die
-}
-
-src_install() {
- emake -j1 install-dev DESTDIR="${D}" DOC_DIR="${EPREFIX}/usr/share/doc/${PF}" || die
- dodoc CREDITS DEPRECATED.pod DONORS.pod NEWS PBC_COMPAT PLATFORMS RESPONSIBLE_PARTIES TODO || die
- if use examples; then
- insinto "/usr/share/doc/${PF}/examples"
- doins -r examples/* || die
- fi
- if use doc; then
- insinto "/usr/share/doc/${PF}/editor"
- doins -r editor || die
- cd docs/html
- dohtml -r developer.html DONORS.pod.html index.html ops.html parrotbug.html pdds.html \
- pmc.html tools.html docs src tools || die
- fi
-}
diff --git a/dev-lang/parrot/parrot-3.3.0.ebuild b/dev-lang/parrot/parrot-3.3.0.ebuild
deleted file mode 100644
index 2578d35728e8..000000000000
--- a/dev-lang/parrot/parrot-3.3.0.ebuild
+++ /dev/null
@@ -1,80 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/parrot/parrot-3.3.0.ebuild,v 1.1 2011/05/05 14:00:26 patrick Exp $
-
-EAPI=3
-
-inherit eutils multilib
-
-DESCRIPTION="Virtual machine designed to efficiently compile and execute bytecode for dynamic languages"
-HOMEPAGE="http://www.parrot.org/"
-#SRC_URI="ftp://ftp.parrot.org/pub/parrot/releases/supported/${PV}/${P}.tar.bz2"
-SRC_URI="ftp://ftp.parrot.org/pub/parrot/releases/stable/${PV}/${P}.tar.bz2"
-
-LICENSE="Artistic-2"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
-IUSE="opengl nls doc examples gdbm gmp ssl +unicode pcre"
-
-RDEPEND="sys-libs/readline
- opengl? ( media-libs/freeglut )
- nls? ( sys-devel/gettext )
- unicode? ( >=dev-libs/icu-2.6 )
- gdbm? ( >=sys-libs/gdbm-1.8.3-r1 )
- gmp? ( >=dev-libs/gmp-4.1.4 )
- ssl? ( dev-libs/openssl )
- pcre? ( dev-libs/libpcre )"
-
-DEPEND="dev-lang/perl[doc?]
- ${RDEPEND}"
-
-src_configure() {
- myconf="--disable-rpath"
- use unicode || myconf+=" --without-icu"
- use ssl || myconf+=" --without-crypto"
- use gdbm || myconf+=" --without-gdbm"
- use nls || myconf+=" --without-gettext"
- use gmp || myconf+=" --without-gmp"
- use opengl || myconf+=" --without-opengl"
- use pcre || myconf+=" --without-pcre"
-
- perl Configure.pl \
- --ccflags="${CFLAGS}" \
- --linkflags="${LDFLAGS}" \
- --prefix="${EPREFIX}"/usr \
- --libdir="${EPREFIX}"/usr/$(get_libdir) \
- --mandir="${EPREFIX}"/usr/share/man \
- --sysconfdir="${EPREFIX}"/etc \
- --sharedstatedir="${EPREFIX}"/var/lib/parrot \
- --pkgconfigdir=pkgconfig \
- $myconf || die
-}
-
-src_compile() {
- export LD_LIBRARY_PATH=${LD_LIBRARY_PATH:+$LD_LIBRARY_PATH:}"${S}"/blib/lib
- # occasionally dies in parallel make
- emake -j1 || die
- if use doc ; then
- emake -j1 html || die
- fi
-}
-
-src_test() {
- emake -j1 test || die
-}
-
-src_install() {
- emake -j1 install-dev DESTDIR="${D}" DOC_DIR="${EPREFIX}/usr/share/doc/${PF}" || die
- dodoc CREDITS DONORS.pod NEWS PBC_COMPAT PLATFORMS RESPONSIBLE_PARTIES TODO || die
- if use examples; then
- insinto "/usr/share/doc/${PF}/examples"
- doins -r examples/* || die
- fi
- if use doc; then
- insinto "/usr/share/doc/${PF}/editor"
- doins -r editor || die
- cd docs/html
- dohtml -r developer.html DONORS.pod.html index.html ops.html parrotbug.html pdds.html \
- pmc.html tools.html docs src tools || die
- fi
-}
diff --git a/dev-lang/parrot/parrot-3.6.0.ebuild b/dev-lang/parrot/parrot-3.6.0.ebuild
deleted file mode 100644
index 1bb6f2dd30f7..000000000000
--- a/dev-lang/parrot/parrot-3.6.0.ebuild
+++ /dev/null
@@ -1,84 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/parrot/parrot-3.6.0.ebuild,v 1.2 2011/08/29 17:32:25 grobian Exp $
-
-EAPI=3
-
-inherit eutils multilib
-
-DESCRIPTION="Virtual machine designed to efficiently compile and execute bytecode for dynamic languages"
-HOMEPAGE="http://www.parrot.org/"
-#SRC_URI="ftp://ftp.parrot.org/pub/parrot/releases/supported/${PV}/${P}.tar.bz2"
-SRC_URI="ftp://ftp.parrot.org/pub/parrot/releases/stable/${PV}/${P}.tar.bz2"
-
-LICENSE="Artistic-2"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
-IUSE="opengl nls doc examples gdbm gmp ssl +unicode pcre"
-
-RDEPEND="sys-libs/readline
- opengl? ( media-libs/freeglut )
- nls? ( sys-devel/gettext )
- unicode? ( >=dev-libs/icu-2.6 )
- gdbm? ( >=sys-libs/gdbm-1.8.3-r1 )
- gmp? ( >=dev-libs/gmp-4.1.4 )
- ssl? ( dev-libs/openssl )
- pcre? ( dev-libs/libpcre )"
-
-DEPEND="dev-lang/perl[doc?]
- ${RDEPEND}"
-
-src_prepare() {
- # skip fink and macports detection, Gentoo Prefix is much better
- sed -i -e '/_probe_for_libraries(/d' config/init/hints/darwin.pm || die
-}
-
-src_configure() {
- myconf="--disable-rpath"
- use unicode || myconf+=" --without-icu"
- use ssl || myconf+=" --without-crypto"
- use gdbm || myconf+=" --without-gdbm"
- use nls || myconf+=" --without-gettext"
- use gmp || myconf+=" --without-gmp"
- use opengl || myconf+=" --without-opengl"
- use pcre || myconf+=" --without-pcre"
-
- perl Configure.pl \
- --ccflags="${CFLAGS}" \
- --linkflags="${LDFLAGS}" \
- --prefix="${EPREFIX}"/usr \
- --libdir="${EPREFIX}"/usr/$(get_libdir) \
- --mandir="${EPREFIX}"/usr/share/man \
- --sysconfdir="${EPREFIX}"/etc \
- --sharedstatedir="${EPREFIX}"/var/lib/parrot \
- $myconf || die
-}
-
-src_compile() {
- export LD_LIBRARY_PATH=${LD_LIBRARY_PATH:+$LD_LIBRARY_PATH:}"${S}"/blib/lib
- # occasionally dies in parallel make
- emake -j1 || die
- if use doc ; then
- emake -j1 html || die
- fi
-}
-
-src_test() {
- emake -j1 test || die
-}
-
-src_install() {
- emake -j1 install-dev DESTDIR="${D}" DOC_DIR="${EPREFIX}/usr/share/doc/${PF}" || die
- dodoc CREDITS DONORS.pod NEWS PBC_COMPAT PLATFORMS RESPONSIBLE_PARTIES TODO || die
- if use examples; then
- insinto "/usr/share/doc/${PF}/examples"
- doins -r examples/* || die
- fi
- if use doc; then
- insinto "/usr/share/doc/${PF}/editor"
- doins -r editor || die
- cd docs/html
- dohtml -r developer.html DONORS.pod.html index.html ops.html parrotbug.html pdds.html \
- pmc.html tools.html docs src tools || die
- fi
-}
diff --git a/dev-lang/parrot/parrot-3.9.0.ebuild b/dev-lang/parrot/parrot-3.9.0.ebuild
deleted file mode 100644
index d9eab6767850..000000000000
--- a/dev-lang/parrot/parrot-3.9.0.ebuild
+++ /dev/null
@@ -1,79 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/parrot/parrot-3.9.0.ebuild,v 1.1 2011/10/22 18:34:28 patrick Exp $
-
-EAPI=3
-
-inherit eutils multilib
-
-DESCRIPTION="Virtual machine designed to efficiently compile and execute bytecode for dynamic languages"
-HOMEPAGE="http://www.parrot.org/"
-#SRC_URI="ftp://ftp.parrot.org/pub/parrot/releases/supported/${PV}/${P}.tar.bz2"
-SRC_URI="ftp://ftp.parrot.org/pub/parrot/releases/stable/${PV}/${P}.tar.bz2"
-
-LICENSE="Artistic-2"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
-IUSE="opengl nls doc examples gdbm gmp ssl +unicode pcre"
-
-RDEPEND="sys-libs/readline
- opengl? ( media-libs/freeglut )
- nls? ( sys-devel/gettext )
- unicode? ( >=dev-libs/icu-2.6 )
- gdbm? ( >=sys-libs/gdbm-1.8.3-r1 )
- gmp? ( >=dev-libs/gmp-4.1.4 )
- ssl? ( dev-libs/openssl )
- pcre? ( dev-libs/libpcre )"
-
-DEPEND="dev-lang/perl[doc?]
- ${RDEPEND}"
-
-src_configure() {
- myconf="--disable-rpath"
- use unicode || myconf+=" --without-icu"
- use ssl || myconf+=" --without-crypto"
- use gdbm || myconf+=" --without-gdbm"
- use nls || myconf+=" --without-gettext"
- use gmp || myconf+=" --without-gmp"
- use opengl || myconf+=" --without-opengl"
- use pcre || myconf+=" --without-pcre"
-
- perl Configure.pl \
- --ccflags="${CFLAGS}" \
- --linkflags="${LDFLAGS}" \
- --prefix="${EPREFIX}"/usr \
- --libdir="${EPREFIX}"/usr/$(get_libdir) \
- --mandir="${EPREFIX}"/usr/share/man \
- --sysconfdir="${EPREFIX}"/etc \
- --sharedstatedir="${EPREFIX}"/var/lib/parrot \
- $myconf || die
-}
-
-src_compile() {
- export LD_LIBRARY_PATH=${LD_LIBRARY_PATH:+$LD_LIBRARY_PATH:}"${S}"/blib/lib
- # occasionally dies in parallel make
- emake -j1 || die
- if use doc ; then
- emake -j1 html || die
- fi
-}
-
-src_test() {
- emake -j1 test || die
-}
-
-src_install() {
- emake -j1 install-dev DESTDIR="${D}" DOC_DIR="${EPREFIX}/usr/share/doc/${PF}" || die
- dodoc CREDITS DONORS.pod PBC_COMPAT PLATFORMS RESPONSIBLE_PARTIES TODO || die
- if use examples; then
- insinto "/usr/share/doc/${PF}/examples"
- doins -r examples/* || die
- fi
- if use doc; then
- insinto "/usr/share/doc/${PF}/editor"
- doins -r editor || die
- cd docs/html
- dohtml -r developer.html DONORS.pod.html index.html ops.html parrotbug.html pdds.html \
- pmc.html tools.html docs src tools || die
- fi
-}
diff --git a/dev-lang/parrot/parrot-3.11.0-r1.ebuild b/dev-lang/parrot/parrot-4.1.0.ebuild
index 46323ccaacbf..bdcf5dada6a4 100644
--- a/dev-lang/parrot/parrot-3.11.0-r1.ebuild
+++ b/dev-lang/parrot/parrot-4.1.0.ebuild
@@ -1,8 +1,11 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/parrot/parrot-3.11.0-r1.ebuild,v 1.1 2011/12/27 06:42:23 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/parrot/parrot-4.1.0.ebuild,v 1.1 2012/03/08 04:18:42 patrick Exp $
-EAPI=4
+EAPI=3
+
+# There's multiple small issues at the moment, so ...
+RESTRICT="test"
inherit eutils multilib
@@ -27,7 +30,10 @@ RDEPEND="sys-libs/readline
DEPEND="dev-lang/perl[doc?]
${RDEPEND}"
-REQUIRED_USE="opengl? ( pcre )"
+src_prepare() {
+ # Fix for #404195 - pcre detection is wonky
+ sed -i 's:libpcre.so.0:libpcre.so.1:' runtime/parrot/library/pcre.pir || die "Couldn't fix pcre location"
+}
src_configure() {
myconf="--disable-rpath"