summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2012-07-08 09:43:42 +0000
committerFabian Groffen <grobian@gentoo.org>2012-07-08 09:43:42 +0000
commit75ef29f36645a0cbc8e1d31371912d717cd0e2b0 (patch)
tree91eda1d76fd00ea1b8e415da7f84378790e17920 /dev-lang/perl
parentia64 stable wrt bug #421565 (diff)
downloadgentoo-2-75ef29f36645a0cbc8e1d31371912d717cd0e2b0.tar.gz
gentoo-2-75ef29f36645a0cbc8e1d31371912d717cd0e2b0.tar.bz2
gentoo-2-75ef29f36645a0cbc8e1d31371912d717cd0e2b0.zip
Adapt library path searching on Prefix for Ubuntu, bug #400839
(Portage version: 2.2.01.20430-prefix/cvs/Darwin i386)
Diffstat (limited to 'dev-lang/perl')
-rw-r--r--dev-lang/perl/ChangeLog6
-rw-r--r--dev-lang/perl/files/eblits/src_configure-v50160001.eblit7
2 files changed, 9 insertions, 4 deletions
diff --git a/dev-lang/perl/ChangeLog b/dev-lang/perl/ChangeLog
index 00074b0b0a87..d3ec6a42ffa3 100644
--- a/dev-lang/perl/ChangeLog
+++ b/dev-lang/perl/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-lang/perl
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/perl/ChangeLog,v 1.384 2012/06/07 06:02:12 tove Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/perl/ChangeLog,v 1.385 2012/07/08 09:43:42 grobian Exp $
+
+ 08 Jul 2012; Fabian Groffen <grobian@gentoo.org>
+ files/eblits/src_configure-v50160001.eblit:
+ Adapt library path searching on Prefix for Ubuntu, bug #400839
07 Jun 2012; Torsten Veller <tove@gentoo.org> perl-5.16.0.ebuild:
Inherit new multiprocessing for makeopts_jobs.
diff --git a/dev-lang/perl/files/eblits/src_configure-v50160001.eblit b/dev-lang/perl/files/eblits/src_configure-v50160001.eblit
index 569312f25b08..00982e9ea0e7 100644
--- a/dev-lang/perl/files/eblits/src_configure-v50160001.eblit
+++ b/dev-lang/perl/files/eblits/src_configure-v50160001.eblit
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/perl/files/eblits/src_configure-v50160001.eblit,v 1.1 2012/06/05 17:52:35 tove Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/perl/files/eblits/src_configure-v50160001.eblit,v 1.2 2012/07/08 09:43:42 grobian Exp $
myconf() {
# the myconf array is declared in src_configure
@@ -82,8 +82,9 @@ eblit-perl-src_configure() {
local llib
local paths=""
echo "int main() {}" > "${T}"/t.c
- # need to ensure dirs contain compatible libs, bug #358875
- for ldir in /lib /usr/lib /lib64 /lib/64 /usr/lib64 /usr/lib/64 /lib32 /usr/lib32 ; do
+ # need to ensure dirs contain compatible libs,
+ # bugs #358875, #400839
+ for ldir in /lib/*-linux-gnu /usr/lib/*-linux-gnu /lib64 /lib/64 /usr/lib64 /usr/lib/64 /lib32 /usr/lib32 /lib /usr/lib ; do
[[ -d ${ldir} ]] || continue
# find a random lib from here
llib=( ${ldir}/*$(get_libname) )